Booting Issue after creating an image


I am currently using OpenSuse 11.3.
After creating an image of sda1 to sda2 with clonezilla my system doesnt boot correctly anymore. i suppose I’ve overwritten some data on sda2 or something even though I am pretty sure that this partition didnt contain any system relevant files as the system was installed to sda1.
When I boot Linux the first error message appearing is
“could not update iceauthority file /home/user/.iceauthority” followed by
“There is a problem with the configuration server. (/usr/lib/GConf/-sanity-check-3 stopped at status 256)” (Probably not the exact message as I translated it from german, original message: "es gibt ein problem mit dem konfigurationsserver. (/usr/lib/GConf/-sanity-check-3 beendet mit status 256
After that I get a third error message, telling me “Nautilus couldnt create the following, needed folder /home/user/Desktop, /home/benutzer/.nautilus” (Nautilus konnte folgende, erforderliche Ordner nicht anleden: /home/benutzer/Desktop, /home/benutzer/.nautilus.)

Before you tell me to google, read on!

I searched for the problem using Google and the board search. Many people had the same error messages, but a completely different source of the problem. Most of them chose to automatically log on whilst having a passworded /home-directory. Also all the people were using Ubuntu. (at least the threads were posted in the Ubuntu forums)
I tried the solutions provided by the guys there, but nothing helped. I tried these solutions
Nach automatischer Anmeldung fehlen Zugriffsrechte - Rechte- und Benutzerverwaltung - Ubuntu-Forum & Kubuntu-Forum |
and some others which are alike to these, but most of the syntax didnt even work. I can log in as root, but after that I e.g. type in “nano /etc/gdm/custom.conf” and the computer replies “nano: command not found” which also happens with several other commands.

So is there still someone with an idea? I hope so! Thanks in advance!

Edit: Forgot to mention: I also already tried to to copy the sda2-image over the sda1-partition. It didn’t change a bit.

It would help if you posted your disk layout with

fdisk -l

You mentioning “…as the system was installed to sda1.” is allmost certainly wrong. Most installations use at least two partitions (Swap and /) and many have three (Swap, / and /home, a recommended configuration). And when your idea about the partitions and their usage before your clonezilla action was wrong, I guess you will understand that your assumption about overwriting things could be very true.

At first glance I thought you may have overwritten /home, especially as you can login as root which doesn’t use /home

But that shouldn’t cause you to have ‘command not found’ for nano … unless of course you didn’t have nano installed, have you tried running any other programs as root, like vi for example?

You’ve not given any info on your partition setup (hence hcw asking for the fdisk -l output) prior to running clonezilla, but ordinarily if you had an existing sda2 one could expect it to exist for a reason such as it having been created for /home, unless you used the custom partition setup the installation would have automatically created a /home partition. To put it another way, unless you purposely created the sda2 partition for such things as keeping backups on it probably would have been used for/by the system and that would explain your problems

Usually a good practice to give all this kind of info when you start a thread asking your question btw, more info you can provide the better people will be able to help you

Thanks for your quick replies you two!

fdisk -l command replies:
(as I have to transcript, I skip the general hdd info (40.0GB, 255 heads, etc as I think it’s unimportant, but if not I can also post that)
Disk identifier: 0x000b3e07

/dev/sda1 Start:1 End:194 Id:82 System: Linux swap / Solaris
Partition 1 does not end on cylinder boundary.
/dev/sda2 Boot: * Start:194 End: 2080 Id: 83 System: Linux
/dev/sda3 Start: 2080 End: 4868 Id: 83 System: Linux

The command vi works and yes it is possible that I don’t have nano installed :smiley: I didn’t know I have to install it, I thought it was a native Linux command or something as the author of the post didn’t mention that you need to have something installed on your system.
Unfortunately I didn’t install the system, so I cant tell if the partition was created on purpose. sda1 was about 15GB and sda2 about 20GB. I wonder if there would be any reason for Linux to automatically create a partition that big, but as I am a complete noob when it comes to Linux I could be terribly wrong…

You do not have to transcript at all. We like the full unabridged input and output of a command and that posted between CODE tags (Posting in Code Tags - A Guide) You should copy/paste to avoid any changes by typos, etc.
When you are afraid of us not being possible to read a foreign language, you can do

LANG=C fdisk -l

And to see what the system thinks those partitions are for, also post

cat /etc/fstab

What I think I can see from your misformed output, I guess that sda1 is the Swap partition, sda2 is the partition where the boot flag is and most probably the / partition.
In that case, when you copied sda1 to sda2, you copied the contents of the Swap to the system. I wonder if in such a situation you will have any change to boot at all!

This starts to giving me the idea that using clonezille something different happened from what you think that you did with clonezilla.

OK, thanks for the Code-Tag tip. The problem is that I can’t copy/paste, because I’m online from another computer. Sorry for making such trouble!
Your interpretation of my misformed output was right, but I just noticed I didn’t copy sda1 to sda2, but sda2 to sda3. It just was a typo in the first post. Seems I’m doing everything wrong today.
Also the output already was in English, so I didn’t had to translate or something. (Or did I misunderstand you at that point?)

Rescue:~ # cat /etc/fstab/
/dev/root / ext2 defaults 0 0
proc /proc proc defaults  0 0
sysfs /sys sysfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

I wrote the code off of the monitor again, but I checked twice for mistakes.

What I noticed when pasting fdisk -l is that sda2 and sda3 have the same Id’s. i don’t know what these Id’s mean, but could that be a problem for Linux?

It is allready a bit better. I will make comments for different subjects.

Can’t you copy paste on the problem system to an USB stick ad then use that for a copy/paste on the posting system? Because all your output until now is strange and your habit to change numbers by accident is not creating much trust with me :frowning:

I guess we can understand an fstab listing in German (better then a corrupted one), but the LANG=C before the command would give it in English.

That is a very strange fstab. There is no entry at all for any disk there.
I will show you mine:

henk@boven:~> cat /etc/fstab
/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part2 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part3 /home                ext4       acl,user_xattr        1 2
/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part1 swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

This is on an 11.4 system, but the difference can’t be great. The first three lines of it show what three disk partitions are used for: one swap, one for* /* and one for* /home*. You have nothing of the kind. Are you sure this is the complete and correct /etc/fstab of the system we talk about?
Also, at installation, what did you decide on the partition scheme of the system, or did you just take al the defaults?

The Id you most probably mean, are the codes given to the partition to denote the type of usage the partition is created for. 82 meaning “Linux swap” and 83 meaning “Linux file system (general)”. Sometimes programs use this r test for it. but mostly they are just reminders for the system manager (you in this case).

In general, I see a dark future for this problem. As you do not know what partitioning you used on installation, do not know how the computer used that partitioning (which is almost the same), do not exactly know what you did with that clonezilla tool, it is even difficult to decide what you wrote over. Let alone what you should restore from your backup (if you have one).

I admit that your fstab-listing looks completely different from mine, but unfortunately that’s all I get. My listing is not even separated with tabs like yours forming a table, it’s put out only separated by spaces. The listing btw already is in english (no matter if i add Lang=c or not)

And to avoid missunderstandings: After having these three error messages the system doesnt start up, it only shows the default desktop background and the cursor, like described by the links I showed. I can only get to the console by starting with the installation-cd and running the rescue system.

Do you mean that the fstab is from the rescue system? We do not need that one, we need the one from your system!

When you are in the rescue system do

mount /dev/sda1 /mnt
ls -l /mnt
cat /mnt/etc/fstab

No need to report all that by retyping. I am interested in any objections by the mount command, if the* ls* command shows a list where etc is one of them and any lines from that fstab which show something about the disk.

What do you mean by “it only shows the default desktop background and the cursor,”. No characters there? What when you hit Esc?

mount /dev/sda1 /mnt
/dev/sda1 looks like swapspace - not mounted

So i tried with sda2 - no objections.

ls -l /mnt
total 116

etc is one of the returned lines

Using these codes my fstab looks similar to yours.

cat /mnt/etc/fstab
/dev/disk/by-id/ata-ST340810A_5FB4PXC3-part1 swap                 swap               defaults                     0 0
/dev/disk/by-id/ata-ST340810A_5FB4PXC3-part2 /                    ext4               acl,user_xattr               1 1
/dev/disk/by-id/ata-ST340810A_5FB4PXC3-part3 /home                ext4               acl,user_xattr               1 2
proc      /proc               proc         defaults           0 0
sysfs     /sys                sysfs        noauto             0 0
debugfs   /sys/kernel/debug   debugfs      noauto             0 0
usbfs     /proc/bus/usb       usbfs        noauto             0 0
devpts    /dev/pts            devpts       mode=0620,gid=5    0 0

What do you mean by “it only shows the default desktop background and the cursor,”. No characters there? What when you hit Esc?

No characters, no taskbar, no reaction when hitting esc. Even when I try to Ctrl-Alt-Del the system returns an error message. The only thing i can do is moving the cursor.

Actually they are important to the system. If the type is wrong, it cannot used for swap or mounted as a data partition as the case may be. But they are correct in his case.

Now we have the fstab of your system and it is clear enough:
. sda1 is the swap space (also reported by your trying to mount it);
. sda2 is your* / partition, all your system files;
. sda3 is your
/home* partition; everything that is personal to all your users (I do not know if you have entered only one or more).
Thus when you copied all of sd2 to *sda3, *you have overwritten all of your end-users data. I do not know if this containts tons of videos, family pictures, music, but it is gone. Together all your KDE configuration and the same for personal configurations of other applications (like FireFox). When you have no backups of this data, it is gone forever. I hope the impact is not to big.

For your system, to find out more about it’s situation, you could try to boot in runlevel 3. For that purpose, when the Grub menu shows, stop the countdown (by using the down arrow and then the up arrow to select the correct entry again), then type the character 3. It should show in the text line on the screen. Then hit Return and let it boot. When this is still working it should end up with a text console and a login prompt. Login using root and the root password (the latter will not echo anything, not even ***). Then type


to see what is mounted. Report if* / *and /home are mentioned there.

Before copying the the partition I checked sda3. Didn’t saw sth important there and also no hint for having system relevant data there (as I only saw some folders I created by myself.

The system starts in runlevel 3. After logging in the system said

Sie haben neue Nachrichten (You have new messages)
Have a lot of fun...

That probably has nothing to do with the problem, but wtf?

Anyways mount does respond sth with /home and /

/dev/sda2 on / type ext4 (rw,acl,user_xattr)

/dev/sda3 on /home type ext4 (rw,acl,user_xattr)

There are also 8 other entries with e.g. proc, fusectl and securityfs.

On 2011-07-13 13:36, Zaibatsu92 wrote:
> What I noticed when pasting fdisk -l is that sda2 and sda3 have the
> same Id’s. i don’t know what these Id’s mean, but could that be a
> problem for Linux?

You did not paste the complete output, so it is not possible to know for
certain. My guess is “yes”.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

@ Robin_Listas
I don’t think it’s a problem anymore, because that was the fdisk output from the rescue system I accidently used as henk explained.

When you saw data on the partition, that should have made you thinking. When that partition would not have been in use for annything, there would have been nothing on it. It probably wouldn’t even have a file system on it and thus you shouldn’t even have been able to mount it and thus to look into it.

The “new messages” is about mails send to root. The system does that to inform root of (potential) problems. Ignore them now.
And for the fun …, no comment from me.

You did not comment about my suggestion of having a backup of the user data, thus I guess you have nothing of the kind.
In that case we are going to recreate the file system that we intend to use for /home. Do not make any typos:

umount /home
mkfs -t ext4 /dev/sda3
mount /home

The second command will take some time. Now we have a clean* /home.*

To recreate your user, type


This will give you the so called ncurses interface to YaST. You can move around there using the Arrow keys and the Tab key. You can select items by using the Return key.
Go down to Security and Users and use Return or Right arrow to go to the right panel.
Go down to User and Group management and use Return to enter it.
Down to your user (is there only one?) then tab to the Delete command and Return.
– Attention, until now I am typing this while doing the same in a terminal window, thus I can see what I do, but I am not going to realy delete a user on my system, thus from now on I cite from memory! —
Do NOT use he feature to delete all users data (there is none anymore and we will not try to run into any problems by YaST trying to remove what is not there).
Finish this using OK functions or what is obvious.

Then go back to User and Group management (I guess you are back there now after the action or else return there in the way described above).
Tab to the Add function and enter your user anew. This will create a new home directory with all the files needed by default.

When ready finish YaST with OK and/or Quit functions, will be obvious.

When back at the normal terminal prompt do

init 5

And see if you get the GUI login and then can login in using your user.

When you have any doubts during this whole rescue process, please ask first and do not destroy more then allready is done :wink:


Please Carlos, that is allready covered above. He means the partition types. Both are 83: Linux for obvious reasons.

Before I delete my user I want to ask which data this action will erase. I guess it’s user specific data like your desktop icons, background and mouse settings, but not program related settings, right?

All of the above is allready deleted by your action with clonezilla.
Desktop icons, mouse settings, background ARE program related settings.

System configurations (which are of course also program related settings) for e.g. your hardware, network, etc. which are mostly in /etc are still there and will not be altered.
Personal settings/configurations for your desktop, Firerfox, Amarok, whatever you have set personaly, but what your wife (when she also had a userid on the system) would have set different, are all gone allready. And you having no backup whatsoever (which you seem to be afraid to admit), they are not restorable other then to start with a fresh user and doing all again.

I get the idea that you have not the slightest idea how a multi user OS like Linux functions. There is a very important boundary between system and users. Users have all their data, that is music, doxuments, etc, but ALSO personal configurations of desktop, programs, etc., in their own place on disk. Every user has such a place. It is called a users home directory. And those home directories are in /home. Thus if you think there is nothing of importance there, your are very wrong. And if you, om that assumption overwrite the complete* /home* using your clonezilla, you removed, let vanish, throw away (yes it is a dead parrot) all and everything of all installed users.

What we are trying to do now is only a bit short of reinstalling the system. Because the system is still there. Even the administration of the users (which is in files like /etc/passwd and /etc/shadow) is still there, but is useless because all files this administration points to are gone.

On 2011-07-14 11:36, Zaibatsu92 wrote:
> Before copying the the partition I checked sda3. Didn’t saw sth
> important there and also no hint for having system relevant data there
> (as I only saw some folders I created by myself.

Your system is still configured to use your disks as they were before the
clonning, so it expects to find in sda3 a home structure. You will have to
rebuild it, and keep using sda2 as the system partition, as it was previously.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)