Booting/Installation error (noob?) System repair #

Hi, Im probally just being a noob here but for the projects sake I thought it would be good to identify this problem. I have an old advent laptop and I tried to install Opensuse from DVD on it. I followed the installation as normal but when I tried to boot it said some sort of check was forced and then I have to enter the admin/root password upon doing this I got the message system repair # in red. I have tried to repair the system through the installation DVD and tried re-installing it but I still get the same message. Any tips guys?

The good message first: welcome to the forum

The bad message: I suspect that your harddisk is broken.

I see, well thanks for the reply. Vista seemed to work ok, i’ll try another re-installation would changing partition settings help in anyway?

Welcome to openSUSE forums.

There is an option to check the media when your disk first boots,you can choose this before choosing to install,

have you done this? and the result.

Some more info about your machine would be useful RAM, video card, etc.

Checking the installation media is good advice. Just in case it reports an error then you have to burn a new DVD and do a fresh install.

But when your media is good then boot your system again as it is. Type the root password when requested. Then type ‘mount’ and <ENTER>. Also try ‘fdisk -l’ (this is a lower case ‘L’). Report what you see. I want to be sure before we do anything else.

i’ll try another re-installation would changing partition settings help in anyway?

Checking the install media is a good place to start, if there is a problem with your download or burning to disk it needs to be fixed first.

I tried checking media and no errors were found, I just tried a fresh install and chose gnome instead of KDE wether that will have any effect I dont know. I will try that when It has finished.

If you end up with a similar error after reinstall, try entering the root password, then


just press enter at any questions, this will help if for some reason the file system appears unclean to the system.

I re-installed it but with a gnome desktop and it seems to have worked fine? Not sure why this is, something to think about. Thanks for your time.

Glad to hear that it works now.

May I ask: how much RAM is installed in this laptop?

988 ram I think not to sure how to check in linux.

To check the RAM type ‘free’ on a command line.

Anyway, I was just curious whether your problem was related to a low RAM machine.

total used free shared buffers cached
Mem: 1012424 617128 395296 0 28572 400228
-/+ buffers/cache: 188328 824096
Swap: 1534168 0 1534168

I’m not sure why this happens.

Sorry guys seemed I spoke to soon, I was using it and it became laggy I had to shut it off by the power button then when it rebooted it loaded but the task bar would not load, just the wallpaper. I forced shut down again and was confonted by the same error checks when trying to boot. I entered the mount and <ENTER> codes and was presented with a few lines of code, I tried the fsck code twice with rebooting and it seems to have worked fine now but seems abit unstable.

Really sounds like your hardware is flaky. Also when you report an error it helps to type the actual error since we can not read over your shoulder. Really find a piece of paper and a pencil and write the error down or take a picture of it. Then we do not have to guess at what you are seeing.

Here are some pictures of the error checks, it seems to run sometimes after doing an fsck check but then sometimes stalls when booting or does not load the desktop. Any ideas? Any ideas on how to fix the hard drive if that is the problem.

P4180048.jpg - P4180053.jpg -

Replace the HDD, reinstall, restore /home from backup media.

That indicate the file system is corrupted. Most likely the Hard drive is dieing. You can test the hard drive with a scan utility from your drive maker.