booting failure

hi there, and thx for answering if you can.

I have installed 13.1 x86_64 on a athlon II alongside with win7. When I started the PC, Grub2 displayed the usual menu and I was able to run both linux and win7, but something went awry, maybe due to win7.

I used to boot linux from a resumed swap partition on a second disk, but this time, the kernel strives to use a wrong swap partition on the primary disk, whatever mode I use (normal or recovery). Moreover at boot time, it complains that is missing, wheras it is present in /lib64. Therefore I’m unable to start opensuse.

From the rescue system, I tried to modify the /etc/default/grub file and run grub2-mkconfig, but it doesn’t work. Is there any way to have a clean change of the grub.cfg file from the rescue sys ?

How to solve the problem ?


ok, no need to answer, I was able to solve the case with a thread below, i.e. remake the initrd.

Thx for reading anyway

It appears I have a similar problem trying to boot Suse 13.1 on a Toshiba laptop, after is has worked fine for several months. Could you refer me to the right thread? Thx

To me it does not seem that you have the same problem.
The original poster made a fresh install.
Your system seems to run for quite some time already.
Probably you should start a new thread in this forum.

Good luck