booting and repairing system

over the last year the grub 2 bootloader was overwritten several times when windows 10 was clean installed or there was a functional update.

so when the bootloader vanished i tried some things to boot my opensuse leap 15.0/15.1:

  • i tried to boot the linux system using installation medium
  • the partition was found as dev/sda3 but you have to choose between dev, UUID, SSID, SATA …
  • you try out all the options it lasts very long but none of the options work
  • i tried to repair the boot loader
  • i started the repair system and expected some kind of simple dialog for common problem solving.
  • there is no dialog, you just have a shell and there is no help available

so here is what i suggest:

give more help to boot installed system. maybe read the menu.lst to find out how the partition is referenced.

provide a dialog when repair system is launched, allow installing a rescue boot loader that is able to start leap.

i like opensuse

regards max

Only users here.

From your description it appears you have installed both openSUSE and Windows using MBR/legacy booting rather then EFI booting. If you use EFI you should not see this problem

Need more info to help

All my MBR PCs, including two with Windows 10™, employ the ancient philosophy stated here, regardless whether or not Windows is installed. When employed, as with UEFI booting, MBR booting via Grub does not depend on the code in the MBR’s code block. The worst Windows can do is change the boot flag. Returning the flag (“repairing”) when necessary is easily done from within Windows™ or from any other type of boot.