Booted into Grub 2.0 instead of openSUSE live dvd menu

I reached the end of my patience with trying to set up ArchLinux on a new computer build I assembled recently. I decided to try openSUSE instead. When I made the live dvd in another computer it seemed to be working fine because I tested it with the other computer and the disc menu came up quickly.

When I tried it on my newly built computer, however, the disc menu does not come up at all. Instead, I get dumped into Grub and I’m not sure what to do. Thinking perhaps it could have been a conflict between the openSUSE live dvd and the remnants of the ArchLinux installation, I rebooted the computer with the ArchLinux live dvd to run cgdisk and delete the partitions. Then I rebooted again with the openSUSE disc and got dumped into Grub again.

So I’m not sure what to try next. Any assistance would be greatly appreciated.

Sometimes DD/CD don’t work between 2 machines because the drives are just a little out of alignment. Is the target machine UEFI?

Yes, the motherboard is currently set to UEFI-only mode although it can also be set to Legacy + UEFI. Shall I try enabling the later?

EDIT: Tried that & it seems to have worked! So far so good…

So apparently the checksum didn’t match? And I downloaded the ISO file directly from the :\

Happens more often then you think with very large files. There is a non-zero error rate when transferring data. Try bitTorrent it is self correcting

And be sure you boot the DVD in UEFI mode from the UEFI boot menu