Bootable usb's only take me to a grub screen with limited capabilities

I downloaded both the Tumbleweed DVD iso and the Live Tumbleweed KDE iso and wrote them to usb drives with dd so they would be bootable. When I go into the BIOS and select to boot from either of these drives, I’m taken to a grub screen with bash-like capabilities.

Why isn’t the Live-KDE or the DVD installer showing up?

Are you using your BBS menu instead of going into the BIOS to make a selection? Are there not at least 2 BBS menu choices (UEFI vs. MBR/Legacy) for either media that you want to boot from? Does this happen regardless which USB port you use?

I don’t know what BBS menu is.

My BIOS gives a choice between the drive or a UEFI partition. I’ve tried both. If I select the drive, it boots from my Nvme drive instead. Which takes me to emergency mode. If I select the UEFI partition it takes me to the grub screen.

USB port doesn’t matter.

I don’t know if this matters, but I was able to boot from a Bitdefender usb drive but I wasn’t able to do anything with that.

I can’t tell you with specificity because you haven’t bothered to tell us anything about the computer you’re trying to put TW on in either of your threads. A search engine should be able to tell you generally. Here is a link that hopefully will tell you how to activate yours, and lead you to whatever your actual BIOS calls it. More info here.

Well first, I’m trying to either reinstall Tumbleweed on a computer that’s been running it for the about the last six years, or fix whatever the problem is that’s causing it boot into emergency mode when I boot normally. I’ve never had a problem before booting from a usb drive by going into the BIOS and selecting that drive.

And why am I given a grub screen when I boot from either usb drive?

Installed another Tumbleweed system on May 4th using this stick:

**erlangen:~ #** lsblk -f /dev/sda 
NAME   FSTYPE  FSVER            LABEL                            UUID                                 FSAVAIL FSUSE% MOUNTPOINTS 
sda    iso9660 Joliet Extension openSUSE-Tumbleweed-NET-x86_6431 2022-05-02-23-54-58-71                               
├─sda1 vfat    FAT16            openSUSE-Tumbleweed-NET-x86_6431 A8BE-B9E6                                            
└─sda2 iso9660 Joliet Extension openSUSE-Tumbleweed-NET-x86_6431 2022-05-02-23-54-58-35                     0   100% /media/openSUSE-Tumbleweed-NET-x86_6431 
**erlangen:~ #**
  • Checked in UEFI: compatibility support module: disabled
  • Inserted stick into USB header
  • Quit UEFI
  • When monitor detected video signal hit F11 to enter UEFI boot menu. Different boards have different keys assigned.
  • Selected stick and readily installed

Did dozen installs based on the above steps. The procedure never failed so far.

I don’t know. If what you really care about is reinstalling TW, download loader and linux from here, save them where Grub can find them, load them with Grub, and perform the NET installation that results. This is my normal installation method for all distros, which originated with SUSE 8.0. Here’s a Grub stanza I use for the purpose with UEFI:

menuentry "Install openSUSE TW via HTTP" {
	search --no-floppy --label --set=root *filesystemlabel*
	linuxefi	/ostw/linux install= hostname=*myhost* ifcfg=*,,"","**" net.ifnames=0 kexec_reboot=0 ipv6.disable=1 video=1440x900@60 XVideo=1680x1050,108 broken.modules=floppy upgrade=1 textmode=1 startshell=1 nomodeset lang=en keytable=us namescheme=by-label 
	initrdefi	/ostw/initrd

Don’t be put off by all those linu line options, about half of which setup static IP in the installation and installed systems. Several I delete at runtime rather than having to remember what to type or look them up if I need them (most that follow the graphics options). They’re all options found here. You don’t need any of them for the YaST NET installer to function.

Paste complete commmad and its output you used to do it.

When I go into the BIOS and select to boot from either of these drives

Are you using BIOS or UEFI boot?

I’m taken to a grub screen with bash-like capabilities.

Show photo of this screen, upload to

Bios screen

Grub screen

There is no network in emergency mode.

As far as arvidjaar’s question about BIOS or UEFI the partitions on the drive are listed as UEFI.

You’re not in emergency mode at the grub menu. The NET installation linux and initrd should do their job if network ever worked on the PC and the NIC is still functional.

This means grub could not find grub.cfg. Do

echo $cmdpath
ls $cmdpath

What is the output?

Well, you did not answer the question how you created this USB stick. Assuming that hd0 is your stick, grub sees one partition on it, while openSUSE installation image should have two partitions. Also, the whole disk should be accessible as ISO9660 filesystem, so error “unknown filesystem” here is unexpected. I certainly can access $cmdpath here after going into grub command line in UEFI. This error also explains why grub stops in CLI.

What is output of “fdisk -l” and “blkid” after you connect USB stick in booted Linux?

The drive was created on a Mac Mini, formatted with FAT file system and then I used the dd command I always use.

dd if=openSUSE-Tumbleweed-DVD-x86_64-Snapshot20220509-Media.iso of=/dev/rdisk4s1 bs=4M status=progress && sync

This has worked before. I’ll do the fdisk cmd next.

Not precise enough information. “like I always use” is not something others know about! Please do not assume that people here can read minds.

And what is the use of “formatting with FAT” (again not clear what is “formatted”, the device of a partition)? When you dd over the device, everything is gone that was there before. Alas for your FAT.

That’s wrong. It puts installation image on the first partition instead of the whole disk. You need to dd to output device /dev/rdisk4 (or whatever disk name for your USB stick is).

This has worked before.

For booting openSUSE installation image? I have my doubts, but of course different firmware may behave differently. Assuming that it can detect nested image inside partition … may be. But that is apparently not what grub expects.

Create installation device using the correct procedure.

You are correct, that’s all it was. And as far as the fact that this has worked before by using a Mac, I obviously got the device name right those times. My ignorance has been EXPOSED.

Aviators rely on checklists for very good reasons. To my experience (since 1976) system administrators frequently claim they never need to do so. I always use one.:wink:


Run dd:
dd if=openSUSE-Leap-15.3-NET-x86_64.iso of=/dev/sdX bs=4M conv=fsync
Double check device name. (some 2 seconds for dd to complete)