Bootable snapshots not bootable on Lenovo W530 i7 3740QM, Nvidia K1000M, SSD 512GB Laptop

Bought a Lenovo W530 i7 3740QM, Nvidia K1000M, Samsung 841 EVO 512GB with preinstalled Windows 7 Professional (OEM).

Working for days 24/7 to get Leap 42.1 correctly working, but at no avail. Yes, I can do normal boot, yes, I can do zypper updates, with/without Nvidia, but …

  1. I could not get Nvidia 361.42 driver working correctly (spuriously not booting, DVI making everything too big)
  2. I could not boot from those bootable snapshots, trying this for days now, literally tried out the whole internet.

Has anybody experience with this? Should I give up with Lenovo W530 + Linux? What is this jungle I have tumbled in?


Hi, the Nvidia Quadro chips seem to give headaches… see a possibly similar thread here:

  1. You have the 361.42 driver that should be OK, but how did you install it? Yours seem an “Optimus” notebook but, as outlined in the thread above, the standard nvidia-bumblebee install is outdated. Did you install suse-prime instead? Or did you install the Nvidia driver “the hard way”? The latter might not be appropriate for your notebook.

  2. WHICH “bootable snapshots”? The Tumbleweed ones? From physical DVD or USB key?
    Booting Tumbleweed snapshots via DVD should work, while USB keys are known to have problems; if the latter, try to burn the image with imagewriter (SUSE Studio Image Writer) available in the OSS repo, then boot with the “kiwi_hybridpersistent=false” option added to the kernel boot line.

Hope This Helps

Thank you very much for your quick answer! Let me just add this briefly …

  1. How installed the 361.42 driver? Well. first added NVIDIA repo via yast2. Then sudo zypper nri (not via yast2, because of famous Leap 42.1 bug with this).

  2. On Leap 42.1 (as well as Tumbleweed) we have btrfs for root partition (dev/sda2) with snapper enabled by default. So there is at least a .snapshots/2/snapshot (under / = root) with description==“after installation” providing kinda fallback if all went down south …

Still 2. You go for system boot, when it comes to the “green screen” you choose from the offered “bootable snapshots”, the last one is No. 2 (“after installation”), hit <ENTER> then you get stuck in this loop, someone had shown exactly this on youtube with tumbleweed, cannot remember URL , sorry.

Still 2. Also tried adding “rootflags=subvol=.snapshots/2/snapshot”, “plymouth.enabled=0”, “noresume”, “nomodeset”, you name it, at no avail. System gets stuck at “nonrandom pool” line, no matter what.

You should always include references and steps you’ve done if you tried to do something and it failed.

Installing nVidia drivers, for most Users

Summarizing the steps in the above link,

  1. Add the nVidia repository
  2. Update your system to install your new drivers and everything else in your system (are you still using the packages in the original LEAP release?), the following command will do it for you
zypper up
  1. Reboot your machine.

As for “bootable snapshots” in the Grub menu during boot, do not choose anything unless you manually modified an entry. Just accept the default selection by waiting or if you click in the screen to pause the boot process, click “enter” in your keyboard to accept default selections and continue. Those snapshots are for emergency recovery should you ever need them. If you did select a bootable snapshot and successfully boot, you may have wiped out your updates, so repeat the above “zypper up” before rebooting again.


AHA … Thanks for your reply, maybe there’s something to go after. Well, firstly, at this moment I have nothing to loose, just checking out things … Secondly, I tried to kinda simulate a recovery, I got it to work on my other Laptop (7 year old Samsung Dual Core) with no issues at all !! URL: . But to be honest, I did NOT “rm -rf /bin/bash” like it is “recommended” in that URL, would that make some difference?

It is absolutely important that you know if this is Optimus device since you have to do things different then a simple NVIDIA card

IMPORTANT NOTICE: the Thinkpad W530 has DEFINITELY an OPTIMUS architecture, see

Please uninstall everything “nvidia” and follow carefully this guide

You are lucky, the 361.28 driver in the default bumblebee install already covers your Quadro K1000M GPU.
Should you still have problems afterward, we are here to help.

BTW, sorry for completely missing your “snapshot” question.

Good catch,
I looked up a different <official> Lenovo technical specs document for this model and it made no mention about Optimus.