Boot to terminal in 13.1

I build a new machine for my MythTV backend. It’s got a Radeon video card built in. I tried using that, but I was having all kinds of trouble with the graphics. So I uninstalled the radeon drivers that were installed by default and shut it down. I installed an old GeForce 7300 card and tried to reboot it to install the drivers. The problem is that when it boots, it goes to the black screen and the monitors stops seeing the computer (monitor light goes amber). So I figured I’d boot to runlevel 3. The problem is that in 13.1, or maybe with my puny monitor, I don’t have an option line at the bottom the enter the runlevel. All I have is:
OpenSUSE 13.1
Advanced options for OpenSUSE.

I installed via a USB stick, but I can’t use that to change the boot options. If that’s in and I get to the install menu, when I try to “Boot to hard drive”, the machine beeps and reloads the install menu. That’s a different issue though, and I don’t care about it.

I’m trying to figure out how to get my machine to boot to runlevel 3. Any suggestions?

BTW, I’m using an old flatscreen (4:3), and I think it’s defaulting to 800x600. So the option line may be there, but I can’t see it or navigate to it.

My plan is to boot to runlevel 3 so I can install the NVIDIA drivers.

On 2014-02-20 21:46, Yippee38 wrote:
> So I figured I’d boot
> to runlevel 3. The problem is that in 13.1, or maybe with my puny
> monitor, I don’t have an option line at the bottom the enter the
> runlevel. All I have is:
> OpenSUSE 13.1
> Advanced options for OpenSUSE.

Press ‘e’ for edit. Find the line starting with “linux”. Add a ‘3’ at
the end of it. Accept and boot.

From memory.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Instead, go to Advanced options, then choose Recovery mode (2nd line, I believe).

This should boot you up into openSUSE, where you can install the appropriate nVidia driver for the card using Yast, in your case the G02 version, I believe.

That should do it.

Second line works, but when I go into software, it shows the nouveau drivers already installed. I’ll try both methods though.

Yes, and the nouveau drivers are not the ones you want.

You want the proprietary nVidia drivers from the openSUSE repos.

Yeah. I know. The nouveau drivers were installed by default.

I screwed something up and now it won’t boot.

I tried re-installing from scratch since I haven’t done anything with the system. I keep getting a “doesn’t support dpo or fua” message and I can’t do anything from there. Not sure what to do now.


That message can pop up when a filesystem requests a force unit access.

Let’s start again, but clean. I am assuming this is no dual-boot setup, and nothing on the disk is important at this point.

If that is correct, let’s clear the disk.

Before proceeding, please read this entire post.

Boot with the install key. 3rd item down should be “Rescue System”. Click on that and wait for it to load.

It will stop with the line

Rescue login:

Type (without the quotes) “root” then press Enter.

You will now see the prompt, probably in a red font:



fdisk -l

This will list your drives and partitions. Double-check which is the drive that you want to install on to make certain you will be using the right drive and right partitions when you run commands on the disk.

I suspect it will be sda, but please be sure. You are about to blow the partitions away.



You will now have a prompt:


select /dev/sda

(Whether you select /dev/sda or sdb depends on which drive you determined it to be when you ran fdisk above. Where I put sda in these commands, you put whatever matches the drive you are installing to.)


mklabel msdos

You have no partitions, now. When this command is confirmed, do


You will be back at the Rescue:~# prompt.



And start the openSUSE installation, creating and formatting new partitions.

(Tip: Choose to use a different password for root than for user, that is when setting your user password deselect “Use this password for system administrator”, and deselect “Automatic Login”. This is much more secure, and one day you will probably be glad you did it this way. You can select “Receive System Mail”.)

Also, do not do any updates during the install, choose to skip updates, leave them for afterwards.

Once it is installing the packages, do not disappear. When it gets to about 80%, watch for the first reboot.

On first reboot (if you recall, there is still some setup to go), you will want to choose the Boot from HD option.

When you get to the Grub menu, go to the Advanced options and choose the Recovery mode. This will not cause any problems with the installation, but when it gets to the login screen after the final setup, you will be in a graphics mode that will allow you to login to KDE and do some additional setup. Do not log in as root, but as your User.

Once in there, start by launching Yast (it will ask for the root password), then choose Online Update. Accept, wait awhile (grin).

If at any time during the updates you are required to reboot (a very rare thing in Linux, but does sometimes happen), make certain you boot again in the Recovery mode.

Once all updates are in, use the Software Manager in Yast to install the correct nVidia driver.

Do Not uninstall the nouveau driver at this point. Instead, just install the nVidia driver and its dependencies. This install should automatically blacklist the nouveau driver, so you have no need to bother touching the nouveau.

After the nVidia driver is installed, you should be able to power down and boot normally.

Good luck, keep me posted.

Thanks for the detailed post! It will be a few days before I can run through this though (working a ton).

OK, now how do I make it ALWAYS boot in runlevel 3? (I used to edit inittab, but that no longer seems to work.)

Sorry it’s taken me so long to reply. I had to work, then we went on a cruise, then I had to work again. I finally had a chance to try this today.

The quoted part is as far as I got. I selected “Rescue System” and got the little pop-up window showing “Loading Kernel” with a progress bar. Then the screen went black and I got the “doesn’t support dpo or fua” message.

A little background info… This is a new machine. I’m putting it in an old case. The case has two optical drives, but they are both PATA. The motherboard doesn’t have any PATA ports, so I figured I’d try to do a network install over the internet from a USB stick. The machine has disk drives in it, but because I wanted to see how OpenSUSE recommended I partitioned the main drive, I disconnected the two storage drives for the install. My plan was to connect and partition them once OpenSUSE was up and running. The drive I’m using as the system drive has been formatted previously. When I did the install, I partitioned it and formatted those partitions (I always do that if I’m repartitioning) using (I think) ext4 except for the Swap partition, of course.

I’m thinking that maybe I’ll need to wipe the partitions from the disk drive somehow before the re-install will work. I have one of those external USB drive adapter cables. Should I try that? Just repartition it to one large fat32, then try the install again?

On 2014-03-05 03:26, ktrudahl wrote:
> OK, now how do I make it ALWAYS boot in runlevel 3? (I used to edit
> inittab, but that no longer seems to work.)

> Telcontar:~ # l /etc/systemd/system/
> lrwxrwxrwx 1 root root 40 Jun  7  2013 /etc/systemd/system/ -> /usr/lib/systemd/system/
> Telcontar:~ #

Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

I connected the drive to my Windows7 machine and deleted all partitions. Then I created a partition without formatting it. I tried again. Same **** “doesn’t support dpo or fua” message.

Any other suggestions?

I’ve tried searching the web, but all of the results I’ve found are for people who’s drives are working, but not 100% correctly. I don’t even know what DPO or FUA are other than Disable Page Out and Forced Unit Access.

On 2014-03-10 17:46, Yippee38 wrote:
> doesn’t support dpo or fua

All my disks produce that message. Some have been in this same machine
for years, one only about a week or two. I have no idea what it means,
but my machine works the same as it always did.

The message started appearing 2013-05-19. The disk that produced that
message that day was actually my mobile phone internal flash “disk”! Via

Eventually all my disks produced that message. I can investigate if they
started with some kernel update, but not now (I’m about to go to bed).

Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)