Boot to a blank screen

XFCE used. Something has changed. I boot to a blank screen, If I <ENTER> I get a CLI login prompt and I can log in as user. I invoke startx and it tells me that the keyring was not unlocked at login. I enter the password and the GUI opens. How do I go back to how it worked before?
Thanks in advance.

Cancel previous post. Incorrectly reported.

Sorry. I was a little mixed up.

XFCE used. Something has changed. My default boot starts a blank screen with no keyboard response. Then I boot in recovery mode to a blank screen. Entering <CTL> <ALT> <1> and then <ENTER> I get a CLI login prompt and I can log in as user. I invoke startx and it tells me that the keyring was not unlocked at login. I enter the password and the GUI opens. How do I go back to how it worked before?
Thanks in advance.

Three days ago I installed a different graphics card and it has worked. But today when I invoked lsmod it did not find the nouveau driver I normally use. No nvidia driver either. I believe the nouveau driver is now built into the kernel. So how do I go about getting it back?
Thanks in advance.

Please provide output from:

sudo zypper se -s nel-def | susepaste

Thanks for the assistance.

Pasted as:
https://susepaste.org/15128342
https://paste.opensuse.org/15128342

I meant for it to be sudo zypper se -si nel-def | susepaste, but that’s OK, just more than I needed to see.

sudo zypper in kernel-default-extra

along with regeneration of initrd should fix this. I don’t remember whether adding kernel-default-extra on its own does the regeneration, though it probably does. Upgrades from 15.2 to 15.3 fail to pick up on the movement of the nouveau kernel module from the kernel-default package into the new-for-15.3 (from SLE) package kernel-default-extra.

Did that. It stopped booting at

Started : Local service

and would not accept any keyboard input.

Is that what happened booting after following the instruction, or won’t it let you follow the instruction?

If it wouldn’t let you follow the instruction, try booting using one of the Grub advanced boot options, e.g. failsafe, or strike the E key at the Grub menu on the default entry and append space 3 to the end of the linu line before proceeding with boot. Then when boot completes, do:

cat /var/log/Xorg.0.log.old | susepaste

and provide the resulting URL here.

After some delay I was able to get to a CLI and apply the instuction.

Pasted as:
https://susepaste.org/49819347
https://paste.opensuse.org/49819347

Why are you using kernel 5.16.2-lp153.8-default from December? Please provide ouput from:

sudo zypper se -si kernel dm
inxi -Gxx

Nouveau DDX is in use. No problem is apparent from the uploaded Xorg.0.log. It shows display is using 1280x1024 mode. Please provide output from:

sudo journalctl -b | grep aile

What was your display manager before this problem of a blank screen came up?

Pasted as:
https://susepaste.org/94705604
https://paste.opensuse.org/94705604

I can’t say since I don’t backup my /etc.

Can this be your problem, taken from your susepaste:

Feb 22 10:14:45 ion-a960d systemd-xdg-autostart-generator[1910]: Opening  /var/lib/lightdm/.config/autostart failed, ignoring: Permission denied

Can’t check my xfce for that error, I am using SDDM.

Well the file in question does not exist probably because the change content permission is set to “only owner” who is root. I will changer that to include users and see what happens.

Before doing that go to yast2 alternatives and look for lightdm set it to auto.
See if it will help. Make it your default display manager

Did both of the above and then…

:~> sudo cat /etc/sysconfig/displaymanager

## Type:        string(Xorg)
## Path:        Desktop/Display manager
## Default:     "Xorg"
#
DISPLAYMANAGER_XSERVER="Xorg"
## Path:    Desktop/Display manager
## Description:    settings to generate a proper displaymanager config


## Type:    string(kdm,xdm,gdm,wdm,entrance,console,lightdm,sddm)
## Default:    ""
#
# Here you can set the default Display manager (kdm/xdm/gdm/wdm/entrance/console).
# all changes in this file require a restart of the displaymanager
#
DISPLAYMANAGER="lightdm"="yes"


## Type:    yesno
## Default:    no
#
# Allow remote access (XDMCP) to your display manager (xdm/kdm/gdm). Please note
# that a modified kdm or xdm configuration, e.g. by KDE control center
# will not be changed. For gdm, values will be updated after change.
# XDMCP service should run only on trusted networks and you have to disable
# firewall for interfaces, where you want to provide this service.
#
DISPLAYMANAGER_REMOTE_ACCESS="no"


## Type:    yesno
## Default:    no
#
# Allow remote access of the user root to your display manager. Note
# that root can never login if DISPLAYMANAGER_SHUTDOWN is "auto" and
# System/Security/Permissions/PERMISSION_SECURITY is "paranoid"
#
DISPLAYMANAGER_ROOT_LOGIN_REMOTE="no"


## Type:    yesno
## Default:    yes
#
# Let the displaymanager start a local Xserver.
# Set to "no" for remote-access only.
# Set to "no" on architectures without any Xserver (e.g. s390/s390x).
#
DISPLAYMANAGER_STARTS_XSERVER="yes"


## Type:        yesno
## Default:     no
#
# TCP port 6000 of Xserver. When set to "no" (default) Xserver is
# started with "-nolisten tcp". Only set this to "yes" if you really
# need to. Remote X service should run only on trusted networks and
# you have to disable firewall for interfaces, where you want to
# provide this service. Use ssh X11 port forwarding whenever possible.
#
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="no"


## Type:    string
## Default:
#
# Define the user whom should get logged in without request. If string
# is empty, display standard login dialog.
#
DISPLAYMANAGER_AUTOLOGIN=""


## Type:        yesno
## Default:     no
#
# Allow all users to login without password, but ask for the user, if
# DISPLAYMANAGER_AUTOLOGIN is empty.
#
DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"


## Type:        yesno
## Default:     no
#
# Display a combobox for Active Directory domains.
#
DISPLAYMANAGER_AD_INTEGRATION="no"


## Type:    list(root,all,none,auto)
## Default: auto
#
# Determine who will be able to shutdown or reboot the system in kdm.  Valid
# values are: "root" (only root can shutdown), "all" (everybody can shutdown),
# "none" (nobody can shutdown from displaymanager), "auto" (follow
# System/Security/Permissions/PERMISSION_SECURITY to decide: "easy local" is
# equal to "all", everything else is equal to "root").  gdm respects the
# PolicyKit settings for ConsoleKit. Shutdown configuration can be done via
# the polkit-default-privs mechanism.
#
DISPLAYMANAGER_SHUTDOWN="root"
ion@ion-a960d:~> sudo cat /etc/sysconfig/displaymanager
## Type:        string(Xorg)
## Path:        Desktop/Display manager
## Default:     "Xorg"
#
DISPLAYMANAGER_XSERVER="Xorg"
## Path:    Desktop/Display manager
## Description:    settings to generate a proper displaymanager config


## Type:    string(kdm,xdm,gdm,wdm,entrance,console,lightdm,sddm)
## Default:    ""
#
# Here you can set the default Display manager (kdm/xdm/gdm/wdm/entrance/console).
# all changes in this file require a restart of the displaymanager
#
DISPLAYMANAGER="lightdm"="yes"


## Type:    yesno
## Default:    no
#
# Allow remote access (XDMCP) to your display manager (xdm/kdm/gdm). Please note
# that a modified kdm or xdm configuration, e.g. by KDE control center
# will not be changed. For gdm, values will be updated after change.
# XDMCP service should run only on trusted networks and you have to disable
# firewall for interfaces, where you want to provide this service.
#
DISPLAYMANAGER_REMOTE_ACCESS="no"


## Type:    yesno
## Default:    no
#
# Allow remote access of the user root to your display manager. Note
# that root can never login if DISPLAYMANAGER_SHUTDOWN is "auto" and
# System/Security/Permissions/PERMISSION_SECURITY is "paranoid"
#
DISPLAYMANAGER_ROOT_LOGIN_REMOTE="no"


## Type:    yesno
## Default:    yes
#
# Let the displaymanager start a local Xserver.
# Set to "no" for remote-access only.
# Set to "no" on architectures without any Xserver (e.g. s390/s390x).
#
DISPLAYMANAGER_STARTS_XSERVER="yes"


## Type:        yesno
## Default:     no
#
# TCP port 6000 of Xserver. When set to "no" (default) Xserver is
# started with "-nolisten tcp". Only set this to "yes" if you really
# need to. Remote X service should run only on trusted networks and
# you have to disable firewall for interfaces, where you want to
# provide this service. Use ssh X11 port forwarding whenever possible.
#
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="no"


## Type:    string
## Default:
#
# Define the user whom should get logged in without request. If string
# is empty, display standard login dialog.
#
DISPLAYMANAGER_AUTOLOGIN=""


## Type:        yesno
## Default:     no
#
# Allow all users to login without password, but ask for the user, if
# DISPLAYMANAGER_AUTOLOGIN is empty.
#
DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"


## Type:        yesno
## Default:     no
#
# Display a combobox for Active Directory domains.
#
DISPLAYMANAGER_AD_INTEGRATION="no"


## Type:    list(root,all,none,auto)
## Default: auto
#
# Determine who will be able to shutdown or reboot the system in kdm.  Valid
# values are: "root" (only root can shutdown), "all" (everybody can shutdown),
# "none" (nobody can shutdown from displaymanager), "auto" (follow
# System/Security/Permissions/PERMISSION_SECURITY to decide: "easy local" is
# equal to "all", everything else is equal to "root").  gdm respects the
# PolicyKit settings for ConsoleKit. Shutdown configuration can be done via
# the polkit-default-privs mechanism.
#
DISPLAYMANAGER_SHUTDOWN="root"



Nothing changed.

You did it by hand? Follow this guide:
https://en.opensuse.org/SDB:Change_Display_Manager
You are in leap 15.3 right? Is that the kernel version for leap 15.3 that you are using?

Thanks to all for the help, but now I get a total lock up after a few minutes with the hard drive light on all the time and only switching off the power gets me out of it. Fortunately I can boot another O.S. on the same drive until I decide on a solution. I apologize if I haven’t been patient enough, but it has occupied much of my time. Thanks again.