Boot times have increased since first install.

I installed 11.2 over Christmas and was quite impressed with how quick it booted. However I’ve noticed that the boot time has increased considerably since then.

From selecting oS in Grub it takes 20s to the login screen. Not too bad.
From login screen it takes 52s to get to the desktop. This is a little long IMO and used to be much quicker, i.e circa 15s.

I looked through dmesg but it’s difficult to see where the login screen gets presented so I can see what happens after than.

Below are snippets from the dmesg output where I have identified gaps in the times.

I assume this gap is where I logged in?

18.762664] 0000:02:00.0: eth0: 10/100 speed: disabling TSO
18.763160] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
21.220966] NET: Registered protocol family 17
27.125472] vboxdrv: Trying to deactivate the NMI watchdog permanently…
27.125477] vboxdrv: Successfully done.
27.125480] vboxdrv: Found 2 processor cores.
27.126199] vboxdrv: fAsync=1 offMin=0x8089a offMax=0x8089a
27.126953] vboxdrv: TSC mode is ‘asynchronous’, kernel timer mode is 'normal

Big gap here with NFS

32.014373] Slow work thread pool: Starting up
32.014644] Slow work thread pool: Ready
32.014704] FS-Cache: Loaded
32.045813] FS-Cache: Netfs ‘nfs’ registered for caching
56.250191] BIOS EDD facility v0.16 2004-Jun-25, 2 devices found
58.556888] Bluetooth: L2CAP ver 2.13
58.556903] Bluetooth: L2CAP socket layer initialized

A few 4 to 5s gaps

68.576113] Bluetooth: SCO (Voice Link) ver 0.6
68.576134] Bluetooth: SCO socket layer initialized
72.580447] Bluetooth: RFCOMM TTY layer initialized
72.580473] Bluetooth: RFCOMM socket layer initialized
72.580487] Bluetooth: RFCOMM ver 1.11
83.031311] iwl3945 0000:03:00.0: firmware: requesting iwlwifi-3945-2.ucode
83.051149] iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
83.116662] Registered led device: iwl-phy0::radio
83.116742] Registered led device: iwl-phy0::assoc
83.116773] Registered led device: iwl-phy0::RX
83.116803] Registered led device: iwl-phy0::TX
83.121866] ADDRCONF(NETDEV_UP): wlan0: link is not ready
88.295458] EXT4-fs (sdb1): barriers enabled
88.332370] kjournald2 starting: pid 4610, dev sdb1:8, commit interval 5 seconds

Then a huge gap after mounting the external usb drive.

88.333987] EXT4-fs: mballoc enabled
88.334214] EXT4-fs (sdb1): mounted filesystem with ordered data mode
122.397572] Registered led device: iwl-phy0::radio
122.398124] Registered led device: iwl-phy0::assoc
122.398212] Registered led device: iwl-phy0::RX
122.398442] Registered led device: iwl-phy0::TX

I’m pretty much running the same setup as I did when I had 11.1 installed so all processes and services would be similar. My old 11.1 installation didn’t take anywhere near 52s to get to the desktop.

Any ideas what I can do to improve things?

You could maybe try running bootchart, it gives a nice graphical chart of what happens at boot time.

It’s available from the standard oss repo, here’s it’s description -

bootchart - Boot Process Charting Application
 bootchart patches your boot process and allows it to giva a graphical representation of what processes are running during the boot process.

Thanks I’ll try that and see what come ups during the next boot.

As you explain yourself, your boottime is still the same. It is your login that takes more time. So imho it is of no use to use tools measuring the boot process (though might be very interesting). I also doubt if the processes started on the users behalf because (s)he logs in is reflected much in dmesg, which is more of a system logging.

That your login takes more time can be due to you having more applics start up at desktop initialisation, etc. Do all the users experience these longer log in times? Or do you have only one user? Then you could create a new user and see what his login times are so you can compare between an initial desktop and one which is modified by the user.

suse tpx60s wrote:
> I installed 11.2 over Christmas and was quite impressed with how quick
> it booted. However I’ve noticed that the boot time has increased
> considerably since then.
>
> From selecting oS in Grub it takes 20s to the login screen. Not too
> bad.
> From login screen it takes 52s to get to the desktop. This is a little
> long IMO and used to be much quicker, i.e circa 15s.
> [snip]

ok, your login screen to desktop time went from 15 seconds to 52
seconds…i wonder if you did any customizations between the time it
took about 15 seconds to today?

like maybe:

-add programs to the system
-changed to more complex background
-changed transparency setting
-implemented changes needed to get 3D actions
-etc etc etc etc

see, everything YOU do to add to your desktop changes what the
system (which still boots in about 20 seconds) has to do to find the
bits on the hard drive for the various tweaks, and reads them to
memory, calculate which pixels need to be which color and then display
it…

> Any ideas what I can do to improve things?

take out all your ‘tweaks’ to make the desktop look the way you want
it, and remove all the programs you added, and . . . etc

it is kinda like: you love the performance of your new sports car,
then decide to fill it with lead weights and . . .


palladium

I am also having the same issue (with 11.2, and previously with 11.1 too).

I have quite a powerful machine (thinkpad T61, core 2 duo 2.20 Ghz) and the boot time is just unbelievable : 4 min !!!

The bootchart is almost unreadable : Free - Envoyez vos documents.
Is it very weired (so many processes taking so long) or is it that I just don’t understand how to read the chart ???

I repeat! Make clear if we are talking here about the time it takes to BOOT, which is until you reach runlevel 5 (in most cases).

Or if we are talking about the time it takes from a user firing of his username/password in the login screen until his DE is full available.

These are very different things. The first one is about the system, loading modules in the kernel, starting of deamons. The second one is about what the user has defined as all the niceties that should be in place for his daily needs. I e.g. start Kontact with Kmail, Kaddressbook, Kalender and Akregator right from the beginning. Often Amarok is there from last session and may be more. That takes time. Has nothing to do with boot. Has to be done when II logout and login again regardless if I boot or not. My wife has a complete different approach and her login time will be different, but not ‘her’ (the systems) boot time.

First decide where you want to do/measure something about performance and the decide which tools you need.

Sadly you didn’t look at the bootchart I attached.
Clearly the stuff that it is taking the longest is opening the Gnome session.
Ok, it is totally different from the kernel init, but it is still part of the boot process of a desktop user.

sorry, i’m not smart enough to figure out how to see that chart (can’t
read french) and even if i could i still wouldn’t be able to
help…but, i can tell you that you have some problems if it take four
minutes to boot…

hopefully a french and bootchart reading openSUSE guru will look in…


palladium

Sorry, I didn’t realize that I didn’t give the direct link (there seem to be some issue with the service I used).

So there it is :
http://www.phocean.net/bootchart.png

For the rest, it is just a plain english bootchart.

you are missing Henk’s main point:

you boot an operating system and THEN start up a desktop environment…

meaning suse_tpx60s’ boot time has NOT increased, but his time to
start up his desktop has (most likey directly due to the decisions he
made in setting up his desktop)

your problem (if i understand your reading of a bootchart i can’t
open) is also during the start up your desktop (Gnome)…which, as
Henk and i have pointed out, will take different folks different
amounts of time depending on how they have their desktop setup…

simplify your desktop and you will decrease the time it take to start
it up…


palladium

That link gives an Error 403 Access forbidden!

I did got the point.
I repeat too, it still part of the boot process, so I don’t understand why you have a problem with it.

Simplify my desktop ?
Not a good answer neither. I have been around with Gnome for years and, though it is something what I could call speedy, it is the first time I see such a behaviour.
Morever, I don’t use anything so fancy, and nothing extra than what comes with any fresh installed openSUSE distro.

So I am just curious to understand what can cause the boot time to increase from 1 min to 4 min.

I am also surprised that noone mentioned anything about the shape of the bootchart. It is obvious that there is something wrong. Never seen such a chart before, just look around on charts you can find on many forums.

Actually boot time is what it take to get to the login. If you are auto-logging in you can not count the time to start gnome. It is apples and oranges.

Since other do not see this (I don’t though I use KDE) It is something you are doing or setup that is causing the slow down. Is there WiFi involved? Do you have a USB drive attached that my be slow to mount? What process are you running? An email server or web server or virus scanners? Are you using AppArmor? Exactly what apps are starting? Have you tried another account with a default desktop? Have you scanned your drives to see if there are any bad or weak sectors? …

Hope you see my point.

Mmm well that does look really strange to me, I’m far from a guru but what is that drop at 155s on disk utilization and throughput. The peak seems ridiculously high to, not apples to apples but mine is 28MBs vs 68MBs(Far removed from a comparison but a relative). This section looks really strange to me, like the disk has gone off line all most(My crude understanding seems to equate it to mono kicking in). My disk util looks like a bunch of flat topped hills yours looks like a wall with a few holes.

Though it seems to be earlier any way i.e like the nearly 10secs before it even starts. Whilst I can see perhaps why you think it is gnome session but even so by the time that has started it is 90secs OK not fast but not exactly 4 mins either.

For example gnome panel looks like it is started at 130s OK still not good but it seems to be another 9 secs for nautilus. Though if gnome session is 90secs, gnome panel 130 secs it then looks like it still took another 29secs before settings got busy on cpu usage.

Any way my tuppence far from knowing but to me it looks like it is waiting in places, or rather consumed with disk activity. As for the why sorry would only be guessing things like swapping come to mind, smart checking the drive, network mounts but all guesses.

OK, in response to hcw and palladiums comments about my problem.

Fair enough my BOOT time looks OK but my time to start the DE is not.

I tried with a new user and that took around 45s to get to the DE from log in. Nothing special was set up with the user.

I did notice though that once I have logged in and then log out and back in (even as a different user) then the DE is loaded and ready in 9s.

So it appear to be only the first time I login after a BOOT that I am experiencing the long start-up of the DE.

I hear what you’re saying about all the settings I may have made to the DE and apps that may be loading for my DE but:

  1. I had exactly the same settings, themes, and apps (actually even more) set up in 11.1 and didn’t get this long start-up of the DE. It was no more than 20-30s.
  2. Even a new user account is taking 40s. So what’s up with that?
  3. After I installed 11.2, the first thing I did was change my theme to what I used in 11.1, set all my Desktop Effects, and installed the ‘can’t be without’ apps and it still loaded the DE in about 15s. I remember as I was quite surprised and happy that it came up so quickly. the slow down seems to have creeped in over the last couple of weeks.

I can’t think of installing anything or setting anything that may be causing the delay unless it’s something that came in with one of the updates to KDE.

I would have to strongly disagree with that notion.

Who on earth turns on their computer and just sits there and looks at the login prompt blinking away?

…white sock and sandle brigade excluded of course :sarcastic:

If someone uses a desktop (which incidentally is a huge part of the openSUSE distribution), then the point where the desktop becomes usable to the user is the end of the “boot” process.

Saying that getting to a login prompt is the end of responsibility of a distro is simply silly, and merely the usual “the end user is to blame cos they’re stupid” response.

Things like the dreaded “desktop search” nasties (nepomuk and his evil friends) can add lots of wasted time, pre-loading versions of Konqueror (check your KDE settings) and other apps will also do that.

Create a new user as a test and see how long it takes to boot when using that account instead.

Thank you for checking. It is already an important thing to know that there is something abnormal and unusual with my DE.
So I am going to seriously investigate about it.
One thing we can exclude for sure is swapping : I have 4 Go of RAM and, even after a few hours of use and several virtual machines running, the swap is still not used.


% swapon -s
Filename				Type		Size	Used	Priority
/dev/mapper/hanshin-swap_1              partition	2097144	0	-1

My issue looks strictly the same, but with the slight difference that I use Gnome… weired.

@suse_tpx60s :
One thing that could be interesting is comparing our bootcharts. Did you generate one ?
It is easy to set up :

  • just install bootchart
  • reboot and at the grub screen, press e to edit and add : init=/sbin/bootchartd
  • then you have a graph in /var/log/bootchart.png