boot time of 13.1

I have the standard 13.1/KDE i586 install of Opensuse. Several computers on my network still run 12.3 and they are booting faster than the one with the 13.1 version. Now I disabled the splash screen during boot and found one difference - the 13.1 version stops for approx 15 seconds on the line “Listening on CUPS Printing Service Sockets.”
I have a network printer installed - the connection is socket://192.168.x.x:9100 and the 192.168.x.x is a fixed IP address.
Any idea why the boot process is stopping at this line - has there anything changed between these versions?
Another thing I noticed - when the server is mounted on this computer and I shut down before unmounting the computer does not finish the shutdown and has to be finished by cutting off the power. But I am not sure how this is with the 12.3 version. I only know that with earlier versions I just shut down and it completed the shutdown. Not any longer.

Have a look at the systemd tools to analyze the true event (it may or may not be that) since things start on demand, in paralell etc.

systemd-analyze blame
systemd-analyze critical-chain
(The following as root user)
journalctl -xb
journalctl -xb --no-pager

Interesting, I don’t get that, but then I’m not using (CUPS) socket activation either. Maybe that has an impact?

Thanks for the replies, deano_ferrari and malcolmlewis
malcolmlewis - these commands have hundreds (thousands) of lines what am I looking for:

uli@linux-top:~> systemd-analyze
Startup finished in 5.531s (kernel) + 56.424s (userspace) = 1min 1.956s
uli@linux-top:~> systemd-analyze blame
          4.845s home.mount
          3.401s dkms_autoinstaller.service
          2.105s postfix.service
          1.888s SuSEfirewall2.service
          1.874s systemd-tmpfiles-clean.service
          1.868s cycle.service
          1.791s systemd-udev-root-symlink.service
          1.581s systemd-fsck@dev-disk-by\x2did-ata\x2dWDC_WD2500BEVT\x2d22ZCT0_WD\x2dWXEY08CR3626\x2dpart7.service
          1.552s kmod-static-nodes.service
          1.373s vboxdrv.service
          1.243s plymouth-start.service
          1.082s vboxadd.service
          1.071s systemd-vconsole-setup.service
          1.065s SuSEfirewall2_init.service
          1.052s ModemManager.service
          1.035s vmtoolsd.service
           924ms xdm.service
           781ms systemd-readahead-replay.service
           779ms dev-hugepages.mount
           776ms systemd-readahead-collect.service
           775ms dev-mqueue.mount
           769ms sys-kernel-debug.mount
           623ms polkit.service
           594ms rpcbind.service
           588ms nagios.service
           569ms systemd-modules-load.service
           569ms systemd-remount-fs.service
           513ms rsyslog.service
           460ms user@1000.service
           451ms apparmor.service
           410ms smb.service
           406ms wpa_supplicant.service
           404ms systemd-readahead-done.service
           387ms NetworkManager.service
           372ms systemd-logind.service
           349ms systemd-backlight@acpi_video0.service
           303ms systemd-sysctl.service
           272ms console-kit-log-system-start.service
           262ms alsa-restore.service
           252ms avahi-daemon.service
           233ms systemd-random-seed.service
           231ms nmb.service
           205ms systemd-tmpfiles-setup.service
           159ms NetworkManager-dispatcher.service
           145ms user@0.service
           126ms systemd-tmpfiles-setup-dev.service
            83ms systemd-user-sessions.service
            76ms udisks2.service
            75ms rc-local.service
            57ms NetworkManager-wait-online.service
            50ms bluetooth.service
            49ms rtkit-daemon.service
            47ms console-kit-daemon.service
            43ms dev-disk-by\x2did-ata\x2dWDC_WD2500BEVT\x2d22ZCT0_WD\x2dWXEY08CR3626\x2dpart5.swap
            41ms systemd-udev-trigger.service
            37ms plymouth-read-write.service
            28ms systemd-update-utmp-runlevel.service
            24ms upower.service
            22ms systemd-journal-flush.service
            21ms systemd-udevd.service
            16ms var-lock.mount
            12ms systemd-update-utmp.service
            11ms var-run.mount
uli@linux-top:~> systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character. @56.395s
└─ @56.394s
  └─nagios.service @55.805s +588ms
    └─cron.service @55.805s
      └─postfix.service @53.699s +2.105s
        └─ @53.697s
          └─ @53.695s
            └─NetworkManager.service @53.248s +387ms
              └─SuSEfirewall2_init.service @52.173s +1.065s
                └─ @52.012s
                  └─ @51.926s
                    └─dbus.socket @51.926s
                      └─ @17.296s
                        └─apparmor.service @16.844s +451ms
                          └─systemd-tmpfiles-setup.service @16.638s +205ms
                            └─ @16.624s
                              └─var-run-vmblock\x2dfuse.mount @52.377s
                                └─var-run.mount @4.407s +11ms
                                  └─ @4.388s
                                    └─systemd-tmpfiles-setup-dev.service @4.260s +126ms
                                      └─kmod-static-nodes.service @2.475s +1.552s
                                        └─systemd-journald.socket @2.472s
                                          └─-.mount @2.468s
                                            └─system.slice @2.485s
                                              └─-.slice @2.484s

The other codes

journalctl -xb
journalctl -xb --no-pager

are even longer. I could get lines out with grep CUPS or similar

So in the blame section, home.mount is taking the longest time (in seconds) the critical chain shows the order in importance, but as you can see cups is not the issue… If not using vbox or plymouth, disable the services. In the case of plymouth, remove the 5 plymouth rpms and then run mkinitrd should knock 5-8 seconds from your boot time. Then run blame again and check.

thanks, malcolmlewis, I removed the plymouth and virtual box which I haven’t used for quite some time. Ran mkinitrd and ran systemd-analyze blame but got exactly the same result. Do I have to reboot?

Yes it is an analysis of the last boot you are looking at with blame

Now it looks like this:

uli@linux-top:~> systemd-analyze blame
          3.943s dkms_autoinstaller.service
          2.572s home.mount
          2.388s SuSEfirewall2_init.service
          1.914s systemd-udev-root-symlink.service
          1.886s cycle.service
          1.565s postfix.service
          1.483s ModemManager.service
          1.411s SuSEfirewall2.service
          1.408s avahi-daemon.service
          1.386s wpa_supplicant.service
          1.371s rsyslog.service
          1.363s systemd-logind.service
          1.354s rpcbind.service
          1.327s kmod-static-nodes.service
          1.204s systemd-vconsole-setup.service
          1.074s xdm.service
           723ms systemd-readahead-collect.service
           723ms systemd-readahead-replay.service
           722ms dev-hugepages.mount
           719ms dev-mqueue.mount
           713ms sys-kernel-debug.mount
           706ms systemd-fsck@dev-disk-by\x2did-ata\x2dWDC_WD2500BEVT\x2d22ZCT0_WD\x2dWXEY08CR3626\x2dpart7.service
           542ms systemd-modules-load.service
           482ms alsa-restore.service
           481ms console-kit-log-system-start.service
           468ms apparmor.service
           423ms nagios.service
           400ms systemd-remount-fs.service
           358ms smb.service
           339ms user@1000.service
           320ms vmtoolsd.service
           265ms systemd-user-sessions.service
           214ms systemd-tmpfiles-setup-dev.service
           210ms systemd-random-seed.service
           183ms nmb.service
           178ms systemd-tmpfiles-setup.service
           172ms systemd-sysctl.service
           104ms NetworkManager.service
            76ms polkit.service
            70ms udisks2.service
            60ms rc-local.service
            54ms console-kit-daemon.service
            54ms bluetooth.service
            49ms NetworkManager-dispatcher.service
            45ms dev-disk-by\x2did-ata\x2dWDC_WD2500BEVT\x2d22ZCT0_WD\x2dWXEY08CR3626\x2dpart5.swap
            44ms sys-fs-fuse-connections.mount
            36ms NetworkManager-wait-online.service
            34ms rtkit-daemon.service
            31ms systemd-udev-trigger.service
            30ms systemd-readahead-done.service
            20ms systemd-hostnamed.service
            20ms upower.service
            17ms systemd-backlight@acpi_video0.service
            14ms systemd-journal-flush.service
            13ms systemd-udevd.service
            13ms systemd-update-utmp-runlevel.service
            10ms var-lock.mount
             9ms systemd-update-utmp.service
             9ms var-run.mount

…and are you still observing the delay you described in your opening post?

I tried after the last post to reboot twice. After GRUB there are a few lines and then the screen remains dark until the login screen comes. No more what is happening and the green OK. So I cannot really compare - I don’t know why that is but otherwise everything seems to be working. I would have to time the boot. Previously I was watching the scrolling text of the boot process and could see where it stops. So at this stage I have no indication where it stops.

The only other service I can see you could disable is vmtoolsd.service

systemctl disable vmtoolsd.service

What is the overall time after a reboot now?


I’m guessing you need the samba, rsyslog and nagios services for monitoring and file sharing. This is a desktop or laptop, are you using a wireless connection via Network Manager? What is the hardware and ram? And how does this hardware compare to the other 12.3 systems?

just did a blame again:

uli@linux-top:~> systemd-analyze blame
          9.494s SuSEfirewall2_init.service
          6.741s postfix.service
          6.121s SuSEfirewall2.service
          5.508s smb.service
          5.244s dkms_autoinstaller.service
          2.099s ModemManager.service
          1.827s cycle.service
          1.659s systemd-udev-root-symlink.service
          1.640s systemd-fsck@dev-disk-by\x2did-ata\x2dWDC_WD2500BEVT\x2d22ZCT0_WD\x2dWXEY08CR3626\x2dpart7.service
          1.256s kmod-static-nodes.service
          1.093s home.mount
           933ms systemd-logind.service
           856ms polkit.service
           823ms NetworkManager.service
           789ms systemd-readahead-replay.service
           787ms dev-hugepages.mount
           787ms systemd-readahead-collect.service
           787ms dev-mqueue.mount
           779ms sys-kernel-debug.mount
           744ms systemd-vconsole-setup.service
           708ms systemd-remount-fs.service
           617ms xdm.service

OK - missed your last post because i posted the first lines of blame with longer times
No I don’t need smb since I have nothing running Windows. I played around with nagios but don’t really need this either. Nagios and virtual box (now uninstalled) did not run on my other laptop. The other laptop has a faster CPU and 4GB RAM versus 2GB here. I watched the speed of boot with the text scrolling past - approx the same scroll speed except the stop described in the first post of this thread. Network connection is via ethernet cable.
I now disabled vmtoolsd.service

Startup finished in 5.386s (kernel) + 1min 3.019s (userspace) = 1min 8.406s

So the smb and nmb services can be diabled and nagios if it still exists, but that may be as good as it gets with your system with 2GB of ram, I’m also guessing a 5400rpm drive? I’m also gussing your using NetworkManager since it’s a laptop, in saying that if the laptop tends to not move location, then consider switch to ifup via YaST Network settings via dhcp or a static ip, gateway and dns addresses required. Oh and if you see the wpa_supplicant service that can be disabled as well.

Thanks malcolmlewis
I don’t know the details of this (you are right) laptop since I got it from my son with Windows not working. It served me well with linux! Turned nagios of at /sbin/chkconfig. How do you turn off smb and nmb services?
Do you know why I don’t see the scrolling text any more -anything to do with plymouth?

They can be turned off with

systemctl stop nmb smb

then permanently disabled with

systemctl disable nmb smb

You should be able to turn off via systemctl

systemctl disable nmb.service
systemctl disable smb.service

Did you try the esc key? Else modifying the bootloader options via YaST can enable this, however this will probably increase the boot time a little, using the journalctl command to check specific things is better and the systemd-analyze command.

Yes, I tried the Esc key - no change. Not important however
Thank you very much malcolmlewis and deano_ferrari. Your help is very much appreciated.