Boot target set to shutdown

Was trying to disable KTorrent from starting automatically (did) not succeed but next day the computer would boot up and immediately shut down.
The boot messages were too fast to immediately understand what was going on and also adding additional options to the grub2 bootline I could not have it stop at a prompt.

Then started an old Mint installation and mounted the openSUSE 13.1 partition. Had a look at /var/log/boot.log but that is pretty brief. I saw there “reached shutdown target” but did not realize what that meant and thought of a hardware or configuration problem. Spend quite some time getting more details in the log files but was not really able.

Eventually found on the Internet “You have set the default target to “shutdown.target” (or similar). So the system immediately boots to shutdown.” [li] and indeed:[/li]
$ ls -als /usr/lib/systemd/system/default.target
0 lrwxrwxrwx 1 root root 16 17 jun 23:01 /usr/lib/systemd/system/default.target -> shutdown.target

Fixed it to graphical.target, rebooted the system and problem solved.

Took me overall quite some time so though let’s (also) post it here.
Still not sure what changed the default target, I even did not know that was possible to do using Yast so I did for sure not do it intentionally.

Well, there are different ways to do that, not only YaST.

This did happen to other people already, mostly when they tried to enable a particular service like mysql apparently.
I’m not aware of (and definitely haven’t noticed myself) any particular bug in this regard.

How exactly did you try to stop ktorrent from starting automatically?
What did you do that it is started automatically in the first place?

Just a hint: KDE by default runs applications at login that were running when you logout. To make a specific application not run at login, make sure you quit it before logging out/shutting down.
You can configure this in “Configure Desktop”->“Startup and Shutdown”->“Session Management”, it’s also possible to exclude specific applications from being started automatically there.

> How exactly did you try to stop ktorrent from starting automatically?

I tried finding it in YaST but could not find it.

> What did you do that it is started automatically in the first place?

Well, very likely what you write “by default runs applications at login that were running when you logout.” Did notice that earlier and that is quite handy but did not realize that also applied here likely because after the KTorrent startup notification nothings indicates KTorrent is still running in the background.

Now stopped it, will check next time.

> This did happen to other people already, mostly when they tried to enable a particular service like mysql apparently.

Yes, maybe that is what I also did.
Funny thing is that I also searched this problem and this forum but could not find it, so maybe somebody with the problem in the future.

Thanks!

You mean YaST->System->Services Manager?
You can only enable/disable system services there. Not programs you run as user…

But you can change the default boot target there, so you probably did that by mistake. :wink:

Did notice that earlier and that is quite handy but did not realize that also applied here likely because after the KTorrent startup notification nothings indicates KTorrent is still running in the background.

KTorrent should show an icon in the system try when it is running, it might be hidden though so you’d have to click on the small up-arrow:
http://wstaw.org/m/2014/10/29/systray.png

Btw, you can configure to “Always show” certain entries or make them “Hidden” in the System Tray Settings->Entries (reachable if you right-click on that small arrow).

I had a look in 13.2 now, and the Services Manager module was changed to only show a select subset of the available boot targets that make sense (no shutdown in particular).
I.e. something like this should not be possible any more in the future. :wink:

On 2014-11-02 14:16, wolfi323 wrote:
>
> marel;2671783 Wrote:
>>> This did happen to other people already, mostly when they tried to
>> enable a particular service like mysql apparently.
>>
>> Yes, maybe that is what I also did.
>> Funny thing is that I also searched this problem and this forum but
>> could not find it, so maybe somebody with the problem in the future.
>>
> I had a look in 13.2 now, and the Services Manager module was changed to
> only show a select subset of the available boot targets that make sense
> (no shutdown in particular).
> I.e. something like this should not be possible any more in the future.
> :wink:

Good! :-))


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)