Boot stucked on tsc calibration (Build with KIWI on VirtualBox guest)

Hello guys,
I’ve create a simple appliance on Suse Studio, containing only JeOS and some stuff in order to build a distro using Kiwi, this appliance is based on openSuse 13.2 (Harlequin) and is actually running on VirtualBox hosted on Windows.
About the VBox image: I’ve installed the original Guest Additions (that one that came with VBox installation) so my kernel is running with all VBox modules.

Ok, in summary here is what I’ve done:

  • Built an Appliance (JeOS) with SuseStudio, exported it and installed it on VBox.
  • Installed VBox Guest additions on my fresh VBox image.
  • Exported that appliance Kiwi configuration and made a build of that config inside my VBox guest, build succeeded!
  • Exported my fresh LiveCD iso to my Windows Host and create a new VBox image using it.
  • Botted (actually tried to… :()

My new LiveCD image stucks on TSC Calibration, and doing a kernel debug i can’t see any error.
I can’t figure out the difference between my build and the one I’ve made with SuseStudio despite kernel differences and I really hope that this is not the problem…
Can you guys help me solving that!

Thanks in advance,

Found the solution!
For some reason Suse Studio was exporting Kiwi configuration to build the image in clic file system, it is possible to choose between clic, seed, overlay and compressed, dunno the difference between them, and so, I’ve picked a choice: overlay.
It worked!

Guys, is it normal to “need” to change between those FSs? Could it be a Virtualization problem? Do I need to get worried about changing the ISO File System?

Thanks in advance,