Boot speed issues in KDE LiveCD

I’m having very strange issues with OpenSUSE 11.3 KDE LiveCD, mainly performance-wise. Most noticeably, it takes 10-30 minutes to actually boot the system, and it doesn’t matter whether the LiveCD is booted from the USB or if it’s install into the hard disk. There aren’t any noticeable errors during boot, though, except a few “timeout” errors and not being able to lauch VirtualBox Guest Additions (which I don’t need since it’s not run from VirtualBox anyway).

It takes the most time during the “scanning USB devices” section if I boot from the USB, and during the state where it detects the network card/assigns an IP. In both cases, every dot that appears there takes around 2 minutes.

During the boot, the PC seems to be mostly idle, and appears to do something only occasinally, when certain parts of the boot sequence are passed, so that makes boot up feel “jumpy” - nothing happens for 10 minutes, then the PC starts accessing the HDD, then nothing happens for 10 more minutes.

There are other performance problems, noticeably during installation to HDD (through the Install option from the CD startup menu - it’s quite a bit faster when started from the running LiveCD). For instance, it takes around 5-10 minutes to make the screen where you need to choose the language and keyboard layout responsive. The performance, in both cases, seems to be inconsistent - sometimes it starts booting and responding quickly, the other times it’s really slow, up to the point of outright hanging.

System specs:
CPU: AMD Phenom II X4 925
4GB RAM
HDD: WD Caviar Black 640 GB
GPU: ATI Radeon HD 4890

I’ll probably add the /var/log/boot.log later.

Were did you get the disk? There should be no reference to Virtualbox in any way from a normal CD. Is this one that may have been optimized to install to a VM???

I’ve got it from the OpenSUSE website itself, KDE x64 LiveCD, Torrent download type.

It could be your CD download. My experience with torrents, the downloads were off in size and never passed checksums. Try downloading your ISO from Kernel.org mirror

http://mirrors2.kernel.org/opensuse/distribution/11.3/iso/openSUSE-11.3-KDE4-LiveCD-i686.iso

"except a few “timeout” errors and not being able to lauch VirtualBox Guest Additions "

A default CD knows nothing about VirtualBox or it’s additions. So why would it complain about loading them? There is something fishy here.

  1. check the checksums
  2. run the media check option.

Be sure you got the image from this page.
software.opensuse.org: Download openSUSE 11.3

I’ve downloaded the Net Install package now and put it on another USB. It seems that it solved most of the problems - the installation was responsive now, and there are no more references to VirtualBox anywhere. However, slow boot times remain, but this time they seem to be isolated to one specific case - the network card. Both boot up and shut down procedures are very slow when it handles the network card, both on setting up the local network and the remote one as well as when shutting them down. It seems that it doesn’t matter if it uses NetworkManager or the classic method.

My network card is integrated Realtek RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC, and the slowdowns weren’t present in OpenSUSE 11.2.

Hmm, second boot and it did boot faster, but now it slowed down in a different area after all. This is my boot.msg right now:
klogd 1.4.1, log source = ksys - GreatEmerald - VNiX03Z8 - Pastebin.com
Somehow it took a long while to activate swap, around 2 minutes, but that’s a whole lot better than I’ve experienced before.

Off hand I’m thinking a hardware problem. most likely the harddrive.
How old is this drive? if it is older than two years and has a lot of hours on it then i would suspect the drive.
I’d run some disk checks to make sure.

It’s one year old now. Could do some diagnostics, but nothing like this has ever happened in OpenSUSE 11.2.
After some more testing, I noticed that now the system is slower at shutting down and booting up, and the speed of boot up and shut down is varying between boots. Sometimes it shuts down normally, the others - takes up to 30 minutes. It seems that it spends the most time at the “Sending all processes the TERM/KILL signal…” step, quite often 5 minutes.
So yea, it does seem quite random…

You have tried the 11.2 cd as it stands now?

I had it installed already, I’m only upgrading my system here, although I’m actually doing a full reinstallation except for the swap partition. There were no problems like that in OpenSUSE 11.2 installed nor Live USB.

Also, I just encountered a shut down where it actually went smoothly, no stops anywhere. So all in all it seems that the slowdowns are completely random.

It does. Seen it before, it has the vbox services enabled, stays like this in installed system, I had to put them off through Yast-System-Runlevel Editor.

I don’t suspect a damaged iso either, would like to know what the behaviour is after install.

I’ve just got something interesting: one time, when it hung up randomly as well, I pressed an arrow key and the log printed “BUG: soft lockup - CPU#2 stuck for 229s! [swapper:0]”. It seems that I can do that any time it hangs like that, too.
This is the full boot.msg:
klogd 1.4.1, log source = ksys - GreatEmerald - 8i2vjnKj - Pastebin.com

Can anyone make anything out of this?

A real mystery, the first klogd has a bunch of kill process, the second looks normal.

Can you run your 11.3 system without any USB devices attached?

Can you also boot to normal but include only one at a time failsafe options? To see if it clears anything?

I’d like to see some of the /var/log/messages from around the time the slow downs start.

Hmm, my keyboard and mouse are both USB, so I might have some problems… But other than that, I have no more USB devices attached right now.
Which failsafe options? From what I’ve tested, they don’t seem to do much, although I didn’t test it extensively. (Side note: why doesn’t the failsafe boot option in GRUB have the ‘failsafe’ boot parameter? It has a whole lot of other parameters, but not the one you’d expect… Hence I couldn’t start X when I had fglrx problems with failsafe boot option, yet it started just fine when I used the ‘failsafe’ switch…)

About /var/log/messages: I guess I can just post all of those. These are from the first boots:
Sep 7 18:51:37 linux kernel: - GreatEmerald - sCVDH46w - Pastebin.com
Still early boots:
Sep 7 22:39:30 linux kernel - GreatEmerald - dfrm66jB - Pastebin.com
This is around the time I fixed fglrx:
Sep 7 23:59:06 linux kernel - GreatEmerald - SjfjYtNT - Pastebin.com
This is after I fixed fglrx and started to work on making alsa/PulseAudio work:
Sep 8 16:30:41 linux kernel: - GreatEmerald - 5J8XMwQc - Pastebin.com
And this is the most recent, just before I managed to fix alsa/PulseAudio:
Sep 8 18:28:35 linux kernel: - GreatEmerald - AWEAyXr5 - Pastebin.com

See if anyone can make any sense from these…
As I said, the slowdowns happen only at boot and at shutdown, randomly. Sometimes it doesn’t even boot correctly at all, just kinda freezes there before it registers the keyboard, but that’s really rare.

Still a mystery but I note in the first 4 message threads there’s significant time gaps around rsyslogd from 5 minute delays to 30 minutes. Its consistent despite the errors for login, flgrx, and pulseaudio. What do you think?

Oh, about login errors, it’s another strange thing - quite rarely, but it does happen that in TTY all input is duplicated, that is, if I try to enter “su”, what gets entered is “ssuu”, but it’s not always the case, too - sometimes it doesn’t duplicate letters, so I usually press a letter, then press backspace, then check if it removed only one or both letters and repeat as necessary. However, naturally that makes logging in impossible. But like I’ve said, it’s fairly rare.

I seems to have fixed the issue (about time, I know :stuck_out_tongue: ), and it seems that it was caused by the BIOS. More specifically, it being horribly broken (resulting in the Qflash tool being absolutely broken - never finds any disks, and when you try to save BIOS to disk, it gives you an empty list where arrow keys move not the line highlight, but a text separator; the Boot Device selection menu always gave me a green square and an accented N letter and nothing else; funny thing is that you wouldn’t notice that unless you enter these tools which are rarely used). So I solved it by flashing my BIOS through @BIOS (like I’ve said, QFlash didn’t work). And now it boots up just as fast as before.
It’s still quite odd why it was different from 11.2 though.

Glad you fixed it. Sometimes one never asks the right questions, like what has changed or did you flash your BIOS.