Boot/reboot issues

  1. Boot takes about 40 seconds. Significantly slower than 13.2 on the same machine. The culprit seems to be wicked. It likes to hang, but I risked trying BTRFS over EXT4 which I used in 13.2. Rebooting/shutdown is painfully slow. I am not sure where to start on this issue. I have no NFS mounted.

  2. I dual boot. Is there a way to get back the boot options on the reboot screen? The slow reboot is bad enough but having to sit through it to manually boot up Windows is annoying to say the least.

  3. Is there a way to remove a incorrect boot option?

The boot lists /dev/sda1 and /dev/sda2 as Windows 7 boot options. They both work but sda1 is just the 100 MB partition that Windows creates. There is nothing in Yast to remove it and stripping it out of /boot/grub/grub.cfg doesn’t work, it just gets rewritten. There is nothing in /etc/default/grub or /etc/grub.d/ that can obviously be removed to clean it up.

Maybe

# rm /boot/grub2/grubenv
  1. Is there a way to remove a incorrect boot option?

The boot lists /dev/sda1 and /dev/sda2 as Windows 7 boot options. They both work but sda1 is just the 100 MB partition that Windows creates. There is nothing in Yast to remove it and stripping it out of /boot/grub/grub.cfg doesn’t work, it just gets rewritten. There is nothing in /etc/default/grub or /etc/grub.d/ that can obviously be removed to clean it up.

You could copy the entry that you like into “/etc/grub.d/40_custom”.

You would then have 3 entries for booting Windows.

After checking that the new entry works, you could then disable the option to probe other operating systems. And then you would only have your added entry.

Removing that file didn’t work. I guess I could try to report it as a regression?

I wasn’t sure how to proceed with editing /etc/grub.d/40_custom. This is what I did and it didn’t show up in the boot menu:

menuentry ‘Win7 (loader) (on /dev/sda2)’ --class windows --class os {
insmod part_msdos
insmod ntfs
set root=‘hd0,msdos2’
if x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2 --hint=‘hd0,msdos2’ 00FAA7A7FAA79804
else
search --no-floppy --fs-uuid --set=root 00FAA7A7FAA79804
fi
chainloader +1
}

It is a copy/paste from the existing boot entry. Any help is appreciated!

Thank you for your response.

That’s because I really didn’t understand the problem you were trying to describe. So I guessed, and my guess must have been wrong.

I wasn’t sure how to proceed with editing /etc/grub.d/40_custom. This is what I did and it didn’t show up in the boot menu:

You did about what I would have done.

It does not have an immediate effect. You need to run:

# grub2-mkconfig -o /boot/grub2/grub.cfg

before it will show up in the menu.

To say it differently: Code involved in booting does not look at 40_custom. It is looked at by the code that us run to generate a new “grub.cfg”.

After running that command, and disable probe foreign OS, at least that minor issue is resolved. Thank you.

It is annoying that GRUB2 all of a sudden doesn’t know about that 100 MB partition and just ignore it, it used to in previous version of opensuse.

What #2 was is that from 13.2 back at least 10 years, on a dual boot machine, after getting the reboot timer popup, clicking it and holding it down would bring up the boot list so you could select what OS to boot into after reboot. It was a very useful function and given how freaking slow shutdown is in Leap(X sometimes hangs for 90 seconds or more on shutdown and if boot up is slow it is always Wicked hanging) it is sorely missed. I guess style over function won yet again. >:(

Is it possible that BTRFS is the cause of the slow boot and shutdowns? I never had the issue with EXT4 and 13.2. Maybe I should have heeded the warnings the BTRFS is years away from being production-ready. Or is this a case of yet again, opensuse moving to a new version of KDE way too early? They did it with KDE 4.0, it is shocking they may have made the same mistake again. Now that I know how to fix some of the issues, a quick reinstall with EXT4 might be the best way to go before going back to 13.2 or finding a more suitable distro.

Anyway, thanks for your help, it is greatly appreciated.

I’ve been staying with “ext4”, so I don’t know what’s the effect of using “btrfs”. However, booting of Leap is slower than booting of 13.2, and 13.2 was slower than 13.1. For shutdown, Leap is slower than 13.2, but 13.2 was usually fast enough at shutdown.

I have not carefully checked the reasons with Leap. For 13.2, it looked to me as if part of the slowish boot had to do with systemd dependencies. (Don’t start service X until service Y is up).

100 meg partition is probably the EFI boot partition foramtted as FAT. Installing can be done 2 ways EFI boot or legacy boot. If you mix them them one OS will not see the other. Both OS’s must use the same boot method.

So you need to be sure to boot the installer in the same mode as the other OS already installed or you will have problems.

Same here:
https://forums.opensuse.org/showthread.php/510878-Long-shutdown

Meanwhile I am also assuming that it is wicked, which is OS’ own (cry)baby.

Ubuntu runs like a flash compared to OS.
Although I am inclined towards OS, I don’t have sufficient spare time to kill to debug wicked.