Boot process freezes after "Started Tell Plymouth To Write Out Runtime Data"

Hi everyone,
I am having trouble booting into OpenSUSE. The boot process fails to mount /var/cache and /tmp, then it hangs after “Started Tell Plymouth To Write Out Runtime Data” indefinitely. It just writes out the following line:

643.280679] systems-journald[1409]: File /run/log/journal/f3b281d6af66b16f0fde50cd5abf3bec/system.journal corrupted or uncleanly shut down, renaming and replacing.

I have tried to boot into a emergency command line by adding init=/bin/bash to the linuxefi line in the boot manager. Df then shows 98% full for the partition mounted to / which might be an issue. But when I try to remount the partition in rw mode to delete some unnecessary files, the system prints out an exception and the command line hangs for any subsequent commands.

Any ideas what can be done to get back a working system?

Hi and welcome to the openSUSE Forums!
Maybe you installed on btrfs file system on a partition too small. To aid us in helping you with more specific advice please add some information.

  1. This thread is labeled “Leap 15.1” (still in beta stage): are you really using this not yet released version or the current 15.0?
  2. Did you install on a btrfs root partition (e.g. accepting the default suggested by the installer?
  3. Can you provide a layout of your disk, for instance booting to the “rescue system” in the install media and copying here the result of:
fdisk -l
  1. or can you boot to another Linux system (multi-boot or live DVD) and see what is going on on the apparently troubled disk?

Hello,
thank you for your response.

  1. You are right, I am running Leap 15.0, I must have misclicked on my phone (I am not sure if I can fix it from a phone though)
  2. Yes, I did install on a btrfs root partition, if I remember correctly, I set the size to 50 GB
  3. Here is the output of fdisk -l (I am rewriting it to my phone, I hope that I did rewrite everything correctly):

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 7063DD9E-880B-46DC-BCF4-8F10D8QY3C0C

Device         Start       End    Sectors    Size Type
/dev/sda2       2048     221183    219136   107M EFI System
/dev/sda5     221184  105078783  104857600    50G Microsoft basic data
/dev/sda6  105078784  138633215   33554432    16G Microsoft basic data
/dev/sda7  138633216 1953517567 1814884352 865.4G Microsoft basic data 

  1. I will try to get a live USB of OpenSUSE, but it will take a while

Nothing obviously wrong in your setup.

  1. That’s important, 15.0 has a default disk layout, 15.1 has another; so we are dealing with the 15.0 we are used to.
  2. It seems that your root partition is /dev/sda5; 50 GB is the recommended size for a standard install, so nothing wrong here apparently.
    To see the real room still available on that filesystem you have to issue (again in the rescue system if you have no other choice at the moment):
btrfs filesystem df /dev/sda5
  1. I assume that /dev/sda6 is a swap partition (if not so, please specify); I assume that /dev/sda7 is your /home (but should not be involved in the problem at hand).
    Maybe you have snapshots enabled (as per default install) and those filled up your root partition.
    I’m no expert in btrfs rescue, so I’m leaving detailed advice to the experts hanging about here :wink:
  1. btrfs filesystem df /dev/sda5 says:
ERROR: not a btrfs filesystem: /dev/sda5

which is weird because I am quite sure it is a btrfs file system.
3) Yes, sda6 is an swap partition, sda7 is /home

I have snapshots enabled and it happened once before that they filled up the entire partition. I managed to find out while the system was running and I was able to delete some snapshots. It is possible that this was again caused by snapper but I have no idea how to delete snapshots without booting.

I have tried to start a live USB but I am getting the following warning a bunch of times:


 170.894074] dracut-initqueue[448]: Warning: dracut-initqueue timeout - starting timeout scripts

Followed by this error:


dracut-initqueue[448]: Warning: Could not boot

Then it switches into emergency mode.

“btrfs filesystem df” takes (mounted) mount point, not device. Actually it probably can be any path on mounted filesystem, not necessary mount point.

I have just found my live USB with GParted and run “check and repair” on the root partition. Now I am able to boot again!

Thank you both for your time. :slight_smile:

Sorry for the wrong hint. As written, i’m not routinely using btrfs here.

Nice to read that.
Maybe you have to check your btrfs now and possibly configure snapper to delete unnecessary snapshots before filling up your partition again.
Ask here if you need help with that.