Boot Problems now XP isnt there after repair Help Please

I have xp and suse 11 on my pc working in dual boot mode.
Has worked fine for the few weeks i have had them installed.
Tonight the pc froze a couple of times, when I rebooted
where it would normally give me the option of xp or Suse all I would get on the screen is Grub repeated over and over so it filled all the screen.

So I put in the Suse 11 disc and selected the automatic repair
it found errors in hda 6 and 7 I think
I clicked repair and then when it checks the bootloader it says if I cant load the item I want then click repair

Once it finished pc rebooted fine into Suse but XP option is no longer there.

When I look at the C drive in Suse my windows install I no longer see files like I was able to to before, I really hope this hasnt screwed up my windows install as I have important stuff on there

Can anyone help me get the xp option back on the grub screen please
thanks

Ive just got this info to see if it helps you see my problem

Disk /dev/sda: 300.0 GB, 300090728448 bytes
255 heads, 63 sectors/track, 36483 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1da41da4

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13676 109844437 7 HPFS/NTFS
/dev/sda2 13676 36483 183205229 f W95 Ext’d (LBA)
/dev/sda5 13676 13937 2104483+ 82 Linux swap / Solaris
/dev/sda6 13938 16548 20972826 83 Linux
/dev/sda7 16549 36483 160127856 83 Linux

and this also

Modified by YaST2. Last modification on Tue Jun 10 13:47:06 BST 2008

default 0
timeout 8
gfxmenu (hd0,5)/boot/message

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0
root (hd0,5)
kernel /boot/vmlinuz root=/dev/disk/by-id/scsi-SATA_Maxtor_6B300S0_B603V32H-part6 splash=silent showopts
initrd /boot/initrd

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.0
root (hd0,5)
kernel /boot/vmlinuz root=/dev/disk/by-id/scsi-SATA_Maxtor_6B300S0_B603V32H-part6 showopts ide=nodma apm=off acpi=off noresume edd=off x11failsafe
initrd /boot/initrd

Try using yast to reconfigure grub. Look under ‘system’ and select ‘Boot Loader’. Then click ‘add’ and select ‘chainloader section’. Call ‘section name’ windows and select the correct partition dev/sda1 in your case. The accept this and reboot. Windows should then be selectable in grub! Hope that helps :slight_smile:

Ill give that a go right now, many thanks for the reply I hope this works :slight_smile:

No problem! Good luck!!

You are an absolute star penguinclaw you have no idea how relieved I am, I did have a back up just not a recent one so Ive just done one :slight_smile:

If I could buy you a pint I would
thankyou again

Glad it worked! If only it was possible to send beer tokens over the internet… now there’s a thought!!! :0