Boot problems in Toshiba L10w-B-102 an Toshiba NB10t

I installed my toshiba notebook L10w-B-102 without problems.
But after installation I cannot boot. I tested secure boot of and on. CSM Boot mode does not exist for this notebook.

I found a workaround for ubuntu on this site
This worked in ubuntu and fedora linux.

In opensuse - which i would prefer - it didn’t work at all. After install, I only get the grub shell!

A little progress I got yesterday:
When I install grub in text mode and made root fs as ext4 instead of brtfs, booting works when I started before bios menu with F2 or “Bios-Boot menu” with F12 on startup. But this is not really satisfactorily.

I would be very grateful if somebody could help me.

I don’t know if it will help, but there’s an old thread dealing with Toshiba UEFI issues:
openSUSE/Windows8 dual boot installation Questions for Secure Boot, UEFI and GPT
It’s a long thread. The solution began to emerge at around post #86 within that thread.

I don’t know if it is still applicable. Toshiba firmware has probably changed since then. My recollection is that F12 during boot didn’t solve the problem back then.

Still, it might be worth the try. And let us know what happens, because there will surely be other people with Toshiba problems.

Dear nricket,

Thank you very much for your reply.

Only copying the files from /boot/efi/EFI/opensuse to /boot/efi/EFI/Boot and rename shin.efi resp. grubx64.efi to bootx64.efi do not work for me. This solution is equivalent to the solution from toshibaonlinux.blogspot I’ve linked. Curiously is that this solution worked for me out of the box in ubuntu and fedora…

also bcdedit /set {bootmgr} \EFI\opensuse\grubx64.efi (resp. shim.efi) did not work

    But I found the following solution:
  • First copy files from /boot/efi/EFI/opensuse to /boot/efi/EFI/Boot
  • rename shin.efi (if seure-boot is on) or grubx64.efi (if secure-boot is off) to bootx64.efi
  • then you have to put Windows Boot Manager with efibootmgr on the first position and inacticate Windows boot manager
    The steps are
    efibootmgr -v —> look which nr. Windows Boot Manager has (usualy 0000)
    efibootmgr -b 0000 -A (for inactivating)
    efibootmgr -o 0000,… (for putting Windows on the first position)

I don’t really understand the solution (I found it on Obviously the firmware change the boot behaviour if Windows is not on first position…

At the moment my system runs with secure-boot disabled. I will try enabling on weekend. But actually I don’t need it (Windows 8 starts also with disabled secure-boot…)

[PS.: mouse left button does not work out of the box. You have to install a instable updated kernel-desktop package from here ( Startin kernel 3.16.7-25 the bug is fixed]