Boot problem

Hi guys,

I cannot boot opensuse since i have problem to load the grub. I’v tried with:

bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi

with secure boot unabled but always start win10.

sorry disabled

We have seen a similar problem before. The last time it was for a Toshiba computer.

The first thing to try: can you get a BIOS boot menu. Often hitting F12 during boot will give you a boot menu. On some computers, it is a different key (I think F9 for HP computers).

On some computers, there are BIOS settings for the boot order (not the disk order, but the UEFI system boot order). One of my computers does that, so I have openSUSE set to be the first in boot order.

The last resort method is to copy the Windows boot files to elsewhere, and then put the openSUSE boot files in their place (giving the Microsoft names). Before we try that, can you try the other possibilities.

If i try in this way I obtain a text like: “Minimal BASH-like line editing is supported.” I’ve never seen this kind of grub. When i use the LEAP 42 version i obtained a different boot, is this a possible error?

I’m not sure what you tried.

If you copied “shim.efi” to replace a Windows boot file, then you also have to copy “grub.efi” and “grub.cfg” to the same directory (the “grub.cfg” from the ‘\EFI\opensuse’ directory in the EFI partition).

Ok sorry i was not clear.

I’ve tried this bcdedit /set {bootmgr} path \EFI\opensuse\shim.efi
I’ve tred to reinstal LEAP 15
I’ve tried with boot repair which i don’t know why always freeze

and when i turn on the pc I always have the grub GNU with minimal bash like line…

This is what you would do to solve some kinds of UEFI problems.

If you were having a UEFI problem, you would not get that “minimal bash” message. You get that message because you at least got as far as grub.

But now, I don’t have nearly enough information on your system to know how to help. I can’t tell if you are booting with UEFI or with traditional MBR booting.

And what happened? What were the last messages before failure occurred?

I’ve tried with boot repair which i don’t know why always freeze
There are several possible causes of freezes, and cmdline options you can append, remove, or edit to allow boot to proceed. Among those to remove (to permit messages to show that might provide clues):

Among those to add:
plymouth=0 # (first thing I would try, along with removing the two above)
nomodeset # (video troubleshooting for the X server mostly; not the first thing to try)

Others are included at:

and when i turn on the pc I always have the grub GNU with minimal bash like line…
Grub has multiple components installed to multiple places. On yours either some component is missing, or some component is in a location that is out of sync with another component. From this bash-like cmdline it should be possible to type in various parameters and eventually cause a boot, but it’s very difficult to understand, and more difficult to explain.

When you are able to get into a rescue boot, provide us with output from the following:

parted -l
lspci -nnk | grep -EiA3 'vga|3d|display'
cat /etc/fstab