Boot problem with a USB device plugged in


I was using Suse 11.0 64b and changed to 11.2 64b some months ago. My laptop is a pretty old Asus A6Km. DSDT of this laptop is broken so I fixed it using Intel’s utility when I installed 11.0. The laptop was booting normally after fixation of the DSDT table. Then I upgraded to 11.2 but computer started to freeze during boot.
I tried several methods.
Acpi=off works as expected.
Acpi=noirq doesn’t work when there is a USB device plugged in during boot.
Acpi=noirq works when there is no USB device plugged in. And after completion of boot process I can plug in USB devices and use them normally. But it is a bit annoying removal of every usb devices and plugging them back in when the boot process is completed.

I regularly update 11.2 hoping that there is a solution but none till now. I don’t know where to check for the problem. Is it a kernel issue or is it a DSDT issue ?

Any advices ?


You might want to check your hard disk boot order setup in your BIOS. It is possible it is trying to boot from the external hard drive even though no operating system is present. I actually have a bootable external hard drive I use on my Dell, but if I set the BIOS to boot from an external hard drive, my laptop will hang at bootup if I have a different USB hard drive attached that has no OS loaded on it. Check your BIOS settings for which device to boot from first and second. Your CDROM should be first and your Internal Hard drive should be second.

Thank You,

Everything in BIOS are in order.
1st boot device : CD/DVD ROM
2nd boot device : Harddisk
3rd boot device : None

I moved Harddisk to 1st place, still no use

Any other ideas ?

Well for Grub to boot, it must know the correct hardware order and actual device names to load your OS correctly. You need to look at your device names sda & sdb. If you can get your PC to boot with the drive attached using any method, I would use the terminal command “df -T” (without the quotes) with the USB drive attached during the boot and not attached during the boot, but connected later. See if there is any difference between the two. Also, if there is any problem reading the external drive for any reason, this can also create a problem. Here is a listing of what “df -T” comes up with on my PC.

james@linux-si8s:~> df -T
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/sdc2     ext4   123854812   8682252 108881108   8% /
udev         tmpfs     4096084       272   4095812   1% /dev
/dev/sdc3     ext4   348602024   1057328 329836652   1% /home
/dev/sda1  fuseblk   312568824  97943048 214625776  32% /Windows/HDC
/dev/sdb1  fuseblk   293035096  67419296 225615800  24% /Windows/HDD
/dev/sdd1  fuseblk   1465136124  20074656 1445061468   2% /Software

Thank You,

I have an older computer and due to RAM constrictions, it won’t install either. How much RAM is on this computer? 512mb is bare minimum…and I do mean BARE. At least 1 GB for a good clean install is essential for any 11.2 install to work well. I have an old Fujitsu-Siemens Amilo laptop and with 512mb 11.2 is not even an option for me. It was not until I added another 512mb stick that the install would even go through. I would certainly check RAM and insure that you have more than 512 for sure. 11.2 is top-heavy for older computers with minimal RAM. Even though I have the RAM for 11.2, I prefer 11.1 myself because to me it fits my needs. Does the system boot properly without the USB device?