Boot problem solved - Multiple distro case

Background: After installing OpenSuse Leap15, the new Distro would not boot.

Hi all. As a long time OpenSuse user you may find yourself in a situation similar to me. You may have a box with multiple hard drives and multiple version of OpenSuse or indeed some other distro. After installing Leap15 I spent many hours trying to diagnose why it would not boot. This command worked wonders - solving my boot problems.

update-bootloader --reinit

But it has to be run by the system that owns Grub2 and the booting process. In my case I needed to run this command while running from OpenSuse 42.3. The command installed the correct boot choices in Grub2 boot menu. At start up, Leap15 - along with other recent and older Distros was then available for booting on this Desktop PC.

Hope his may help someone.

MBR or EFI booting??

show fdisk -l ( use code tags pleas. # in menu)

Not a question or request for help, but a support method. Moving to Unreviewed FAQs.

Thread Closed & moving.

Thread Moved and re-opened.