Boot problem after kernel upgrade (swap encrypted part.)

Hi all,
after applying last kernel upgrade in my 11.2 I can’t boot anymore. I have swap and home partitions encrypted but not root partition. The structure is:

sda1: swap partition (encrypted)
sda2: root partition (not encrypted)
sda3: home partition (encrypted)

This is what happens when I boot the system with this grub option (default):

title openSUSE 11.2
    root (hd0,1)
    kernel /boot/vmlinuz- root=/dev/sda2    resume=/dev/sda1 splash=silent quiet showopts vga=0x317
    initrd /boot/initrd-

  1. Grub boot shows all options ok and then splash screen starts, but stops 2 secs after and shows terminal
  2. Term screen shows:
doing fast boot
Creating device nodes with udev
Only english keyboard layout supported
Please ensure that the password is typed correctly

Then the system asks the password for swap partition and I have to write using the english keyboard layout.

The it asks the password for home partition but it previously shows an error:

Command failed: Can't open device /dev/mapper/cr_sda1 for exclusive read-only access.

Anyway I write the password for /home partition but system doesn’t mount it, so KDE shows an error because there’s no home partition.

The workaround I have found is going to Ctrl+Alt+F1 terminal, and running /etc/init.d/boot.crypto. Then all partitions are mounted and I can start the KDE session.

Any ideas?


Start Yast - System - Runlevels
Go Advanced
Activate boot.crypto

Reboot and you should be OK.

boot.crypto is already activated (B option) and running. Maybe boot.crypto-early? boot.crypto-early is running but is not active.


Sorry, missed the last part, fingers too fast.

What happens if you run ‘mkinitrd’ as root, then reboot?

Yes, it works! Thanks :slight_smile:

Now the only problem is that it keeps using english keyboard layout when asking for swap encryption password and spanish layout when asking for home encryption password. How could I set the spanish keyboard layout at the beginning, just before boot asks me to enter the swap encryption password?


Good you got it starting again.

Can’t help you on the other matter.