Boot order problems after install(13.2 ->15.0)

During a recent install of Leap 15.0( 13.2 -> 15.0, upgrade failed, clean install succeeded), I defaulted the bootloader configuration suggested by the installation program. This is a two-disk machine, legacy boot, built in 2010. Windows7 is on /sda, OpenSuSE on /sdb. The default boot order installed is /sdb, but the BIOS on this motherboard does not seem to allow for a saveable/permanent switch of the boot order, which seems to be hard-coded as /sda. I have to hit F12 at boot, get the boot menu, and there I can select /sdb, but this change is not saved. Annoying, but not impossible.

I went into the bootloader configuration in YaST2 and there is a boot order option there. I changed it to /sda, finished, and rebooted. But nothing had changed, the appropriate GRUB code had not apparently been written to the MBR on /sda. Any suggestions on what I am missing in the bootloader configuration? The BIOS seems hopeless…

Is all of this 64 bit, 13.2 & Windows as well as 15.0? This really sounds like Windows is installed UEFI, incompatible with having Linux in legacy mode even when entirely on a different disk than Windows. It was already common in 2010 for Windows 7 to have been installed UEFI.

Yes, this is all 64-bit. And while it may have already been common for UEFI boot in 2010, this motherboard does not support/require it. Checking my notes from the previous upgrade from 12.3 to 13.2, I think in the 2015 timeframe (possibly earlier) I encountered this same problem, but in that case I seemed to be able to configure the bootloader to write its code to the MBR on /sda rather than to the “/” partition on /sdb. Editing the bootloader disk order in YaST2 seems to make no difference at this point, the code just doesn’t seem to be there in the MBR on /sda, and the BIOS boots to that disk regardless… Previously I upgraded another machine at the same time, with another, and newer motherboard that did support UEFI boot, and everything went smoothly. Just to check, I went into the BIOS again, after reading my previous notes, and yes there is an option for boot order change in the BIOS, but it does not work.

We’re probably going to need to see bootinfocript output to be able to help with this.