boot on Apollo Lake

Hi! Is it possible to install opensuse leap 15 on apollo lake latops?

I tried to disable secure boot and fast boot in boot menu (aptio setup utility) but nothing, opensuse installation program doesn’t start… it appears only a black screen and a white cursor.

Ubuntu and Manjaro can be booted, but I would not change distro.


It certainly should be. What model is the laptop? Is it only Intel, or is there also NVidia or AMD gfx, aka Optimus, in need of special installation instructions (Bumblebee)? The black screen is often avoided so that installation can proceed by using the E key at the openSUSE media boot menu and appending “nomodeset” to the line containing “splash=silent quiet”.

Do you get a startup menu? how did you copy/burn to the install media?

For openSUSE you do not want to modify the iso image at all which can happen with some of the Linux USB install boot helpers. You want a simple binary copy of the ISO to the device (not a partition on the device)

Is there a UEFI Boot Mode option for “UEFI with CSM” (Compatibility Support Module) in the UEFI menu?

  • If there is, enable it …
  • And, after doing that, take a look to see if the boot medium (USB?) can be set to “Legacy” mode …

Sorry, I was wrong… the right soc is Gemini Lake, not Apollo Lake!

What model is the laptop?

E-book pro by Microtech with Ubuntu 18.04 LTS (CPU Intel pentium silver n5000, gpu intel hd graphics 605, ram 8gb, 32 gb eMMC + ssd m2 wd green 240gb. More spec. at 

The black screen is often avoided so that installation can proceed by using the E key at the openSUSE media boot menu and appending “nomodeset” to the line containing “splash=silent quiet”

Boot from USB doesn’t arrive to openSUSE media boot menu

Do you get a startup menu?

No, I don’t.

how did you copy/burn to the install media?

Suse imagewriter

Is there a UEFI Boot Mode option for “UEFI with CSM” (Compatibility Support Module) in the UEFI menu?

There isn’t. (American Megatrends Aptio setup utility 2018)

Linux Kernel support for the Intel Gemini Lake chips became available with version 4.11 …
Therefore, with Leap 15.1 (Kernel version 4.12) it could, possibly, “work out of the box”, once the USB has booted …
Are you absolutely sure that, there’s nothing, anywhere, in the “Boot” section of the Aptio setup related to the USB ports?
The Laptop looks very nice – aluminium instead of plastic case …

According to, Gemini preceded Kaby, on which I have two 42.3s and two 15.0s running OOTB, one on a Gigabyte motherboard, the other Asus. So apparently Gemini & Kaby must have been backported to openSUSE’s 4.4.x kernel and OP shouldn’t need wait on 15.1 (which in alpha is already on the mirrors).

If you don’t even hit a startup menu ( GRUB ), there’s either something wrong with the install medium, or something wrong in the UEFI settings. Also, look for USB Legacy mode in the BIOS.
Another suggestion: download a Leap 15 live image, and use ‘dd’ or Etcher on Ubuntu to create the install disk. My bet would be a failing install stick.

I tried, but nothing changes.

I was reading this
it seems the same problem that I have. In the last post a bug in grub is suggested as cause of the issue, but I don’t know how to apply the fix suggested.

I have an Asus Kaby Lake (1/2 generation newer than Gemini Lake) motherboard with text mode Aptio AMI BIOS dated 2018-05-11. F8 at POST brings up a boot device selection screen. If yours is like mine I suspect in trying to boot your stick that you need to be able to see at the F8 screen a description of your stick that includes “UEFI” and that if selected your stick should boot into the GUI installation screen. This may require first going into BIOS setup and changing “Boot Option Priorities” and/or “UEFI Hard Drive Priorities” and/or making a different “Boot Override” selection.

F8 doesn’t work for me, I have another version… 2.19.1268 with core version 5.13 and Build date 2018-08-24. Anyway, I can see my stick and its four uefi items in the boot menu. I tried everything… I managed Boot option Priorities and also the boot override selection, trying each item I see… nothing. Then I found two usb configuration menu and the usb legacy mode, that was already enabled! So I changed all the other settings (xhci, xdci ecc), testing all the possible combinantions, but the result was always the same! I also tried to use another usb drive and etcher, but again nothing has changed. Now I’m wondering if this isn’t enough to conclude that probably there is an issue in opensuse iso itself, given that, as I wrote in my first post, the same usb drive works with Ubuntu’s and Manjaro’s isos, and also with the secure boot enabled on the machine.

I think F8 is primarily Asus. Other possibilities include F12 (e.g. Dell, Lenovo & Toshiba), F9 or ESC (e.g. HP) & more. Maybe yours is like my B250 Gigabyte, which requires going into BIOS setup to choose “Boot Override” each time a non-default selection is desired.

Yes, I can change boot order priority or I can choose “Boot override”, but this doesn’t solve the problem.

It seems that I just have to keep ubuntu…

No, you don’t. Linux is linux. Try one of the Tumbleweed Live images.

I tried… again and again and nothing has changed. And yes, linux is linux, but it’s also true that each distro has some different features and each release of them too. So, which different feature could lead to this blank screen on boot from usb? Could it be the reported bug in grub? I don’t know, I haven’t this kind of knowledge.

Using alternate openSUSE media is somewhat like using other distros, startup differences. If you try to boot media made from a live image, or the little NET CD iso, or using PXE, you might enjoy better results.

Try adding ‘nomodset’ the the ‘linux’ line in the bootloader. At boot hit ‘e’, use arrow keys to navigate to the line ending with showopts, add space, add ‘nomodeset’, hit F10 to boot and report results here.

There isn’t a bootloader in which I can add ‘nomodset’. I select the boot from usb… I push enter and the screen becomes black with a white cursor on the top-left immediatley! Then I can only power off the machine. And this appens both with secure boot enabled and with the secure boot disabled. Instead, if I try with Debian, black screen (of failure) appears only with secure boot disabled (if this one is enabled appears a red window about a security alert, which lead back to boot menu).

The only thing that I haven’t tried yet is PXE… I don’t know it and I don’t even know from where I could start.

I would be trying to boot other distros besides Ubuntu, Manjaro and openSUSE, to see if there are others that refuse to boot. After reading through I get a sense that maybe you have not managed to fully disable secure boot. I would also try booting using a different HD.

I’ve never needed to try PXE myself. I’ve always managed to boot something local, or move the HD to another PC to install, then move it back, or any number of other workarounds, but I’ve also never had to fight against secure boot, stubborn or otherwise.