Boot messages are outputing to every tty

Hi,

I’m booting openSUSE 12.1 Live CD (“Minimal server” template, default runlevel 3, built with SuseStudio).
After boot I keep getting boot and service messages to every tty. For example, if openvpn is not able to resolve hostname, I get error message directly to tty. I switch to onther tty (Ctrl+F2) - and there I keep getting same messages. Ctrl+F3 - still same

Is there a way to stop outputting those messages to every tty?

Thanks

On Tue, 17 Apr 2012 08:06:02 +0000, tosiara wrote:

> After boot I keep getting boot and service messages to every tty. For
> example, if openvpn is not able to resolve hostname, I get error message
> directly to tty. I switch to onther tty (Ctrl+F2) - and there I keep
> getting same messages. Ctrl+F3 - still same
>
> Is there a way to stop outputting those messages to every tty?

You’re using the wrong key combination to switch ttys.

Try Alt+F<n>

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

That was typo, of course I’m using Alt+F<n> to switch between ttys.

On Tue, 17 Apr 2012 16:36:02 +0000, tosiara wrote:

> That was typo, of course I’m using Alt+F<n> to switch between ttys.

We have no way of knowing that. :slight_smile: We only know what you tell us.

Is the tty actually changing? It almost sounds like you’ve got just a
single tty configured.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Hi
For 12.1 the tty’s 2-6 are created on demand with systemd…


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 17:34, 3 users, load average: 0.00, 0.01, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Yeah, sorry for that :slight_smile:

Ttys are changing. I log in using root on tty0. There I get openvpn messages every 2 seconds (retrying connect). Then I switch to tty1 and need to log in as different user. While I’m typing in new username to the prompt I again get output of openvpn error messages (mess on the screen, I can’t figure out if I entered user name correctly)

On 2012-04-17 10:06, tosiara wrote:
> Is there a way to stop outputting those messages to every tty?

Try:


klogconsole -r 10

However, it those messages have level “emergency”, you can not.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

No, this didn’t help because klogconsole redirects kernel’s messages (printk). But I get errors from startup script (the script starts openvpn)

Still looking how to turn off those messages

On 2012-05-01 16:46, tosiara wrote:

> No, this didn’t help because klogconsole redirects kernel’s messages
> (printk). But I get errors from startup script (the script starts
> openvpn)
>
> Still looking how to turn off those messages

Strange…

Are they syslog messages? You could have a bad syslog config. Did you edit
it? Try reinstalling rsyslog.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On Tue, 01 May 2012 14:46:03 +0000, tosiara wrote:

> Still looking how to turn off those messages

I ran into this earlier today and found that it’s dmesg’s loglevel. It
looks like in 11.4 the /etc/boot.klog script executes the command:

dmesg -n 7

Which enables console logging.

I found in my test that setting “loglevel=3” in the boot parameters for
the kernel helped a lot, and adding “quiet” to it should suppress all
messages to the consoles.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On 2012-05-05 00:51, Jim Henderson wrote:

> I found in my test that setting “loglevel=3” in the boot parameters for
> the kernel helped a lot, and adding “quiet” to it should suppress all
> messages to the consoles.

I’m testing “splash=verbose console=tty1 loglevel=3” without quiet, in
oS12.1. It produces a similar result as with systemV, a verbose log to tty1
while booting.

View this thread
here

What I do not know yet is if reporting continues on tty1 after booting has
finished.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On Fri, 04 May 2012 23:23:06 +0000, Carlos E. R. wrote:

> On 2012-05-05 00:51, Jim Henderson wrote:
>
>> I found in my test that setting “loglevel=3” in the boot parameters for
>> the kernel helped a lot, and adding “quiet” to it should suppress all
>> messages to the consoles.
>
> I’m testing “splash=verbose console=tty1 loglevel=3” without quiet, in
> oS12.1. It produces a similar result as with systemV, a verbose log to
> tty1 while booting.
>
> View this
> thread here

>
> What I do not know yet is if reporting continues on tty1 after booting
> has finished.

That’s the same test I did, because I was getting iptables output on all
consoles and it was making it difficult to edit configuration in a
mediawiki installation in the VM.

I only did loglevel=3, but I had found some info on a page about Arch
that talked about using quiet to suppress all the messages, and that the
dmesg command issued to suppress the console output (in Arch) was in a
script that systemd doesn’t use.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Hi,

yes, adding boot parameter “quiet” solved my issue

Thanks a lot!

On Sat, 05 May 2012 09:06:03 +0000, tosiara wrote:

> Hi,
>
> yes, adding boot parameter “quiet” solved my issue
>
> Thanks a lot!

Glad to help out - when I saw that solution, I thought of this thread. :slight_smile:

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C