Boot menu messed up

Hi All,

I did an installation of 13.1 with a single / partition and UEFI enabled.

Unfortunately I lost the paritition due to a mess up and now when I switch ON the laptop all I am seeing Boot Menu with only one option,

  1. opensuse

I am not able to login to BIOS (F2) nor I am able to go to Boot Menu (F12). It is not responding at all. When I select the only option (above) 1. opensuse, it just takes you no where and loads the screen again. I am using a Fujitsu Lifebook LH532. Please see the link for the snapshot. http://snag.gy/PT7G9.jpg

Any idea how to resolve this. I want to do the re-installation again.

Regards,
Kurian.

Hmm. Is this a dual boot?

You should have at least a separate swap partition. and very recommended but not required a home.

Did you perhaps wipe out the efi boot partition (FAT format)

Does it boot to the install media??

You can’t get into the BIOS at all???

Hi,

This wasn’t a dual boot.

There was only a single parition ext4 with / and no swap partition.

This / parition was deleted due to a mess up unfortunately. Now I believe due to the opensuse signatures in the bios it is not allowing for other boot devices or BOOT cds to be used in the laptop.

What do you think?

Is there a solution for this?

Regards,
Kurian.

Did you at least retain the EFI partition, and mount that at “/boot/efi”?

This / parition was deleted due to a mess up unfortunately. Now I believe due to the opensuse signatures in the bios it is not allowing for other boot devices or BOOT cds to be used in the laptop.

As far as I know, there are no opensuse signature in the BIOS, unless you added one.

There’s an opensuse key (which I guess has a signature) installed in NVRAM, and I suppose you could consider that an extension of the BIOS. But it requires “shim.efi” or similar to use it. The BIOS will not use it for other operating systems.

What do you think?

From this distance, it is hard to know what went wrong. If you deleted the EFI partition, that could be part of the problem.

It looks to me as if you might need the manufacturer’s recovery procedure to get this working again.

Actually your problem has nothing to do with openSUSE.
It is a problem of your Mainboard resp. your UEFI BIOS settings.
It looks that you have something like “fast boot” enabled which does not let you select F2/F10/F12 (enter UEFI settings, boot menue, boot from network).
I recall having had similar problems once.
The Problem is that the fast boot skips the USB devices detection - including your USB Keyboard - and thus yout “F2” or what have you is not seen by the startup routines.
USB Keyboard is only available after the boot of the OS later.

With some Intel boards it helps to switch off the computer right in the moment before the UEFI BIOS starts - maybe you have to do this repeatedly.
After this the UEFI BIOS will report that the start has failed and explicitly ask you if you want to de-activate the fast boot.
Another option may be to set the BIOS settings reset jumper on the Mainboard - consult your mainboard manual.

I strongly disrecommend the “fast boot” setting for the reasons described here…
But maybe Thorvalds is right about “Intel’s brain damage” like he called EFI once…