Boot menu does not show all options

I have the following installed and bootable:

OpenSuse 15.4 Cinnamon
OpenSuse 15.4 LXQT

I changed the default distro in Yast Boot Manager to be LXQT
Now the boot menu only shows the LXQT options.

How to I reset the boot menu to show all bootable installs?

Are you sure the other isn’t hidden in Grub’s advanced options?

As long as in /etc/default/grub GRUB_DISTRIBUTOR= is the same for both, your twin Leap installations will be wresting control of boot from each other with each grub update. I suggest you make them unique, such as GRUB_DISTRIBUTOR=“leapcinn” for one and GRUB_DISTRIBUTOR=“leaplxqt” for the other. For best results, include no whitespace in whatever you choose, and, because of Linux filesystem case insensitivity, you’ll be best off in the long run only using lower case & numerals. It should help if in each /etc/default/grub you include GRUB_DISABLE_OS_PROBER=“false”. This way, each will include the other plus Windows when generating /boot/grub2/grub.cfg. Right now it seems the one in control doesn’t know anything about the other yet, and needs grub.cfg regeneration after /etc/default/grub edits are done.

Another option would be to uninstall Grub from one of the two, letting the other enjoy Linux exclusivity.

Another would be commenting the fstab entry for the ESP partition for one of the two. This is functionally more or less equivalent to Grub removal, as updates to Grub won’t show up as changes on the ESP partition overwriting those of the other.

There are other alternatives I won’t get into before we see how you make out with any of these.

Is the “normal” solution to wanting to use different DEs on a system not simply by installing both (or more) DEs on a system and leaving it to the individual user what he wants to use at that time at login?

As a human being I prefer to use both lowercase and uppercase.

  1. I use GRUB_DISTRIBUTOR=Tumbleweed-NVME
    . 1. From that grub2-install creates by default /boot/efi/EFI/tumbleweed-nvme
    /grubx64.efi. 1. efibootmgr displays Boot0004* tumbleweed-nvme
  2. The corresponding grub menu entry reads: Tumbleweed-NVME

Post executed as root:

efibootmgr -v

Of course, and much easier to install and maintain.

I qualified my recommendation. You are a well qualified and experienced responder here. OP is the opposite. The reasons for using lower case only have little to do with booting, but with system maintenance, help requests, and divergent contexts, by the nominally experienced; and tertiarily, an overall policy of keeping things short and sweet.

COOL! This addresses an issue I have long been curious about. Now I know how to install leap and tumbleweed on the same box! :slight_smile: