Boot menu after kernel update

a week ago I made a kernel update for o.S 11.3 to on
both Fujitsu- Siemens Esprimo (running with o.S.11.3 since Aug.2010, dual boot with Win XP)and
Asus P 42 J (o.S 11.3 since Feb.2011 ,dual boot with Win 7).
After completion of the update and restart the Fujitsu was okay,
on the Asus boot menu o.S.11.3 and Failsafe were disappeared, only Win 7
was left and bootable.
Wha t a surprise.
I tried to revive o.S.11.3 by inserting installtion DVD rescue mode and parted magic.
The boot entry was still on extended.
However eventually no success to revive it.
So I solved the problem my way: I made a fresh install of o.S. 11.4.hoping the next kernel
won’t distroy it.

I’m not sure I understand what you mean and if you’re not confusing Grub menu entries (which indeed may vanish after a kernel update) and active partitions (which can be set inactive and become unbootable under certain circumstances). But if you’re wondering what removes kernel boot entries from Grub menu after a kernel update, this post might provide an answer and a solution (more precisely a hack) : updategrub for openSUSE Legacy Grub (not update-grub!).