"Boot Manager is missing" Error

Due to some booting problems with Windows Vista Home Premium

  1. I unplugged the power and data cables to the SATA 1 HD where Windows Vista HP 32-bit was previously installed
  2. left only the power and data cables plugged to the SATA 2 HD where opensuse linux 11.1 64-bit was previously installed
  3. ran Parted Magic 4.2 (2009) and deleted the three (3) opensuse linux 11.1 X64 partitions
  4. installed again opensuse 11.1 X64

When I entered into the BIOS and changed the booting devices order to boot from the SATA 2 HD, the following message appeared onscreen

BOOTMGR is missing
Press Ctrl+Alt+Del to restart

However, I can boot opensuse linux thru its Installation DVD, and it will work well.

I ran Parted Magic and it gives the following readings

…Mount point…Flags
/dev/sda1 … linux-swap
/dev/sda2 … ext3…/media/sda2…boot
/dev/sda3… ext3…/media/sda3

The motherboard is an Asus M3N-HT Deluxe Series, and the CPU is an AMD AM2+ 7750 Dual-Core processor.

I will appreciate your kind assistance in knowing the code lines that should be entered into the appropriate oss linux 11.1 files.

Once things become stable I will work then with the other o/s switching from the 32 to the 64-bit version. While working with this the booting problems arose.

sata 1 = vista correct?
sata 2 = suse?

You think you have set sata 2 as first to boot in bios? But the error message you report is not consistent with suse, which is installed on sata 2.

The error you are getting is from vista. Have you tried with just sata 1 connected? Do you get that same error? If you do, you need to fix the vista boot code. Let us know what happens with just sata 1 connected and for that matter just sata 2:

Yes, SATA 1 is for Vista and SATA 2 is for opensuse. However, I have left the power and data cables unplugged to the SATA 1 HD as there is no active Windows Vista HP partition on it.

I have not performed the test that you recommend but I will let you know what happens when I do it.

Thanks again for your valuable feedback.

So he has one HD plugged in which is SATA 2.
It housed a previous version of openSuse.

When you did the install, was this a New Installation and the installer reformatted the drive?

Or did you choose the update option?

It would seem very odd to me if you did a New Installation that reformmatted the drive that you would get that message. Have you run the repair option off of the DVD and checked the install & boot loader?

I do not have enough details on your bios to say anything has caused the problem. One thing I do which someone could probably come up with a better way, if I have an Linux install problem that is partition related, I throw in a Windows disc and do a full NTFS format, power the unit down when it completes before it starts copying files, and then I start my Linux install.