Boot Loop Problems

I am trying to load openSuse 11.0 GNOME 32bit into failsafe from LiveCD, so I can install video drivers in yast, but every time I try to load up failsafe the system reboots. Any ideas? I had opensuse running perfectly well today, but I had some problems and decided to reinstall. So it’s not a compatibility issue with my hardware.

AMD Athlon 64
1024 ram
200 gb hdd
nvidia 6600gt

Update: I’ve tried resetting my BIOS by taking out the Cmos battery and putting it back in, but no go. Suse will still not go into failsafe mode, but simply reboots. PLEASE HELP!

Anyone? I am unable to access runlevel 3 from liveCD. Any ideas would be greatly appreciated.

Sorry, but I don’t follow why you’re trying to use failsafe to load video drivers? Which drivers? You do realize that the live-CD is running entirely in RAM, until you install to disk? What am I missing?

Are you trying this from the main menu selection; typing just a 3 in the box below? Getting the graphical (framebuffer) screen? You can hit escape to go to framebuffer text and possibly see what is tripping the reboot. But as I queried above, if you are only using failsafe, the kernel may be missing something it needs for your machine.

I am trying to use failsafe to load video drivers because I can’t see anything if I try to load into the regular GUI. If I could access runlevel 3 I could go into yast and load my video drivers, but reboot is tripped everytime I attempt access to runlevel 3.

I tried to enter 3 as my “boot option” while logging in regularly, and not in failsafe, but again the reboot was tripped.

Oh and the driver I am trying to “load” is the Nvidia driver which I can load through yasat by accessing nvidia’s ftp server. But I have to access yast first.

FINALLY! I disconnected a secondary CD drive, and logged into runlevel 3…where I was glad to discover by chance that you login with “linux”.

Sorry to get back to you a tad late . . . you don’t need to install the nvidia driver. With your card (I have it in one of my machines, and I just double-checked with the live-CD), the “nv” driver will be loaded autommatically. You can install the proprietary driver, but it probably would not be retained if you’re planning to install from the live-CD. But again, with that card the “nv” driver should do fine until fully installed, or just for use alone with the live-CD. If you are in, but still don’t have a gui, take a look at /etc/X11/xorg.conf, it should show “nv”.

You did make me curious, so for the heck of it I used zypper to add the nvidia repo, installed the driver and the kernel module, modprobe the module, changed xorg.conf to use it, and restarted X. It actually worked, although it did bork the desktop layout a bit. Interesting.

Not a problem on the late reply…I appreciate your help. However for some reason even though it is supposed to work when I boot to the GUI my display is junk until I install the new Nvidia driver. Oh and I don’t know how to get to /etc/X11/xorg.conf I’ll check yast. Thanks for your help.

If the gui isn’t working on that card with “nv”, it’s possible that the resolution and/or monitor settings are wrong. At the command line do:


That should bring up the configuration utility. As far as seeing what X is actually using which is in xorg.conf, just do:

cat /etc/X11/xorg.conf

The driver is in the Device section, the resolutions in the Screen section, and monitor refresh rates in the Monitor section. You can also take a look at the X server error log, which can only be viewed as root (the file will be long; the “more” command is used to scroll thru it):

more /var/log/Xorg.0.log

Finally, when you install the nvidia driver, it should automatically setup xorg.conf for you. But if it doesn’t, you can force that with:

sax2 -r -m 0=nvidia

I tried all of your helpful advice, but none of it worked. When I type “sax2” the system brings me to the GUI which of course doesn’t display. When I type “cat /etc/X11/xorg.conf” the system says that the directory or file does not exist. Same when I type “more /var/log/Xorg.0.log” the system says the directory or file does not exist. Finally typing “sax2 -r -m 0=nvidia” again attempts to bring up the GUI, but again I can’t see anything.

 I took the plunge and am downloading the 4.5 gb DVD install .iso, which I hope will actually work. Thanks for the help, and keep the ideas coming if you have time!

Should have thought to ask before . . . did you check the .iso you downloaded, and check the burn with “media check” from the CD? I just booted my 6600GT card machine from the CD, and the “nv” driver was loaded, there is an xorg.conf file, there is a /var/log/Xorg.0.log file. And I can run sax2 (which does not require the X server to work; it has its own built-in graphics server because, among other things, it expects that your graphics config is not yet set up). So something is really amiss with what you’re working with. In a terminal as root, you can do:


And that will you all the hardware using the pci bus that was detected, i.e., the chipset and disk and usb and firewire and agp controllers with attached devices - you should see your card in that list. But I don’t think the problem is with the graphics card or driver at all.

When you get the DVD, it’s even more important than with the CD to verify the .iso and the burn. In some burners it will calculate the md5sum when it loads the .iso, saving you that step. Also some have a “verify” option which checks the tracks against the source file. Burn on the lowest speed possible (has to do with readable layers for the laser); force that if need be. Good luck.

I just burned another copy of the .iso at the very slowest speed possible…so I’ll try using that. Oh I used the lspci command which displayed the Geforce 6600gt under vga. I’ve also almost completely downloaded the DVD so I’ll try that here in a bit too.