Boot Loader Problems

I have opensuse 11.2 new installation and boot loader will not recognize windows. How do I get windows to boot? I can boot it using Super Grub disk but I can’t get boot loader to set it up. Any help would be greatly appreciated.

First need to see the partitions
become root in a terminal or console
su -

fdisk -l

also let’s see the grub menu file

cat /boot/grub/menu.lst

Please open a su terminal
Become su in Terminal - HowTo - openSUSE Forums

and post result of the following

cat /boot/grub/menu.lst

fdisk -l

edit: ditto

inux-fxzk:/home/rowland # cat /boot/grub/menu.lst

Modified by YaST2. Last modification on Sun Jun 6 13:29:30 EDT 2010

THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader

Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd1,0)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.2
root (hd1,0)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-ST3160811AS_6PT0WGM4-part1 resume=/dev/disk/by-id/ata-ST3160811AS_6PT0WGM4-part6 splash=silent quiet showopts vga=0x31a
initrd /boot/initrd

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.2
root (hd1,0)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-ST3160811AS_6PT0WGM4-part1 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
initrd /boot/initrd

###Don’t change this comment - YaST2 identifier: Original name: menu###
title Windows
root (hd0,0)
configfile
linux-fxzk:/home/rowland #

inux-fxzk:/home/rowland # fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xcab10bee

Device Boot Start End Blocks Id System
/dev/sda1 1 13446 108004963+ 7 HPFS/NTFS
/dev/sda2 14601 15755 9277537+ c W95 FAT32 (LBA)
/dev/sda3 * 13447 38913 204563677+ 5 Extended
/dev/sda5 13447 14045 4811436 83 Linux
/dev/sda6 15756 18366 20972826 83 Linux
/dev/sda7 18367 38913 165043746 83 Linux
/dev/sda8 14046 14117 578308+ 82 Linux swap / Solaris
/dev/sda9 14118 14600 3879666 83 Linux

Partition table entries are not in disk order

Disk /dev/sdc: 2038 MB, 2038241792 bytes
64 heads, 63 sectors/track, 987 cylinders
Units = cylinders of 4032 * 512 = 2064384 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sdc1 1 969 1953439+ 6 FAT16

Disk /dev/sdd: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0006290e

Device Boot Start End Blocks Id System
/dev/sdd1 * 9937 19457 76477432+ 83 Linux
/dev/sdd2 2 9936 79802887+ 5 Extended
/dev/sdd3 1 1 8001 83 Linux
/dev/sdd5 2 9585 76983448+ 7 HPFS/NTFS
/dev/sdd6 9586 9936 2819376 82 Linux swap / Solaris

Partition table entries are not in disk order
linux-fxzk:/home/rowland #

Try editing this entry

###Don't change this comment - YaST2 identifier: Original name: menu###
title Windows
    root (hd0,0)
    configfile

to this

###Don't change this comment - YaST2 identifier: Original name: menu###
title Windows
rootnoverify (hd0,0)
chainloader +1

This is how to edit in kde:
open a terminal, not su

kdesu kwrite /boot/grub/menu.lst

in gnome

gnomesu gedit /boot/grub/menu.lst

It didn’t work. Any other suggestions? Thanks in advance.

Didn’t work is not helpful: What happened?? explain…

As it is that code works if sda is set first in the boot order of your BIOS. You have to know your boot order. Do you understand this? If sda is not set first and you change it, you will probably loose grub too.

The entry for your SUSE boot shows SUSE on the second boot device hd1,0 and the first partition. The only HD entry which could match that is sdd, specifically sdd1 whcih has a boot flag on it * too.

So if you can identify the order of the drive sda in the BIOS settings, you can change the grub code accordingly. As far as I can see the windows drive has to be either 1st or 3rd, because SUSE is certainly 2nd if it’s booting from hd1,0

I wonder why your code shows sda - sdc - sdd and no sdb?

Yes I understand. I will keep trying. Thanks for your help.

It tried booting windows but it froze on the boot up section of windows with the blue line going back and fourth. I changed it to (sda1,0) That’s where it show the NTFS is located. I will try to edit it now in yast boot loader and see what happens.

I got it to work by editing the boot loader and setting it as /dev/sda1. It boots find now. Thanks for your help.

If it’s working, fine, but what you posted doesn’t make any sense actually.