Boot Loader Error in Instalation

So my last laptop ran Ubuntu but after research I think I want openSUSE on my new (to me) laptop.
It is a dell Latitude E6410 and since it has a easy to remove hard drive I have decided to have two hard drives that I switch out depending what I want to do. One with windows and one with Linux.
The one with Linux is a Toshiba 120gb hdd.
Anyway wile installing openSUSE it said that there was a error wile installing the boot loader. if I tell it to skip the step it, as expected, doesn’t boot.
after researching I came to the conclusion that I had downloaded the 64bit one when I needed the 32bit legacy one (the bios boots legacy).
so I loaded a new DVD and tried again. long story short it still gives the exact same error. I assume its something wrong with the bios but I have no idea what needs to be changed.
Any suggestions?

I’m surprised that a new laptop does not have UEFI firmware.

Or, maybe you purchased with Windows 7, and Dell sets the BIOS to legacy compatibility mode to install Win7 for legacy booting.

In any case, there’s a possibility that your problem is related to the default selection of “btrfs” for the root file system. So try again, but edit the suggested partitioning and change to “ext4”.

I suggest you go with the 64-bit, rather than 32-bit for installing.

Its not a new laptop. I bought it off a collage that gets new computers for the professors every four years. It was made in 2010 and has a 64bit i5 in it. To the best of my knowledge it dose not UEFI but I will check and get back to you. I will also try your suggestion with the root partition.


Oh I love it when solutions are as simple as clicking a extra key. In this case: the down key. I tried booting the dvd using UEFY instead of legacy this time. I don’t know why I didn’t think of it earlier. Anyway it works now. Thanks for nudging me in the right direction.