Boot Loader Error (dual boot with xp)

Hi,

I’m new to the whole linux scene.
I thought it was time to try something new on my pc.
I’ve downloaded Linux openSuse11.1.
I’ve used all standard installation settings, except for the language part then :wink:
All went fine, untill the last part of the installation, when it was installing the boot loader.
It said not installed, partition not found.
So I tried several times, but then after a while,i just said, do not retry.
So the result, when trying to boot it says no operating system found… (like lol, i had xp installed ??)
But whatever I said I wont give up.
Booted from the dvd again, and went in the repair mode.
It says problems found, ofc. At the bootloader, but guess what it wasnt fixed. It keeps saying partition not found?
(at the section manager)(a small overview)
Label:
Suse Linux
Type:
image
Section summary:
append= repair=1 resume=/dev/disk/by-id/ata-ST3300822A_5NF1GAS4-part5 splash=silent showopts, image=/boot/initrd, root=/(pract, the same unless part 6), vgamode=0x348
then u have the fail safe thingy.

any idea’s whats wrong with it ?
of something is not clear or dont understand, or need more information plz ask ^^

tried with lilo failed aswell, says not supported now

hi,
did you installed linux in logical partition or you left it shoose the installation partition?

No, it was a clean install a standard once. I’ve let suse diside for the partitions.

Mayby it’s better that I reinstall linxus when I get home.

but remember to let it live on its own partition(the one you provide your self) don’t let it shoose it automaticaly so you can remove it if needed

I think you encountered a bug in the YaST Boot Loader module that has since been fixed. Probably the grub control file menu.lst is corrupted. IIRC the installation gives the option of installing Updates; that should include the fix. If that isn’t an option/didn’t work, then do you have a LiveCD? - we can also fix this from the DVD Rescue System but it will be easier for you with the LiveCD, assuming it makes an internet connection. Either way, we need to see the output from this command run either in a terminal (the LiveCD) or the command line (the DVD) to get the boot working:

su -
fdisk -lu

Sounds like my problem as well.

Here’s the error I get from the install:


 Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename. ]
grub> setup --stage2=/boot/grub/stage2 --force-lba (hd0,2) (hd0,5)
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (hd0,2)"... failed (this is not fatal)
 Running "embed /boot/grub/e2fs_stage1_5 (hd0,5)"... failed (this is not fatal)
 Running "install --force-lba --stage2=/boot/grub/stage2 /boot/grub/stage1 (hd0,2) /boot/grub/stage2 p /boot/grub/menu.lst "... failed

Error 22: No such partition
grub> quit

I’ve tried installing from the DVD as well as the LiveCD; both give me the same error. I even tried running the software updater on the LiveCD to get any patches etc, it said I needed to restart because some stuff affected YAST, I wasn’t sure if this was possible when I was using the LiveCD so I started the install hoping that it would pickup the new bootloader patch that I saw had been included in the update, but I still got the same problem. In fact the error message above was taken from the this last installation failure.

Help, I’ve got a mother and brother that want to get back onto Windows (fools) and they can’t because I’ve knackered the boot.

If it helps here’s the results of that code (run using the updated LiveCD) you asked ayumi to run:


linux@linux:~> su -
linux:~ # fdisk -lu

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0x811b6786

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048    11575295     5786624   27  Unknown
Partition 1 does not end on cylinder boundary.
/dev/sda2        11575296   164892095    76658400    7  HPFS/NTFS
Partition 2 does not end on cylinder boundary.
/dev/sda3   *   164892096   312575759    73841832    f  W95 Ext'd (LBA)
Partition 3 does not end on cylinder boundary.
/dev/sda5       164892097   169086960     2097432   82  Linux swap / Solaris
/dev/sda6       169087023   190149119    10531048+  83  Linux
/dev/sda7       190149183   312575759    61213288+  83  Linux
linux:~ #

Thanks

Col

Amnesia,
while you’re waiting for a reply, since your install doesn’t seem to work, you can at least let your computer boot with windows by using cfdisk in the live cd.

When in the live cd, open a terminal and login as root (type su)

Then type cfdisk /dev/sda

This will show you that same partition table that fdisk did. Now use the down arrow key to highlight

/dev/sda2        11575296   164892095    76658400    7  HPFS/NTFS

on the bottom make sure that [bootable] is selected and hit enter. This will mark your windows partition as bootable and it should then look like this

/dev/sda2  *     11575296   164892095    76658400    7  HPFS/NTFS

Then use the down arrow key to highlight

/dev/sda3   *   164892096   312575759    73841832    f  W95 Ext'd (LBA)

Once again make sure that [bootable] is selected and hit enter. This will unmark your linux partitions for booting and it should then look like this

/dev/sda3       164892096   312575759    73841832    f  W95 Ext'd (LBA)

Then hit the right arrow key until [write] is selected and hit enter. I think it asks you if you’re sure, answer yes and it will rewrite the partition table so that windows boots up instead of linux.

My laptop came with Vista already installed.

I installed Ubuntu and have difficulty getting Vista boot by default. I went to Ubuntu forum and they suggested I installed startup manager. This solved the problem to startup Vista.

I then installed SuseLinux, I hit the same problem. Isn’t there something similar to Ubuntu startupmanager in SuseLinux instead of editing the menu.list?

Thanks.

Simple.

Changed the default from 0 to 2 in menu.lst

I’m up and running now.

I had trouble with the 11.1 installer because it was installing the boot loader to an extended partition rather than in the MBR. It turns out you can change where the boot loader is installed to in the boot loader installation tab when installing OpenSuse 11.1. I think I may have read somewhere about Thinkpads wanting the bootloader installed to the extended partition (possibly saw it on ThinkWiki?) but I currently have the bootloader in the MBR - I can boot to Suse and Windows and all is fine so I don’t think its too much of an issue.

Just like several others with the same issue (ie failing to find the Operating System to boot after installing Opensuse 11.1) I found the following site explained how to correct my issue:

GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

I’m using a Lenovo Thinkpad and it turns out there’s also a tickbox about setting up the boot loader with generic boot code (or something like that) which removes the ThinkVantage button function so now I’m going to try running through the instructions on the following page to see if I can get this back working again (because I only found out from the installation Release Notes that only showed up after the installer had installed the bootloader - how stupid):

ThinkVantage Rescue and Recovery

Failing that there’s also…

Lenovo Support & downloads - Master boot record repair kit

…but I think this may overwrite my OpenSuse 11.1 boot option and leave me only being able to boot into Windows. If it does come to this I could always use the 11.1 LiveCD to edit the new bootloader file but we’ll see if it comes to that first.

Also, I installed from the DVD version first and the KDE4 desktop didn’t show any of the system tray icons which was a bit annoying. I then had a go with the LiveCD because I could see there and then that the icons were working and they’ve been fine. They sometimes have a black background when I switch program windows or desktops but that’s all…nothing really to worry about.

This is just fwiw . . . IIRC some Thinkpads have proprietary MBR code. The YaST Boot Loader module’s suggestion logic actually checks for this and factors that into its recommendation. The “generic” code option you saw in YaST is essentially the old DOS boot code; that code, XP code, or Vista code will all boot the primary partition marked active (the only difference being that generic code can use a boot sector in the extended primary whereas the newer code cannot). Also, note that if your Windows version is Vista, your best solution may be to install grub to the SuSE root partition boot sector and use the Vista boot manager to boot SuSE.