Boot live via local network

Hi everybody,

like my title say, I want to be able to install openSUSE throw my local network, but not by downloading all the sources, I want to do it only with the ISO image. All informations I foud talk about internet install or mirroring all packages on my server… I know it’s possible beacause I use to do this with Ubuntu.
I have a working DHCP server and PXE / TFTP server install on my Ubuntu desktop.
Dou you have any tutorial or working pxe configuration to share with me ?
I hope you will understand my english and be able to answer my question.


Easiest way is putting the content of the ISO in a folder of your UBU machine, let’s say in a folder /INSTALL
Now export this folder through NFS, i.e. add next line to /etc/exports:
/INSTALL *(ro,root_squash,sync,no_subtree_check)

Don’t know how to (re)start the NFS server on Ubuntu, but that’s up to you.

Next, on a machine where you want to install, boot from install disk, change CD/DVD to NFS. You will be asked for an IP (IP of UBU machine) and a folder (should be /INSTALL).

Done. Install now takes place from the UBU machine.

Booting the openSUSE install kernel from a NIC is definitely possible. All you need to do is extract the kernel and initrd from the netinstall CD and install that on your TFTP server. Since you have activated DHCP and TFTP on your Ubutu system, I assume you are familiar with running those.

Of course, once you have booted it, you need to provide the contents of the DVD over the LAN. NFS or HTTP are two usual ways.

You should be able to find the howtos for netinstall on the openSUSE wiki, follow the documentation link from the home page

ok guys,
first of all thanks for your reply.
I do as you say, I’ve go some blueu screen which ask me to choose network → nfs. I enter the good ip address and path to the folder where I’ve copy the content of my iso (openSUSE-11.1-KDE4-LiveCD-i686) and then I’ve got a big red message saying: “No repository found.”
Is there something to do with the file or folder such as rename some of them ?

I would guess so. It works here. On my system the content of the iso is in /Install/11.1 , I export /Install, enter server IP, and there you’ve got me: forgot whether I enter /Install/11.1 or just /11.1 and cannot test right now. Mind, I am oldfashioned, I avoid spaces etc. in folders that I use on system level.

Good luck.

I try all the stuff that came in my mind…:
I also try by ftp but there I got a new error: first a message say “no update for your driver”, then start installation and finaly, just when I thought I 've do it: “An error occured during the instalation”
I don’t know if it’s bad but when I’m in my blueu screen it’s wrote: kernel2.3.31-rc6-3-default and in my iso image file I’ve got openSUSE-kde-11.1-read-only.i686-2.7.0. Doesn’t seems to be the same version.

I’ve just try with a Gnome version, it fail to…no surprise.

Just make sure you can actually mount via NFS first. You can do a loopback mount from the server to check this:


mount -t nfs <server-ip>:/path/to/install /somemountpoint

then debug this until you get it right. Check the log files in case of mount error. Lots of things can get in the way, exportfs wrong, firewall, etc etc.

BTW I can’t be sure, but I think the LiveCDs are not suitable as repos. When installing via the net I have always installed using the DVD as the install repo.

ok guys, thanks you again for your help,
I’m prety sure that my NFS work well but I’ll try what you say.
I think that using a DVD insted of a CD might be the good solution, I’ll try it as soon as I’ll be back home. I keep you posted.

You got it ken_yap, the problem was the CD/DVD. After downloading the dvd i install my new openSUSE perfectly.
The last is now to find a way to pass the bleu screen configuration, I 've seen some option to pass my server ip and nfs folder directly from the defaul file in pxelinux.cfg. Thank you all for helping me.