Boot issues - Failed services in run level 5

Hello Everyone,

I am facing the serious problem. I am using opensuse 11.3. I have install the update from Yast and after reboot getting the message:

Failed services in run level 5:
Skipped services in run level 5:

and after I find the login command.

Even it do not start at failsafe mode.

Please help me what should I do.

Thank you in advance.

Do you mean it boots to a terminal window and asks for a login?
Also, do you have a radeon or nvidia video card?
If so, read the thrad:
openSUSE Graphic Card Practical Theory Guide for Users
which will dive you info on how to install the video support.

Note how graphic card drivers are handled is different in 11.3 than it was in 11.2. Did you try entering ‘nomodeset’ as a boot argument?

Please also take a read here: SDB:Configuring graphics cards - openSUSE

On 2010-08-08 22:36, vineetgupta wrote:
>
> Hello Everyone,
>
> I am facing the serious problem. I am using opensuse 11.3. I have
> install the update from Yast and after reboot getting the message:
>
> Failed services in run level 5:
> Skipped services in run level 5:
>
> and after I find the login command.

I assume you mean that graphics mode does not start. Then look up the log and find out why :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

You could also check you /etc/X11/xorg.conf file. Try deleting it entirely (backup first).

What graphics card do you have NVIDIA?

Actually It was working fine before. I was using gnome desktop. I just applied update from Yast and after reboot, I am getting the message


Failed services in run level 5:
Skipped services in run level 5:

Welcome to openSUSE 11.3 “Teal” - Kernal 2.6.34-12-default (tty1)

linux-vineet login:_


Hello Everyone,

I am facing the serious problem. I am using opensuse 11.3. I have install the update from Yast and after reboot getting the message:

Failed services in run level 5:
Skipped services in run level 5:

and after I find the login command.

Even it do not start at failsafe mode.

Please help me what should I do.

Thank you in advance.

There is no /etc/X11/xorg.conf file. How to know about graphics card? I am unable to find about graphics card in BIOS.

I find that system has “ATI Fire PRO Professional Graphics ASIC” graphic device.

You need to look at this section on installing the drivers you need for the graphics card:
openSUSE Graphic Card Practical Theory Guide for Users

You can still run yast in the terminal login you have to add the ati repo.
Login as root and type yast.
Choose software>software repos and add the ati repo from the community repos.
When added go to software management and instead of ‘search’ add the ati repo. Then choose the ati driver for your card.

I have applied step 1 to 3rd in SDB:Configuring graphics cards - openSUSE, nothing works.
There is no /etc/X11/xorg.conf file and I find that system has “ATI Fire PRO Professional Graphics ASIC” graphic device.
In the forth step if I open the file /etc/X11/xorg.conf.d/50-device.conf

The file is:
Section “Device”
Identifier “Default Device”

#Driver “radeon”

Required magic for radeon/radeonhd drivers; output name

(here: “DVI-0”) can be figured out via ‘xrandr -q’

#Option “monitor-DVI-0” “Default Monitor”

EndSection

What should I do?

OK, then look at this thread:
Hardware - Installing ATI Drivers

I have done this in software management if I search ati keyword. There are so many entries, how to find which one is for ati repo.
Thank you…

In the thread written that “Click Here to download the ATI Linux Driver” but how to download ATI driver without desktop(eg gnome ie I was using before.)

In yast>software>soft manage:
Don’t search - Press alt+tab to get to the ‘Filter’ and then use the up/down arrow keys to change this to repos and the select the ati repo.

On 2010-08-09 13:36, vineetgupta wrote:
>
> Dorax;2203563 Wrote:
>> You could also check you /etc/X11/xorg.conf file. Try deleting it
>> entirely (backup first).
>>
>> What graphics card do you have NVIDIA?
>
> There is no /etc/X11/xorg.conf file.

There is none in 11.3 or 11.2 unless you create it.

> How to know about graphics card? I
> am unable to find about graphics card in BIOS.

You should know what you have in your own computer. If not, you can open the box and look up the
card or the chip. Or run “hwinfo --gfxcard”. Or give a link to your smolt profile.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

11.3 normally does not use an xorg.conf, so that should be ok.

Worst case, you can add a line to xorg.conf to temporarily switch to a vesa driver, that should allow you to startup x. But, perhaps, that is the recovery mode these days.

Sorry, I don’t have many suggestions left.

Did you update to 11.3 or did a fresh install?

I would recommend a fresh install always when updating.

I was already using opensuse 11.3 with gnome desktop. It was just that I open ‘software update’ and after update I reboot the system and getting this problem.
Just for the information, when I run ‘startx’, I get a black screen and arrow which moves with the mouse.

I was already using opensuse 11.3 with gnome desktop. It was just that I open ‘software update’ and after update I reboot the system and getting this problem.
Just for the information, when I run ‘startx’, I get a black screen and arrow which moves with the mouse.

Luckily I find the related thread but no reply from that…


Hello Edward,

I am facing the same problem. I am using opensuse 11.3. I have install the update from Yast and after reboot getting the message:

Failed services in run level 5:
Skipped services in run level 5:

and after I find the login command.

Please help me

Thank you in advance.

Quote Originally Posted by Edward_Iii View Post
Hello Catchy,

First of all welcome to the community!

It would be helpful if you could post your version of openSUSE.
And maybe you can try to boot in failsafe mode.

Did you install,update or uninstall something before this happend?

Best of luck!

On 2010-08-09 14:36, vineetgupta wrote:

> In the thread written that “Click Here to download the ATI Linux
> Driver” but how to download ATI driver without desktop(eg gnome ie I was
> using before.)

:slight_smile:

There are browsers you can use in text mode, although you may have to install them first.

lynx, links, w3c → html browsers

mc → file browser and much more. Better than any GUI!

alpine, mutt → mail and news clients.

wget → powerfull downloader

aria2c → metalink downloader (best choice for packages).

yast you know it.

zypper → package manager, CLI.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))