Boot issue.

Well today, I’ve installed Opensuse 12.3 (Gnome) 64 bit edition.
Installation was successful but however whenever I try to boot into the opensuse OS i get the error “insert media”

fdisk -l output

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  1953525167   976762583+  ee  GPT
Partition 1 does not start on physical sector boundary.


But however I can boot the OS by booting from “Optical drive” but not the hard drive. By optical drive I mean there’s no media inserted into my machine but it still boots.
Hope I could get some help with this issue, opensuse seems amazing so far. :wink:

More information is needed on what you are doing.

It is normal, on the first reboot after install, for the install media to be required. That’s for completing the final install steps.

That’s not the full output. It should have told you that the disk was GPT partitioned, and that you need a tool other than “fdisk”.

Can you provide the full output from “gdisk -l /dev/sda” (use code tags).

Is this a UEFI box? If Windows is there, then it probably is.

Did you install to use grub2-efi, or is it using a form of grub2 that depends on MBR booting?

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 1953525168 sectors, 931.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 388F2666-7874-499E-A7D4-082B03633981
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1953525134
Partitions will be aligned on 2048-sector boundaries
Total free space is 3437 sectors (1.7 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048         4208639   2.0 GiB     8200  primary
   2         4208640      1953523711   929.5 GiB   EF00  primary


No it’s not normal after installation, I have to go into bios and boot from optical drive. & I don’t use Windows at all, this was a freshly formatted install from Debian. Never had any problems with any boot issues until installing this, not entirely sure what I’ve done wrong, searched multiple threads and none have helped me so far.

Also I did the default settings without the “Propose separate home partition”

It is really good to have a separate home but is not strictly needed. It looks like you did not install proprtly for UEFI. So did you chose to use the BIOS method in the UEFI and install the grub to the MBR??

If doing a UEFI style boot you need an UEFI boot partition formatted as FAT.

You need to do one or the other.

I’m really not that familiar with partitioning so are you saying I need to install GRUB-UEFI in the boot loader type?

You don’t have to if

  1. you tell the BIOE/UEFI to boot in legacy (BIOS) mode
    and
  2. tell the installer to put the GRUB boot code in the MBR.

I just looked at gparted I’m currently on the installed opensuse right now it says SDA2 flags , boot, boot_legacy.

ok So did you install grub to the MBR??

You need something there even generic MBR will work if you install grub to the boot partition (in this case root) and set the boot flag. but if ater atr doing legacy boot you must hae MBR code in the first disk sector.

If there a possible way of doing this without re-installing everything again? I’ve re-installed this about 8+ times and all has failed :cry:

Also I highly recommend a separate home it makes up grades and OS changes soooo much easier.

Well, that’s weird.

You have “/dev/sda1” as a swap partition, and the rest of the disk as a hugely oversized EFI partition.

You probably have UEFI firmware, which is not finding what it expects on the hard drive.

Did you attempt to install using the DVD image, or did you use the live image (Gnome or KDE). I’m guessing that you used the live image, which gets things wrong for UEFI systems.

You will probably need to reinstall. I can try to provide some guidance, but I will need more information.

First things first:

  1. How are you installing (live or DVD image)
  2. Does your BIOS make it possible to boot into UEFI mode?