Boot issue

I have got a boot issue on server using legacy version of grub. The issue is that the kernel file can not be found. I do not have the operating system installation CD so i have to try to fix the problem without using a backup media (the machine does not have cd or floppy reader or anything else except a usb interface).
I am new to this system i wonder if anyone could help !

The first thing to try, is booting to a different kernel.

Use the “Advanced” menu in grub. That should give you a submenu where you can pick which kernel to boot.

If none of the available kernels boot, then you will need rescue media. If there’s a kernel that can boot, that will make it easier to fix the problem.

Are you sure? I cannot recall the existence of any such option in Grub Legacy, which I’m still using on all my non-UEFI systems.

Thank you for replying. Unfortunately there is no advanced menu in the version of grub i am dealing with.

Thank you for your post…
Actually there is one file called /vmlinuz-2.4.21-99-default i can find using find command on (hd0,0) partition. But the /vmlinuz file needed can not be found ! And i think it is the missing file…
Any ideas ?

Apart from the fact that you use legacy Grub (of which you already found out that so few people use it that they mentaly skipped you mentioning it), I am afraid you did not tell much abut how you reached the present situation.

How can it be possible that yesterday you were able to boot the system and today the “kernel file can not be found”?
I assume you owe us an explanation here, to be sure that people can help you with as much background information as possible.

There should be a symbolic link from vmlinuz to the actual to be used file. Thus when you have only one, there is only one possible symbolic link to be made.

But again, it is important to understand how/why you lost that link. Else it might happen again tomorrow, or the week after, or …

That 2.4.21 kernel is what SUSE 9.0 used 16 years ago, not openSUSE 15.0. Is your failure really an openSUSE 15.0 system? As hcvv indicated, we really need more information to be of any serious help to you.

SUSE and openSUSE normally create vmlinuz as a symlink to the most recently installed versioned vmlinux-#.##.###. There should be more than one bootloader menu selection available, one using vmlinuz, another using a versioned vmlinuz-…

Hello and thank you for replying;
Actually i am not quite sure of what i did, i am totally new to all this. I messed up things when i was trying to solve an other problem on the server that was not able to communicate properly with an other device connected to it via LVDS link and i ended loosing the entire operating system boot. I remember i entered to BIOS to check that the LVDS card is correctly “declared” but that was the wrong thing i did.

Thank you for your answer.
The operating system is not open suse linux but i do not know what exactly is. I have the possiblity to take the hard disk and use an adapter to try to explore its content using my laptop. Is there any hope to find the missing file using this tip ?

If you can boot any live media, collect output from bootinfoscript and share it via the susepaste command or any of the conventional pastebins, e.g., then someone here may be able to spot a solution for you. As it is you haven’t provided enough information to work from.

Then, why do you

  • go to the openSUSE forums?
  • choose LEAP 15.0 from the prefix list?
  • do not explain anything about what you have and do?

People here are volunteers and spend their spare time in trying to help other openSUSE users. They expect those who have problems/questions to be honest and to explain as much as possible about what ant details that might be relevant to a problem and not to post riddles. When not, people will simply stop taking you serious and stop posting and spending their time in helping more cooperative persons.

Oops. I missed the “grub legacy” part.

It’s around 9 years since I last used grub legacy.

Good morning;
I am so sorry for not being able to provide enough information about the problem. I thought that it was only a matter of a missing command or something like that, and i didn’t imagine that the issue needs accurate information to be analysed and solved, otherwise i would solved it by myself.
My error was to enter to a professional Linux forum without having basics in this operating system.
I apologize for waisting your time and i thank you for your candidness.

Your apologizes are accepted of course.
Indeed we are not professional, at least not while we are trying to help in these forums, but many did or do have professional backgrounds in Unix/Linux (which is of course fantastic). And we still might be able to help you if you do not expect us to be claivoyant ;).

IMHO you already got a rather adequate answer to your direct problem: create that symbolic link. When you do not know how to do it: ask.

When you do not know at all what type of Linux (and what version) you have, again we can help you to find out. You only have to tell the few things you know and to ask how to find out more.

The only thing is your bad start by assuming others will know more about your system then you know without giving them the slightest part of information. People will try to help you, but you only must see the restrictions forced on all of us by not being at your place and not being able to look over your shoulder.