Boot issue finishing in recovery mode : kde+Wayland dead

I did a update this morning, last update was 3 days ago.

I saw that many updates came for libqt6 and now the system terminate booting in recovery mode, no more KDE with Wayland starting.

What can I do?

This is a bit confusing.

Do you mean “recovery mode”, or do you mean that it boots, but does not start the GUI login?

The console during boot show recovery mode and ask to enter super user password

Finally, it is really Wayland that does not seems to start since libqt6 update, I solved the problem of recovery mode at boot because I removed a disk thinking it was the initial root cause.

But I have a black screen with mouse pointer but nothing else, KDE not started.

How can I revert the last updates?

How can I switch from KDE Wayland to KDE xorg ?

If you use btrfs, you could rollback to a previous snapshot. Otherwise you could use history repositories to force downgrade. Installing tumbleweed-cli package provides convenient command tumbleweed that can be used to switch between these repositories.

On the login screen, you move the checkbox for session type from Plasma Wayland to Plasma X11 before typing your password.

I don’t have windows manager working, black screen with mouse pointer, KDE is not shown, juste X server

i did a rollback btrfs and the system is working but how to know when the problem will be solved in the next update ?

KDE or Wayland, i don’t know which one is broken with the last updates of libqt6 ?!

Finally the auto login DE used is KDE(X11), so it is problem KDE that is broken by some update but i don’t know which one in the last updates, perhaps libqt6 ?!

I just finished a TW/Xorg/SDDM/Plasma dup to 20231005. Everything tried so far is working as expected:

# inxi -C
CPU:
  Info: single core model: Intel Pentium 4 bits: 64 type: MT cache: L2: 2 MiB
  Speed (MHz): avg: 3200 min/max: N/A cores: 1: 3200 2: 3200
# pinxi -GSaz --vs --zl --hostname
pinxi 3.3.30-05 (2023-09-29)
System:
  Host: g5eas Kernel: 6.4.12-1-default arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1 clocksource: tsc available: hpet,acpi_pm
    parameters: root=LABEL=<filter> ipv6.disable=1 net.ifnames=0 noresume
    consoleblank=0 preempt=full mitigations=off
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 7
    dm: SDDM Distro: openSUSE Tumbleweed 20231005
Graphics:
  Device-1: NVIDIA G98 [GeForce 8400 GS Rev. 2] vendor: PNY driver: nouveau
    v: kernel non-free: series: 340.xx status: legacy (EOL) last:
    release: 340.108 kernel: 5.4 xorg: 1.20 arch: Tesla process: 40-80nm
    built: 2006-13 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 link-max: lanes: 16
    ports: active: DVI-I-1,VGA-1 empty: none bus-ID: 0b:00.0
    chip-ID: 10de:06e4 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting unloaded: fbdev,vesa alternate: nouveau,nv,nvidia
    dri: nouveau gpu: nouveau display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3600x1200 s-dpi: 120 s-size: 762x254mm (30.00x10.00")
    s-diag: 803mm (31.62")
  Monitor-1: DVI-I-1 pos: primary,left model: NEC EA243WM serial: <filter>
    built: 2011 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 519x324mm (20.43x12.76") diag: 612mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 640x480
  Monitor-2: VGA-1 pos: right model: Dell P2213 serial: <filter> built: 2012
    res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2 size: 473x296mm (18.62x11.65")
    diag: 558mm (22") ratio: 16:10 modes: max: 1680x1050 min: 720x400
  API: EGL v: 1.5 hw: drv: nvidia nouveau platforms: device: 0 egl: 1.4
    drv: nouveau device: 1 drv: swrast gbm: egl: 1.4 drv: nouveau surfaceless:
    egl: 1.4 drv: nouveau x11: egl: 1.4 drv: nouveau inactive: wayland
  API: OpenGL v: 4.5 compat-v: 3.3 vendor: mesa v: 23.2.1 glx-v: 1.4
    direct-render: yes renderer: NV98 device-ID: 10de:06e4 memory: 483.4 MiB
    unified: no
  API: Vulkan Message: No Vulkan data available.
#