Boot issue after installing updates to 11.2 (x11failsafe)

Hello all!

Would really appreciate your help on this…

Hardware: Gateway LT3103u netbook, integrated Radeon X1200

  1. Installed openSUSE 11.2… and it worked fine for a few days.

  2. The software-update installed 53 updates and now the login hangs after I enter the user name and password unless I boot with “x11failsafe” (all other boot parameters are normal, not failsafe)

  3. Performed format and fresh install, again works fine until i perform a software update, the have the same problem (tried this twice).

  4. I have tried the following suggestion as root:

init 3
sax2 -r -m 0=radeon
init 5

Sax2 recognized my video card and configured it without error but this did not solve the problem.

So… I still can only login with x11failsafe added to the GRUB options.

What should I try next?

Thanks in advance, Spence

Have a look here
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Thanks for the link… I retried the procedure to have sax2 generate xorg.conf using the correct, radeonhd driver… no change.

A few key points:

  1. Graphics driver (radeonhd) and everything else in 11.2 worked fine before the autoupdate

  2. The system hangs after login. My desktop background is correctly displayed (a custom image). In fact, a bubble even appears indicating a network connection; but there is no task bar or any other icons. The mouse moves, but I cannot get any function through clicking or keystroke.

  3. starting by adding “x11failsafe” fixes this problem, but then the monitor resolution is not optimal.

Thanks for your continued help!!!

Best regards, Spence

Did you originally install a driver for your ATI?

No… I didn’t even have the xorg.conf file. The 11.2 installer correctly identified the radeon integrated chip and everything fine until the update. On the third clean install, i delayed using the software update for a few days, during which all was fine. As soon as I updated, i had the problem again.

I think that you are getting at the fact that if the kernel was updated that i would need to recompile the custom ATI driver and regenerate xorg.conf with aticonfig… but that was not the problem since i was using the driver installed by the 11.2 installer.

Thanks again for all the help! Much apreciated!

Regards, Spence

Try rolling back the kernel
If you don’t know how, I’ll walk you thru it

A walk through or link to instructions on rolling back the kernel would be fantastic!

Thanks, Spence lol!

Open Yast Software Management and search for kernel

See this image and](
using the versions tab select the older version of the kernel

I suspect all the rest will auto switch - but just check.

You may not have the kernel-source or devel installed though :slight_smile:

The OP did not mention the desktop type KDE or Gnome. It could be the bug that hit a lot of Gnome desktops.