BOOT & Grub problem after I apparently fubar’d something - NO Grub menu on boot

Sorry I can’t give images, every thing was done in tty mode, but here goes.
This is on my legacy HP Compaq CMT7700 desktop.

FIRST OFF I DELETED ALL PARTITIONS ON A GOOD HDD(it had lmde on it) and installed Leap on it.
I FORGOT TO DO THE ‘grub2-mkconfig’ routine!
So when booting it got to one of those time limit thing looking for a /dev/disk that no longer existed in grub!

So I think I messed up Grub2.

  • got to the point nothing would boot, not even Win7.
  • I put in the install usb & went to the Rescue Menu, and logged in as root.
  • ‘fdisk -l’ showed all my systems, so they are there.
  • I noticed that the boot flag on the Win7/Leap was on the Win7 partition.
  • right or wrong, I set it to the ‘system reserve’ partition
  • I can now boot into Win7 ONLY - YEP that should have been expected!
  • my windows partition manager shows ALL of the systems, so again they are there!

go back to Leap USB rescue mode and move the boot flag to Leap root partition?
OR do a grub2 REINSTALL from within Windows?

PS> I found some old opensuse articles that have walkthroughs for reinstalling Grub in winXP(still good today?)

I don’t get it. You say you installed Leap on an empty disk and then you say “… nothing would boot, not even Win7.”
That looks logical to me, when there is only Leap, it can not boot into Windows 7 or any other OS.

Sorry to have confused you, AGAIN!!
yes, I installed leap on an empty drive. BUT that drive previously had lmde Linux on it. After deleting the ldme partitions I forgot to run the grub2-mkconfig to clean up grub.
When went to boot after the new install boot process stopped at a place it was look8ng for in grub THAT no longer existed, and threw me into emergency mode.

i assume by not cleaning up grub after NOT doing the grub2-mkconfig, I messed it up and somehow got the HDD that has Leap AND Win7 on it!

All I’m asking is can I ‘REPAIR’ grub2 in Win7 since that is the only OS that boots.

To get it down to nuts and bolts, ALL THREE drives are there. ALL three drives have what they are supposed to have but I can’t access them!! I just need help figuring out how to unscrew my screw up!

At the, indeed bewildering to me again, story above, you, out of the blue, talk about THREE disks. That comes as a complete surprise to me.

Wouldn’t it be better for the communication with the non-clairvoyant people here, to tell exactly how your system looks. Specially about the disks, what is (supposed) to be on them, etc.

I hope you are used now to commands like

fdisk -l

and or

lsblk -f

Tose are the things others understand.

And I also do not understand why you keep talking about that lmde Linux that once was on that disk. You started with an “empty” partition table, so it is no longer there, gone, removed, vanished.

Grub probably is looking for the deleted partition.
You will see the messages while booting Leap.

If you can go to your /etc/fstab you can remove the deleted partition’s entry
if it is still there save and reboot leap.

You need to clean up both the the EFI boot partition which may have files pointing to non existent partitions. Also the UEFI boot table may require similar care since you need to tell the computer what is new and what is gone. It reall does not anything unless you tell it.

Then the problem also could be the formatting of the drive and and boot method selected on install.

Mostly overview, as you’ve gone through this before:

  1. Boot any linux installation, live or rescue media
  2. Mount and chroot to the newly installed 15.3
  3. Make GRUB_DISTRIBUTOR= in /etc/default/grub something unique, using only alphanumerics; e.g. os153may22 or opensuse153. This is optional on MBR systems, necessary on UEFI systems booting in UEFI mode.
    *]Run YaST bootloader, making sure all is as it should be, but ensuring something gets changed, to ensure YaST will write out everything. ±1 second to timeout will do it if you made no other changes.

Did all that, except, I could not run YaST in the Leap rescue system.
I’ve (somehow) managed to get grub menu on boot now, BUT each Leap selection still gets to a point where it is constantly ycling through a line searching for a /dev/disk/(followed by a uuid) that I haven’t written down yet.

The on live Linux live USB is for lmde(Linux mint Debian). Tried that, it is what got the grub menu back.
Alas, none of the Leap installs will boot past that /dev/disk(………) thing.
Thanks for your response.

The machine is legacy(mbr ?) not UEFI.

Ya sure! I know all that. But hard to do fdisk -l & lsblk from an OS that won”t boot.

Oddly, I got the ‘new’ leap install working.(I don’t know how, so don’t ask)

looking at /dev/fstab for both other disks, there was an entry for a UUID @ /user/local, that did not exist.
& removed them, I ran the grub2-mkconfig routine, and the YaST bootbloader.

i did a few things in lmde & and finished in the one leap that booted.

so thanks to users mrmazda & conram, things are looking up.

Do you have any idea why that was?