Boot failure. OpenSuSE 13.1 64b cannot find /dev/mapper/pdc_cbbaifafid_part7

I did a reset and now the system will not reboot.

The display indicates:

Waiting for device /dev/mapper/pdc_cbbaifafid-part7 to appear: …
Could not find /dev/mapper/pdc_cbbaifafid-part7.
Want me to fall back to /dev/mapper/pdc_cbbaifafid-part7? (Y/n)

Any ideas?


I have the same problem.

Did you find some solution?

That looks like a partition is no longer present or is broken

yep. almost exactly.

it was happened after online udate and reboot.

system is installed on RAID and probably some updated package dealed with RAID is broken.
partition(s) is ok, but is not visible correctly on boot.

have anybody any ideas how to fix this issue and run system?

Title says pdc_cbbaifafid**_part7 (underscore before “part7”) while in text you say pdc_cbbaifafid-**part7 (minus before “part7”). I tried to simulate it in VM and I can reproduce the problem if variant with underscore is used for root name. So - what exactly do you have? Photo of screen would be helpful.

I probably have a typo with the title or the error message listed. I wish I could have done a cut and paste. Since this is a boot problem, there is no way to actually accomplish that task.

Since this is a boot problem, the only way to do a screen shot is with a camera and camera shots of screens typically don’t look very good.

Someone in this thread suggested that the RAID software might be broken. At one point, I thought my drive was broken. Out of curiosity, I removed one of the drives and tried rebooting. Same problem.

My solution was to re-install the OS. Fortunately, the partition that failed contains just OS info so I didn’t loose any data.

Note below: This is not the first time I’ve posted this problem. The problem seems to be new to the 64 bit version of 13.1. My 32 bit version has not encountered this problem.

I have found some solution.

As arvidjaar sad, there problem is in “underscore” and “minus” in partition name.

This issue is located somwhere in grub2 package.

On reboot in grub menu I press “e” to edit menu item(s), change “underscore” to “minus” before part* of selected item and press F10 to boot.

System was booted normaly and I change all insuffisient “underscores” to “minuses” in /boot/grub2/grub.cfg

All changes will be lost on next grub2 configuration utility run/save untill this bag will be fixed.
i.e. after using grub2 configuration utility make manual changes (“underscores”) in /boot/grub2/grub.cfg before reboot!!!

This issue has nothing to do with grub2. Please post your /etc/fstab and /etc/default/grub.

In /boot/grub2/grub.cfg partition /dev/disk/by-id/raid-ddf1_Main-part3 is presented as /dev/disk/by-id/raid-ddf1_Main_part3
This issue is reprodused only for raid.
I am using GUI tool for Partition management - /sbin/yast2 disk

My /etc/fstab

/dev/disk/by-id/raid-ddf1_Main-part2 swap swap defaults 0 0
/dev/disk/by-id/raid-ddf1_Main-part3 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/raid-ddf1_Main-part1 /boot ext4 acl,user_xattr 1 2
/dev/disk/by-id/ata-ST3250620AS_5QE3HVDP-part1 /ext ext3 defaults 1 2

My /etc/default/grub

Modified by YaST2. Last modification on Sat Mar 15 14:34:40 MSK 2014


For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of

flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

If you change this file, run ‘grub2-mkconfig -o /boot/grub2/grub.cfg’ afterwards to update


GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-id/raid-ddf1_Main-part2 splash=silent quiet showopts"

kernel command line options for failsafe mode

GRUB_CMDLINE_LINUX_RECOVERY=“showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_c
state=1 nomodeset x11failsafe”

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD …)


Uncomment to disable graphical terminal (grub-pc only)


The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo’


Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to Linux


Uncomment to disable generation of recovery mode menu entries


Uncomment to get a beep at grub start

#GRUB_INIT_TUNE=“480 440 1”

Skip 30_os-prober if you experienced very slow in probing them

WARNING foregin OS menu entries will be lost if set true here


You need to report this info on bugzilla

Please, open bug report, attach grub.cfg, /etc/fstab and /proc/self/mountinfo. Post number here. Thank you.

P.S. strictly speaking it is kpartx bug - it has to include udev rule to create _ variant in initrd. grub2 likely picks the first link it finds (and it is not clear which one should it prefer if there are multiple links).

Compat rules for creating _ variants cause other issues as well (cf.

This ugly problem has re-emerged after the latest kernel upgrade. Is there a reloaded 13.1 version available?

The problem appears to reproducible.
Reinstalling the OS.
Go into YaST Software Management. Upgrade the kernel. Reboot. Here is what you likely get:

RAID set “pdc_cbbaifaifid” was activated
RAID set “pdc_cbbaifaifid” was not activated
Trying manual resume from /dev/disk/by-id/raid-pdc_cbbaifaifid-part6
resume: libgcrypt version: 1.5.3
Trying manual resume from /dev/disk/by-id/raid-pdc_cbbaifaifid-part6
Waiting for device /dev/mapper/raid-pdc_cbbaifaifid-part7 to appear: … could not find raid-pdc_cbbaifaifid-part7
Want me to fall back to /dev/disk/by-id/raid-pdc_cbbaifaifid-part7

It appears that Grub boots from MBR, located in pdc_cbbaifaifid-part7. /boot is located in pdc_cbbaifaifid-part6.
If I install the OS disabling MBR and enabling /boot, the installation fails to boot for initialization.

This is such a waste of time.

I’m not quite sure of the question.

If you use the DVD to install, and have a wired connection during install, then there’s an install option to add online repos during the install. If you add the update repo, your initial install will have most updates, including the most recent kernel.

Trying manual resume from /dev/disk/by-id/raid-pdc_cbbaifaifid-part6

Usually, the swap device is configured for resume. Unless you hibernated on the last shutdown, it won’t find anything there.

Waiting for device /dev/mapper/raid-pdc_cbbaifaifid-part7 to appear: … could not find raid-pdc_cbbaifaifid-part7

A mapped file system is supposed to be mapped by the “initrd”. So it is looking as if you are getting a bad “initrd” except during install.

My suggestion:

Boot from the install DVD (in repair mode).

Do whatever RAID magic is needed to access your partitions.

Mount the root file system on “/mnt”. Mount any other file systems on top of that.

# mount --bind /dev /mnt/dev
# mount --bind /proc /mnt/proc
# mount --bind /sys /mnt/sys
# mkinitrd /mnt

Note: I have never tried doing that. It is supposed to be using the “mkinitrd” from the DVD to create an “initrd” for your system. That should give about the same result as you get with an install.

I don’t know if it will work, but it is worth trying.

Didn’t think to use a wired connection. Thank goodness I saved my 30 meter Ethernet cable. I guess everyone limited to a wireless connection is beyond hope.

That’s only a problem if you really need an online repo during the install.

Another alternative is to use the NET install CD, which does have the ability to properly configure wireless to access repos.

I reinstalled, using the wired internet connection. It installed all the latest updates, as expected. On Friday, the updater indicated there were three new updates. After installing, the pdc_cbbaifafid_part7 error recurred, so I’m back to square one.
I can’t be the only person in the world with this problem.

I have some vague ideas … please, when you reboot your system, in GRUB menu start editing menu entry (press ‘e’ character when menu entry is selected). In a window that opens scroll down to line that starts with “linux”. Do you have this string (pdc_cbbaifafid_part7) anywhere on this line? If possible, make a photo of this screen.

I’m not sure how to edit at the Grub menu at start up. Grub flash for a moment, then it goes straight to the opensuse 13.1 screen.

Did you change the timeout? should give you about 7 sec if set normally

Pressing any key should stop the boot assuming you did not reduce the boot timeout to 0

Note that the welcome to grub message is just that the menu that comes next is grub