Boot failure on authentication manager after system or softwares updates

:(Hello everyone,

For several months, I can no longer do software updates or migrate to a higher version of the operating system such as LEAP 15.3 of my OpenSuSE LEAP 15.2 system. Each time, the updates work well but each time I restart, I have an error on the Authentication Manager and other daemons such as Virtual Manager and I cannot access the login page and enter the system. The only solution I have left is to restart on the snapper session to return to the session before the update. I never found the right solution on the web to solve the problem, and I found and tried many without any success. I even tried to migrate to LEAP 15.3 but the installation process failed towards the end with no possibility to boot the system. The operational solution is the same as for the problem on software updates.

My system is an HP Z400 station with 2 x 8 core CPUs, 24 GB of RAM and 1.3 TB of disk.

I am an advanced Linux user but not an expert, and your help will be of great help to me.

Thank you very much for your help, support and understanding.

Faithfully Yours,

Eric Ersilio

Are you sure about the “work well” part? For zypper upgrading from 15.2 to 15.3, a simple zypper dup is insufficient. The dup process adds required additional repos. So, the dup must be immediately followed with a refresh and an update, to get the whole system up to date. Optionally, immediately before upgrading, add the two new repos manually, by saving these two small repo files to /etc/zypp/repos.d/:
Having those in place first will make the upgrade a one-step process.

HI mrmazda,

Thank you for your answer, which I will test as soon as possible.

But when I said updates are working fine, I was only talking about software updates.

For the migrations, I didn’t run a simple zipper, I used the different methods, described either in the documentation or on the web, and each of them all failed.

As I said before, I will try your method and let you know if it solved my problem.

Thanks again for your reply.

faithfully yours,

Eric Ersilio