Boot failure after security updates

Security updates after upgrade, killed system.

Specifically, system won’t boot using 5.3.18-150300.59.43 unless I use the “safe-mode” selection. Works OK 5.3.18-59.40-default kernel.

Screen goes dark after ramdisk loads, both monitor loose signal and no activity on harddrive after a few seconds.

Troubleshooting / Remediation Steps

  1. Using [AMD/ATI] RS780L [Radeon 3000] card, so suspected Bug 1195142


  • mkdir /lib/modules/5.3.18-*.43-default/updates

cp /lib/modules/5.3.18-.40-default/kernel/drivers/gpu/drm/radeon/radeon.ko /lib/modules/5.3.18-*.43-default/updates/

depmod 5.3.18-150300.59.43-default


This didn’t seem to change anything.

  1. Removed quiet boot options and add debug, I see lots of boot-up activity and screen then goes black after about a minute. No red flags or errors that I could see, it just goes dark at 66 seconds. There is some radeon messages ~57 seconds, but no errors that I could see. Used cell phone to record scrolling and captured last frame before darkness.


I hate to run with an unpacked system, but I’m not sure how to get around this.

I welcome any suggestions on how to isolate or remediate the problem. Thanks in advance.

Don’t you still have the 59.40 kernel installed to boot from?

I only tried those bug instructions for one installation, though not exactly. Instead of to updates I copied over the original. After that one I’ve been installing the kernel from here instead of messing with the bad one. On my main installation I’m still running on 59.37.

Yes, I can boot to the old kernel, which is what I’m doing now. I just wanted to know the root cause so I can see when it’s resolved and keep up with patches.

I’m having the same problem. Now booting from 5.3.18-59-37. Are you saying that 5.3.18-150300.59.43 is from a bad repository? How to recover?

This is the only weirdo I found in Yast:$releasever/

I just now replaced it with:

Am I supposed to be using All the others use the same base:

It’s an option. It contains patches that are not in the 59.43 kernel, including one that solves the black screen problem with radeon GPUs.

There’s “me too” here. Following for resolution.

Although the work-around didn’t fix my problem, the Kernel update to 5.3.18-150300.59.46 did. :slight_smile: Problem resolved.

The current kernal that actually works likes like something from “Farscape.” Here’s my Kinfo:

Operating System: openSUSE Leap 15.3
KDE Plasma Version: 5.18.6
KDE Frameworks Version: 5.76.0
Qt Version: 5.12.7
Kernel Version: 5.3.18-150300.257.g6971cec-default
OS Type: 64-bit
Processors: 6 × AMD FX™-6100 Six-Core Processor
Memory: 11.4 GiB of RAM

I included the OSS debug repositories on my last update.

The actual problem should be resolved with the new kernel from Leap 15.3 by updating.

I suppose ‘works likes like something from “Farscape”’ refers to the long string of alphanumerics in the version. That’s normal for devel kernels. Their version strings get reduced when they become release kernels. You have the option of installing .59.46 now from current mirrors and keeping or removing 5.3.18-150300.257.g6971cec, or just keeping 5.3.18-150300.257.g6971cec and waiting to install whatever version follows .59.46 in 4-10 weeks.

5.3.18-150300.259.g3367546-default is unstable: The graphics / monitor completely cuts out randomly in the middle of a session as if going into monitor power save mode. When this happens, the system does not respond to the reset button. I must power off.

However, 5.3.18-150300.257.g6971cec-default is stable at this point. I should have stayed with this kernal because the previous stable kernal is now unavailable.

That are no Leap 15.3 kernels.

Do you try the latest from Leap:

zypper se -s kernel-default | grep -i 5.3
v  | kernel-default                 | Paket      | 5.3.18-150300.59.49.1                | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
v  | kernel-default                 | Paket      | 5.3.18-150300.59.46.1                | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
v  | kernel-default                 | Paket      | 5.3.18-150300.59.43.1                | x86_64 | Update 

If anyone still has the repo enabled, it’s time to disable it, and install the latest kernel from updates: 5.3.18-150300.59.49.1

For some reason, my OSS 15.3 only wants to update the kernal from the above repository. I would like to find out why. Where is the preferred repository for kernal updates? Thanks in advance.

This is due to vendor stickiness, and perhaps repo priority.

Use Yast Software Management. Search for “kernel-default”. Then click on the “Versions” tab. You should be able to select the version you want. The current kernel version is “5.3.18-150300.59.54.1”.

You can also de-select any kernel you don’t want, as a way of removing that kernel.

Auto-updates is always giving me this error message: “There is no update candidate for kernel-default-extra-5.3.18-150300.259.1.g3367546.x86_64” So I have been updating the kernel in Yast. Is there a safe way to get that troubled kernel out of the way, so auto-updates can proceed error free? Thanks in advance.

I installed 5.3.18-150300.59.63.1 just a bit ago.