Boot failure after motherboard replacement

Hello all,

I just had my mothrboard replaced on my laptop which had a perfectly functioning openSuse Leap 15.2 installation. And now, the laptop will not boot. It does go through the bootloader phase, so I can select the OS to boot, but after that, it gets stuck for about a minute, then displays two lines with messages like:

Warning: /dev/disk/by-uuid/XXXXXX does not exist

then it enters emergency mode, where I just don’t know what to do.

I’ve looked at dozens of websites giving “solutions” for this kind of problem, but nothing worked: either they relied on commands that I don’t seem to have, or they ask to do something that doesn’t give any result on my PC.

I still have the USB stick from which I installed the distro, so I also tried a “Rescue system”, but again, I’m completely over my head here, I just don’t know what to do. I did have a similar problem a few years ago, and I think I remember I managed to access the existing disks and fix the problem, but here, I can’t even get to see the existing disks. Maybe there are some BIOS options that I haven’t got right - of course, the motherboard replacement reset everything to the default -, but I just can’t find out what it is.

If anybody had any idea about I can fix this issue, that would be awesome.


It’s possible that, the new Motherboard has caused the UUID value of the disk to change.

Then, you’ll have to list the ‘/dev/disk/by-uuid/’ directory to find the new UUIDs of the disk partitions.

  • Edit ‘/etc/fstab’ to correct the UUID values being used.

Alternatively, you can temporarily replace the UUID values by the device values – /dev/sd?? – and then revert to the UUID values when the box has booted.

  • Currently, mounting by means of UUID values is considered to be more reliable than mounting by means of device values.

This was exactly what I feared, but I had another issue:

This is what wasn’t working: when I went into ‘Rescue system’ from the installation USB stick, the only disks listed here where the ones for the USB stick itself, I couldn’t see any other one.

I finally dived into the hundreds of BIOS options and found one regarding the disks that had a strange value (something about ‘RAID 0’, that I don’t use at all). I changed it to another value that seemed more appropriate, and that was it: apparently, the disks are not made visible by default, you have to tweak this setting to make them work correctly. :rolleyes: The UUIDs actually hadn’t even changed, the disks simply weren’t visible…

Anyway, thanks for your answer!

Hopefully, something like AHCI – given that, the parameter was located in the SATA configuration …

  • On the other hand, you seem to have a strange Mainboard –
    *=2]If it was setup at the factory to have a default “RAID 0” configuration, it should have asked for a RAID setup at the first boot …

Default setting for laptop disk controllers is fake “RAID” mode.
With Linux user needs to disable this mode by selecting “AHCI”.