Boot failure after clean install

Installed 42.2 from USB DVD onto Acer notebook. Text only version. No errors occurred. But when I try to boot it tells me there is no bootable media. I can boot SuperGrub2 from a USB stick and start 42.2 but various attempts to update the bootloader had no effect. The following is information that’s available:-

                  Boot Info Script 0.61      [1 April 2012]

============================= Boot Info Summary: ===============================

 => No boot loader is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/opensuse/grubx64.efi /efi/ubuntu/MokManager.efi 
                       /efi/ubuntu/fwupx64.efi /efi/ubuntu/grubx64.efi 

sda2: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Welcome to openSUSE Leap 42.2 - 
                       Kernel ().
    Boot files:        /boot/grub2/grub.cfg /etc/fstab

sda3: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

sda4: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________
Disk /dev/sda: 298.1 GiB, 320072933376 bytes, 625142448 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1                   1   625,142,447   625,142,447  ee GPT

GUID Partition Table detected.

Partition    Start Sector    End Sector  # of Sectors System
/dev/sda1           2,048     1,050,623     1,048,576 EFI System partition
/dev/sda2       1,050,624    22,040,575    20,989,952 Data partition (Windows/Linux)
/dev/sda3     616,980,480   625,141,759     8,161,280 Swap partition (Linux)
/dev/sda4      22,040,576   616,980,479   594,939,904 Data partition (Windows/Linux)

"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/sda1        5271-00FD                              vfat       
/dev/sda2        b2fbdc73-3f6f-4252-9c6b-c2dc9cc1adef   ext4       
/dev/sda3        51a75dcc-7b0a-4597-bbd7-1732909cb4b0   swap       
/dev/sda4        dc47707d-57c2-4816-ad6e-e56cf0d78df3   ext4       

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/sda1        /boot/efi                vfat       (rw,relatime,fmask=0002,dmask=0002,allow_utime=0020,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
/dev/sda2        /                        ext4       (rw,relatime,data=ordered)
/dev/sda4        /home                    ext4       (rw,relatime,data=ordered)

I must have formatted the drive incorrectly. Any suggestions would appreciated.

Are you trying to boot in legacy mode? Your install is EFI boot

Also looks like you had ubuntu since yo have leftovers in EFI boot.

Can you use the EFI boot selector??

Maybe the UEFI is trying to boot Ubuntu

there is a common problem with some models of ACERs “supervisor password” and BIOS upgrades sometimes required. you can see some of the issues on this thread you should give the exact model number, bios version. i dont believe installing mbr if it is eufi is a good idea.