Boot fails late in process - console works however

Hi and thanks for reading this - any support is appreciated.

After a system crash, SuSE 41.1 fails to boot if I use the default target. Boot stops just before ttys are initialized. No warnings are visible on screen.
System is still running, though - if I try to reboot using ctrl-alt-del, some shutdown messages are flashing across the screen.
If I boot into RL 3, however, all is fine: I can login as root and start kdm via “init 5”. System runs stable then.

I already fscked the disk, reinstalled systemd and grub - no joy.

Any ideas, how to write some debug output to disk to find out what is blocking the boot?

Thanks and BR
Holger

Boot stops here:


 OK ] Reached target Basic System
      Starting Machine Check Exception Logging Daemon...
      Starting Login and scanning of iSCSI devices...
      Starting Save/Restore Sound Card State...

Compare that to a successful boot into runlevel 3


  OK  ] Reached target Basic System.
         Starting Machine Check Exception Logging Daemon...
  OK  ] Started Machine Check Exception Logging Daemon.
         Starting D-Bus System Message Bus...
  OK  ] Started D-Bus System Message Bus.
         Starting Avahi mDNS/DNS-SD Stack...
         Starting Permit User Sessions...
         Starting Name Service Cache Daemon...
         Starting Initialize hardware monitoring sensors...
         Starting irqbalance daemon...
  OK  ] Started irqbalance daemon.
         Starting Modem Manager...
         Starting Self Monitoring and Reporting Technology (SMART) Daemon...
  OK  ] Started Self Monitoring and Reporting Technology (SMART) Daemon.
         Starting /etc/init.d/boot.local Compatibility...
         Starting SuSEfirewall2 phase 1...
         Starting Save/Restore Sound Card State...
  OK  ] Started Permit User Sessions.
  OK  ] Started Name Service Cache Daemon.
  OK  ] Started /etc/init.d/boot.local Compatibility.
  OK  ] Started Save/Restore Sound Card State.
  OK  ] Started Avahi mDNS/DNS-SD Stack.
  OK  ] Reached target User and Group Name Lookups.
         Starting Login Service...
  OK  ] Reached target Host and Network Name Lookups.
         Starting Terminate Plymouth Boot Screen...
         Starting Wait for Plymouth Boot Screen to Quit...
  OK  ] Started Initialize hardware monitoring sensors.
  OK  ] Started Login Service.


Maybe blacklist the soundcard? How do I do that?

Thanks

Did you try the failsafe boot option on the Grub menu? What happens then?

Or, when the Grub menu shows, hit the “e” key, scroll down to the line that starts with “linux”, hit the END key to make certain you get to the end of that line, type a space, then type:

nomodeset

and press F10 to boot?

Hi Gerry,

thanks for the reply.
There is no “failsafe” entry in the GRUB menu - only an item with an old kernel which does not change anything.

I tried adding “nomodeset” to the kernel cmdline - didn’t change anything, however.

Any idea what I could try to better diagnose what in the boot process fails exactly?

Thanks and BR
Holger

Are you using the default btrfs root partition?
If so you could use “Advanced Options” from Grub to “boot from a read only snapshot”.

Poke around until you are comfortable it is working and then do a

sudo snapper rollback

to reinstate that snapshot.

If you run Snapper in Yast you might also be able to compare differences before/after the crash to see exactly what happened, but if it was caused by a crash while writing to disk then whatever was being written is probably what broke.
This does work in console/text mode. Just run Yast from one of the tty’s / console and the menus are much the same, albeit text based.

I’m using ext4 for the root partition - hoping that the journal will prevent most of the fs damage. Unfortunately that means that snapper will not help me here.
BR

This is when booting into graphical.target? Well, iSCSI is definitely unexpected here, it comes way too early before networking is initialized (although I also do not see Network Manager in successful boot), and it rather hangs here. Not sure how system crash could mess up unit definitions though. Do you actually have any iSCSI device? If not, try disabling this unit.

Thanks a lot for the suggestion. I deactivated all iscsi related units with systemctl. Boot no longer shows the iscsi line, but still freezes.
Puzzled…

BR
Holger

OK, nothing worked, so I reistalled the OS.
Works now.

Shame I was not able to troubleshoot and fix the issue.

BR