Boot fails: [Firmware Bug]: TSC ADJUST

Hi! I am new to these forums. I hope I can find some help for the issues I have with Leap.

I am using a Thinkpad with a Core i5 6200U, 8 GB RAM and a 256 GB SSD. I have done a fresh installation of Leap 15.3 the day it was released.
A few days ago, I let the system update and shut down the laptop. Until then, the system had been running perfectly.

The next day, I wanted to start the system. I got as far as the boot screen displaying the Leap logo in the bottom. After that, the system would fall back to a emergency terminal. As instructed, I logged in and tried the default options, but the system would take some time only to fall back to the same terminal.

I ran “journalctl -xb” multiple times, which would always give me lots of text in white and one line in orange:

leap kernel: [Firmware Bug]: TSC ADJUST: CPU0: -39856600 force to 0

I did some searching and my problem appears to be an issue between the kernel and the CPU. It appears TSC is some sort of time counter.
I found highly technical explainations of TSC, but nothing to help me (and I really don’t feel like learning x86 Assembler right now).
Any Live USB runs fine and so did Leap before it decided to update and kill itself. So it’s not a CPU defect. In fact, I am writing this post from the same laptop running from a Leap Live USB, which also works just fine.

Does anyone here know what is going on with my system and how to fix it?

It looks like the graphics system did not start.

So boot failed partially.

After logging in emergency mode, in the terminal, try to run



startx -- -verbose 5 -logverbose 5

If possible, read the log messages in file


Other possible reasons of dropping into emergency mode are unmountable partitions (dirty bit present?) and misconfigurations. Try to look into many log files. Most are in

  1. Try to load previous kernel.
  2. Try to update BIOS.