Boot fails after YAST 12.3 and driver updates today (5/15)


Running 12.3 (fully updated) and got an upgrade notification for 2 SUSE upgrades (one SSL and one security, I think). Also a large block of graphic drivers as well. Came back this afternoon and the system boot stalls - gets to something like ‘reach graphical interface’ and everything stops. Tried a few times with the same result - I am writing this on a recovery boot. If this is now a known problem, how do I recover from it (or back out whatever is seizing up the boot). If it is not known, what do I need to do to provide sufficient information to figure out the problem and then get it resolved. I am no super user…

Thanks and regards – Roger

I think your system booted, but the graphic desktop failed to start.

You will need to give more information, particularly about your graphics. You are possibly using proprietary drivers, and you may need to reinstall them.

Forgot to include that I am using Nvidia drivers and a Dell 2007WFP monitor. Since the stop point is at graphics, I guess that the problem is with the new Nvidia driver set (but again, no Linux guru).

Regards – Roger

Thanks for the reply. What additional information do you need about the drivers and hardware? I am getting the drivers from URL: set up in my repositories in YaST2. Given what you suggest is true, there was either a problem with the new drivers from Nvidia or install was bad.

Is it useful to download and install the same drivers, or go downlevel one (in case the new drivers have a bug). Can you point me to a tutorial on how to do this? I can see the drivers I have installed and a number of other programs (search Nvidia in installer) but not the downlevel drivers that the new ones replaced. Since the system worked just FINE with the prior drivers, going back to them would be just great. Any help on how to do this would be great.

Thanks – Roger

Went to the Nvidia site, and it looks like I am not alone - problems with the new drivers and no boot. I figured out how to delete the nvidia drivers, and then did the one-click install, and all is well.

Nvidia repository is now disabled, since I gather no new improvements for my card - only downside!!

Thanks and regards – Roger

Doubt it is a general bug, so it would be helpful to know what NVIDIA card

Can you boot to rescue mode. Hint select from advanced boot options


My card is a Nvidia GTX560Ti. On the Nvidia site there were a number of posts of people with different cards encoutering the same no-boot problem. The response I saw was to move to downlevel drivers since there are no performance mods to these ‘older’ cards. My card works fine with the older drivers, so that sounded like good advice…

I was able to access the system and reload the Nvidia drivers via the rescue mode - worked fine with a bit of distorted screen.

Regards – Roger

I had no problem bu have an old card (6800+) and use the GO2 version. Did have an update but I guess things are different enough.