Boot failed opensuse 15.4


I just installed opensuse 15.4. Everything went well but after I restarted my laptop, I got boot failed message.

If i boot using usb opensuse image and go to more and boot installed system, it works and opensuse runs well. Looks like it can not boot from ssd.

Any suggestion?

Thank you.

That’s a possibility. Maybe your BIOS cannot handle the SSD.

Is this UEFI booting, or is this traditional DOS booting?

Do you have a traditional hard drive, and can you use that for booting?

How old is your BIOS, when was the laptop new, and what form factor is your SSD?

Hi, thank for the reply.

Laptop is Lenovo x220, UEFI boot.
It used to run opensuse 15.2 with my old ssd. If i installed my old ssd with 15.2, it boots fine.

Thank you


It is 2.5 inch SSD, bios 2012. Not a new laptop, Lenovo x220.

Thank you.

If you can provide input/output from fdisk -l or parted -l from each SSD, a difference may become apparent. It could be that with the old you had installed in UEFI mode, and with the new MBR, but the BIOS is set to boot only UEFI.

Old ssd, which boots fine:

localhost:~> fdisk -l
Disk /dev/sda: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Disk model: Samsung SSD 840
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x1f64cd10

Device Boot Start End Sectors Size Id Type
/dev/sda1 2048 4208639 4206592 2G 82 Linux swap / Solaris
/dev/sda2 * 4208640 88100863 83892224 40G 83 Linux
/dev/sda3 88100864 500118191 412017328 196.5G 83 Linux

@localhost:~> parted -l
Model: ATA Samsung SSD 840 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 2155MB 2154MB primary linux-swap(v1) type=82
2 2155MB 45.1GB 43.0GB primary btrfs boot, type=83
3 45.1GB 256GB 211GB primary btrfs type=83

New SSD, it does nott boot:

@localhost:~> fdisk -l

Disk /dev/sda: 232.89 GiB, 250059350016 bytes, 488397168 sectors
Disk model: WDC WDS250G1B0A-
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 735EBB1B-65FE-496A-A075-056D1669222A

Device Start End Sectors Size Type
/dev/sda1 2048 18431 16384 8M BIOS boot
/dev/sda2 18432 182386687 182368256 87G Linux filesystem
/dev/sda3 182386688 484202495 301815808 143.9G Linux filesystem
/dev/sda4 484202496 488397134 4194639 2G Linux swap

@localhost:~> parted -l
Model: ATA WDC WDS250G1B0A- (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: pmbr_boot

Number Start End Size File system Name Flags
1 1049kB 9437kB 8389kB bios_grub
2 9437kB 93.4GB 93.4GB btrfs legacy_boot
3 93.4GB 248GB 155GB xfs
4 248GB 250GB 2148MB linux-swap(v1) swap

Sorry for the late reply. Thank you.

The old disk is a non-gpt (dos) and the new disk is gpt formatted.

I would start looking at the bios menus again to see if if the boot mode is dos (often called legacy) or UEFI.


Here is the bios setting:

UEFI/Legacy Boot [Both]

UEFI/Legacy Boot Priority. [Legacy First]

I tried to change both to legacy onlyb or uefi only, but still it does not boot.

Thank you.

Problem solved. I reinstall with dos format instead of gpt.

Thank you all.