BOOT ERROR si_restrict_performance_levels_before_switch failed AFTER VIDEO CARD UPGRADE

Hi

After swapping a Radeon HD4650 for an Ultimate R7 250, I get this error every time I boot:

ERROR si_restrict_performance_levels_before_switch failed

What does this mean? Most importantly, how can I get rid of this?

There was another error of Invalid VGA mode during GRUB boot where I had to change a parameter to VGA=3D4

No other changes to the system where made and I am fully up to date on OpenSUSE 13.2. I plan to change the
monitor too but I’m worried, that’s why I just changed one part at the time.

Thanks in advance,

The monitor was changed now and the error still persists. It is the last thing which appears upon booting before the desktop loads. Graphics seem
to be working most of the time but the screen freezes occasionally.

For some odd reason, I also see the error when rebooting or shutting down. It is possible the same instance just still displayed on the text console
or it could be that it happened again.

Also, the error still happens if I plug both screens simultaneously.

Any ideas? If you need more information to diagnose the problem, please let me know, as I don’t know where to start.

Thanks in advance,

  • Itai

Driver???

Hi,

Not sure if this is the number you are looking for this is what I have installed:

libdrm_radeon1 - 2.4.58-1.1
libdrm_radeon1-32bit - 2.4.58-1.1
libvdpau_radeonsi - 10.3.7-91.9.2

lspci -v returns this:


01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [Radeon HD 7750 / R7 250E] (prog-if 00 [VGA controller])
        Subsystem: PC Partner Limited / Sapphire Technology Device a001
        Flags: bus master, fast devsel, latency 0, IRQ 44
        Memory at d0000000 (64-bit, prefetchable) [size=256]
        Memory at fdd80000 (64-bit, non-prefetchable) [size=256]
        I/O ports at ee00 [size=256]
        [virtual] Expansion ROM at fdd00000 [disabled] [size=128]
        Capabilities: [48] Vendor Specific Information: Len=08 <?>
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Legacy Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Capabilities: [150] Advanced Error Reporting
        Capabilities: [200] #15
        Capabilities: [270] #19
        Kernel driver in use: radeon
        Kernel modules: radeon

dmesg says:


    5.622552] [drm] Initialized radeon 2.39.0 20080528 for 0000:01:00.0 on minor 0

Does any of this help? If not, let me know which command to run and I will post the output.

Thanks in advance,

  • Itai[/size][/size][/size][/size]

maybe try the proprietary AMD driver?

https://en.opensuse.org/AMD

It would be nice to have an other option but my new card is not yet on the supported list.

My older one was supported by both but worked much better with the open source drivers.

One though is that when changing cards, I didn’t do anything to the driver. Could there be something to do to select the new hardware?
It mostly worked automatically but maybe there is more to do.

Thanks!

  • Itai

nope if same Manufacture more or less the same drivers. Still try the AMD driver it is much more likely to work with cutting edge hardware then the OS radeon drive even if the card is not on some arbitrary list that may not have been updated forever.:open_mouth:

maybe try mkintrd tore set the systemd start-up code but that should not be needed but does not hurt

Great, thanks! The list was probably out of date.

The error is gone and only the splash-screen (I’m guessing it’s KDE generating it) is weird (flashes some question marks and then different
sizes and aspect-ratios) but everything works once the system is fully up. Could there something else to ‘reset’ so that startup takes into
account the new graphics card and screen?